Ask Your Question

Revision history [back]

Getting 'HTTP 500' while creating image in Glance

Hi Experts,

I have configured Glance configuration step by step as per Openstack Officical Document. In the last step I am getting error while trying to create image.. Please guide to trouble shhot the error.

@control images]# grep ^[^#] /etc/glance/glance-api.conf
[DEFAULT]
[DEFAULT]
rpc_backend = qpid
qpid_hostname = control
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone
[store_type_location_strategy]

@control images]# grep ^[^#] /etc/glance/glance-registry.conf
[DEFAULT]
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone

Created glance service point..

-------+
|                id                |   region  |        publicurl         |       internalurl        |          adminurl         |            service_id            |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+
| 006f674412154aa4bf13a84bd05d1f26 | regionOne |   http://control:9292    |   http://control:9292    |    http://control:9292    | c3c6b999f5cf4dfc871019f3a8fd1e8a |
| 977ff0c49dec4cf6873804edf3fa6e34 | regionOne | http://control:5000/v2.0 | http://control:5000/v2.0 | http://control:35357/v2.0 | 808ee4f6b8944fc9895f5fa52ad2327f |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+

Still I am getting below error,, Please let me know is there any value se for enviroment..

@control images]# glance --debug image-create --name "cirros-0.3.2-x86_64" --disk-format qcow2 --container-format bare --is-public True --progress < cirros-0.3.2-x86_64-disk.img
curl -i -X POST -H 'x-image-meta-container_format: bare' -H 'Transfer-Encoding: chunked' -H 'User-Agent: python-glanceclient' -H 'x-image-meta-size: 13167616' -H 'x-image-meta-is_public: True' -H 'X-Auth-Token: MIIFpAYJKoZIhvcNAQcCoIIFlTCCBZECAQExCTAHBgUrDgMCGjCCA-oGCSqGSIb3DQEHAaCCA+sEggPneyJhY2Nlc3MiOiB7InRva2VuIjogeyJpc3N1ZWRfYXQiOiAiMjAxNC0wOS0xNVQwNzowMzozNi4wNzY1MjQiLCAiZXhwaXJlcyI6ICIyMDE0LTA5LTE1VDA4OjAzOjM2WiIsICJpZCI6ICJwbGFjZWhvbGRlciIsICJ0ZW5hbnQiOiB7ImRlc2NyaXB0aW9uIjogIkFkbWluIFRlbmFudCIsICJlbmFibGVkIjogdHJ1ZSwgImlkIjogImY4Nzc5MjY4NmY0OTRhOTU5YzdjMzEyZWNiYTJmMjMzIiwgIm5hbWUiOiAiYWRtaW4ifX0sICJzZXJ2aWNlQ2F0YWxvZyI6IFt7ImVuZHBvaW50cyI6IFt7ImFkbWluVVJMIjogImh0dHA6Ly9jb250cm9sOjkyOTIiLCAicmVnaW9uIjogInJlZ2lvbk9uZSIsICJpbnRlcm5hbFVSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIiwgImlkIjogIjE5MDQ2YWZkNGY4NzQyMzhhMTdhY2E5ZjE0MGMyZTY1IiwgInB1YmxpY1VSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImltYWdlIiwgIm5hbWUiOiAiZ2xhbmNlIn0sIHsiZW5kcG9pbnRzIjogW3siYWRtaW5VUkwiOiAiaHR0cDovL2NvbnRyb2w6MzUzNTcvdjIuMCIsICJyZWdpb24iOiAicmVnaW9uT25lIiwgImludGVybmFsVVJMIjogImh0dHA6Ly9jb250cm9sOjUwMDAvdjIuMCIsICJpZCI6ICIwYTY5ZGI4MGU4OWY0OTQ4OWUxNWQzYjM4ZjY5ZmEyYiIsICJwdWJsaWNVUkwiOiAiaHR0cDovL2NvbnRyb2w6NTAwMC92Mi4wIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImlkZW50aXR5IiwgIm5hbWUiOiAia2V5c3RvbmUifV0sICJ1c2VyIjogeyJ1c2VybmFtZSI6ICJhZG1pbiIsICJyb2xlc19saW5rcyI6IFtdLCAiaWQiOiAiZmU0MTIyOWE0Njc4NDgyMGFkZGViZjg2ZjQ3M2VlM2IiLCAicm9sZXMiOiBbeyJuYW1lIjogImFkbWluIn1dLCAibmFtZSI6ICJhZG1pbiJ9LCAibWV0YWRhdGEiOiB7ImlzX2FkbWluIjogMCwgInJvbGVzIjogWyJjMmUwNWViOGRmODY0NmQ5OTQ0YWY1MGE0YmEwOThjNSJdfX19MYIBgTCCAX0CAQEwXDBXMQswCQYDVQQGEwJVUzEOMAwGA1UECAwFVW5zZXQxDjAMBgNVBAcMBVVuc2V0MQ4wDAYDVQQKDAVVbnNldDEYMBYGA1UEAwwPd3d3LmV4YW1wbGUuY29tAgEBMAcGBSsOAwIaMA0GCSqGSIb3DQEBAQUABIIBADQFal6QU24fdXtXoNd2rbsPVMvuiwWJvtoHgOaTqA7jQpsojIfSzya+XArWLUykDZq6U3x5ZM8TS6tGtOFQkA7LAhXN6qtH3p7Tgpufsl0c+PYFtKxrDGLQYk+F69z4bxAxszYJqcopnMdn2RdEznDI0tLPZK1bvlXXrfv6owJEh-Lv6HFVUautkCukpzK07pDE+AIkU9o0KPxDTWp97LiNhxZgJj9ocGTuuqBFSKsQnD92i4kOopr2p7gq62FAfs7+CEo1gxcJ73nHxzM3fhbc2GkVNAkm6vi5MJkOenol2c0gZwxVXzKJdAUzWMEXstzPWisg1oH5D6tDYwO8PR0=' -H 'Content-Type: application/octet-stream' -H 'x-image-meta-disk_format: qcow2' -H 'x-image-meta-name: cirros-0.3.2-x86_64' -d '<glanceclient.common.progressbar.VerboseFileWrapper object at 0x274eb10>' http://control:9292/v1/images
[=============================>] 100%

HTTP/1.1 500 Internal Server Error
date: Mon, 15 Sep 2014 07:03:36 GMT
content-length: 0
content-type: text/plain
connection: close

Request returned failure status.
HTTPInternalServerError (HTTP 500)

Getting 'HTTP 500' while creating image in Glance

Hi Experts,

I have configured Glance configuration step by step as per Openstack Officical Document. In the last step I am getting error while trying to create image.. Please guide to trouble shhot the error.

@control images]# grep ^[^#] /etc/glance/glance-api.conf
[DEFAULT]
[DEFAULT]
rpc_backend = qpid
qpid_hostname = control
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone
[store_type_location_strategy]

@control images]# grep ^[^#] /etc/glance/glance-registry.conf
[DEFAULT]
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone

Created glance service point..

-------+
|                id                |   region  |        publicurl         |       internalurl        |          adminurl         |            service_id            |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+
| 006f674412154aa4bf13a84bd05d1f26 | regionOne |   http://control:9292    |   http://control:9292    |    http://control:9292    | c3c6b999f5cf4dfc871019f3a8fd1e8a |
| 977ff0c49dec4cf6873804edf3fa6e34 | regionOne | http://control:5000/v2.0 | http://control:5000/v2.0 | http://control:35357/v2.0 | 808ee4f6b8944fc9895f5fa52ad2327f |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+

Still I am getting below error,, Please let me know is there any value se for enviroment..

@control images]# glance --debug image-create --name "cirros-0.3.2-x86_64" --disk-format qcow2 --container-format bare --is-public True --progress < cirros-0.3.2-x86_64-disk.img
curl -i -X POST -H 'x-image-meta-container_format: bare' -H 'Transfer-Encoding: chunked' -H 'User-Agent: python-glanceclient' -H 'x-image-meta-size: 13167616' -H 'x-image-meta-is_public: True' -H 'X-Auth-Token: MIIFpAYJKoZIhvcNAQcCoIIFlTCCBZECAQExCTAHBgUrDgMCGjCCA-oGCSqGSIb3DQEHAaCCA+sEggPneyJhY2Nlc3MiOiB7InRva2VuIjogeyJpc3N1ZWRfYXQiOiAiMjAxNC0wOS0xNVQwNzowMzozNi4wNzY1MjQiLCAiZXhwaXJlcyI6ICIyMDE0LTA5LTE1VDA4OjAzOjM2WiIsICJpZCI6ICJwbGFjZWhvbGRlciIsICJ0ZW5hbnQiOiB7ImRlc2NyaXB0aW9uIjogIkFkbWluIFRlbmFudCIsICJlbmFibGVkIjogdHJ1ZSwgImlkIjogImY4Nzc5MjY4NmY0OTRhOTU5YzdjMzEyZWNiYTJmMjMzIiwgIm5hbWUiOiAiYWRtaW4ifX0sICJzZXJ2aWNlQ2F0YWxvZyI6IFt7ImVuZHBvaW50cyI6IFt7ImFkbWluVVJMIjogImh0dHA6Ly9jb250cm9sOjkyOTIiLCAicmVnaW9uIjogInJlZ2lvbk9uZSIsICJpbnRlcm5hbFVSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIiwgImlkIjogIjE5MDQ2YWZkNGY4NzQyMzhhMTdhY2E5ZjE0MGMyZTY1IiwgInB1YmxpY1VSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImltYWdlIiwgIm5hbWUiOiAiZ2xhbmNlIn0sIHsiZW5kcG9pbnRzIjogW3siYWRtaW5VUkwiOiAiaHR0cDovL2NvbnRyb2w6MzUzNTcvdjIuMCIsICJyZWdpb24iOiAicmVnaW9uT25lIiwgImludGVybmFsVVJMIjogImh0dHA6Ly9jb250cm9sOjUwMDAvdjIuMCIsICJpZCI6ICIwYTY5ZGI4MGU4OWY0OTQ4OWUxNWQzYjM4ZjY5ZmEyYiIsICJwdWJsaWNVUkwiOiAiaHR0cDovL2NvbnRyb2w6NTAwMC92Mi4wIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImlkZW50aXR5IiwgIm5hbWUiOiAia2V5c3RvbmUifV0sICJ1c2VyIjogeyJ1c2VybmFtZSI6ICJhZG1pbiIsICJyb2xlc19saW5rcyI6IFtdLCAiaWQiOiAiZmU0MTIyOWE0Njc4NDgyMGFkZGViZjg2ZjQ3M2VlM2IiLCAicm9sZXMiOiBbeyJuYW1lIjogImFkbWluIn1dLCAibmFtZSI6ICJhZG1pbiJ9LCAibWV0YWRhdGEiOiB7ImlzX2FkbWluIjogMCwgInJvbGVzIjogWyJjMmUwNWViOGRmODY0NmQ5OTQ0YWY1MGE0YmEwOThjNSJdfX19MYIBgTCCAX0CAQEwXDBXMQswCQYDVQQGEwJVUzEOMAwGA1UECAwFVW5zZXQxDjAMBgNVBAcMBVVuc2V0MQ4wDAYDVQQKDAVVbnNldDEYMBYGA1UEAwwPd3d3LmV4YW1wbGUuY29tAgEBMAcGBSsOAwIaMA0GCSqGSIb3DQEBAQUABIIBADQFal6QU24fdXtXoNd2rbsPVMvuiwWJvtoHgOaTqA7jQpsojIfSzya+XArWLUykDZq6U3x5ZM8TS6tGtOFQkA7LAhXN6qtH3p7Tgpufsl0c+PYFtKxrDGLQYk+F69z4bxAxszYJqcopnMdn2RdEznDI0tLPZK1bvlXXrfv6owJEh-Lv6HFVUautkCukpzK07pDE+AIkU9o0KPxDTWp97LiNhxZgJj9ocGTuuqBFSKsQnD92i4kOopr2p7gq62FAfs7+CEo1gxcJ73nHxzM3fhbc2GkVNAkm6vi5MJkOenol2c0gZwxVXzKJdAUzWMEXstzPWisg1oH5D6tDYwO8PR0=' -H 'Content-Type: application/octet-stream' -H 'x-image-meta-disk_format: qcow2' -H 'x-image-meta-name: cirros-0.3.2-x86_64' -d '<glanceclient.common.progressbar.VerboseFileWrapper object at 0x274eb10>' http://control:9292/v1/images
[=============================>] 100%

HTTP/1.1 500 Internal Server Error
date: Mon, 15 Sep 2014 07:03:36 GMT
content-length: 0
content-type: text/plain
connection: close

Request returned failure status.
HTTPInternalServerError (HTTP 500)

It seems glance token mismatch at the time of connection. Please help how I can fix this issue.

Getting 'HTTP 500' while creating image in Glance

Hi Experts,

I have configured Glance configuration step by step as per Openstack Officical Document. In the last step I am getting error while trying to create image.. Please guide to trouble shhot the error.

@control images]# grep ^[^#] /etc/glance/glance-api.conf
[DEFAULT]
[DEFAULT]
rpc_backend = qpid
qpid_hostname = control
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone
[store_type_location_strategy]

@control images]# grep ^[^#] /etc/glance/glance-registry.conf
[DEFAULT]
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone

Created glance service point..

-------+
|                id                |   region  |        publicurl         |       internalurl        |          adminurl         |            service_id            |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+
| 006f674412154aa4bf13a84bd05d1f26 | regionOne |   http://control:9292    |   http://control:9292    |    http://control:9292    | c3c6b999f5cf4dfc871019f3a8fd1e8a |
| 977ff0c49dec4cf6873804edf3fa6e34 | regionOne | http://control:5000/v2.0 | http://control:5000/v2.0 | http://control:35357/v2.0 | 808ee4f6b8944fc9895f5fa52ad2327f |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+

Still I am getting below error,, Please let me know is there any value se for enviroment..

@control images]# glance --debug image-create --name "cirros-0.3.2-x86_64" --disk-format qcow2 --container-format bare --is-public True --progress < cirros-0.3.2-x86_64-disk.img
curl -i -X POST -H 'x-image-meta-container_format: bare' -H 'Transfer-Encoding: chunked' -H 'User-Agent: python-glanceclient' -H 'x-image-meta-size: 13167616' -H 'x-image-meta-is_public: True' -H 'X-Auth-Token: MIIFpAYJKoZIhvcNAQcCoIIFlTCCBZECAQExCTAHBgUrDgMCGjCCA-oGCSqGSIb3DQEHAaCCA+sEggPneyJhY2Nlc3MiOiB7InRva2VuIjogeyJpc3N1ZWRfYXQiOiAiMjAxNC0wOS0xNVQwNzowMzozNi4wNzY1MjQiLCAiZXhwaXJlcyI6ICIyMDE0LTA5LTE1VDA4OjAzOjM2WiIsICJpZCI6ICJwbGFjZWhvbGRlciIsICJ0ZW5hbnQiOiB7ImRlc2NyaXB0aW9uIjogIkFkbWluIFRlbmFudCIsICJlbmFibGVkIjogdHJ1ZSwgImlkIjogImY4Nzc5MjY4NmY0OTRhOTU5YzdjMzEyZWNiYTJmMjMzIiwgIm5hbWUiOiAiYWRtaW4ifX0sICJzZXJ2aWNlQ2F0YWxvZyI6IFt7ImVuZHBvaW50cyI6IFt7ImFkbWluVVJMIjogImh0dHA6Ly9jb250cm9sOjkyOTIiLCAicmVnaW9uIjogInJlZ2lvbk9uZSIsICJpbnRlcm5hbFVSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIiwgImlkIjogIjE5MDQ2YWZkNGY4NzQyMzhhMTdhY2E5ZjE0MGMyZTY1IiwgInB1YmxpY1VSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImltYWdlIiwgIm5hbWUiOiAiZ2xhbmNlIn0sIHsiZW5kcG9pbnRzIjogW3siYWRtaW5VUkwiOiAiaHR0cDovL2NvbnRyb2w6MzUzNTcvdjIuMCIsICJyZWdpb24iOiAicmVnaW9uT25lIiwgImludGVybmFsVVJMIjogImh0dHA6Ly9jb250cm9sOjUwMDAvdjIuMCIsICJpZCI6ICIwYTY5ZGI4MGU4OWY0OTQ4OWUxNWQzYjM4ZjY5ZmEyYiIsICJwdWJsaWNVUkwiOiAiaHR0cDovL2NvbnRyb2w6NTAwMC92Mi4wIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImlkZW50aXR5IiwgIm5hbWUiOiAia2V5c3RvbmUifV0sICJ1c2VyIjogeyJ1c2VybmFtZSI6ICJhZG1pbiIsICJyb2xlc19saW5rcyI6IFtdLCAiaWQiOiAiZmU0MTIyOWE0Njc4NDgyMGFkZGViZjg2ZjQ3M2VlM2IiLCAicm9sZXMiOiBbeyJuYW1lIjogImFkbWluIn1dLCAibmFtZSI6ICJhZG1pbiJ9LCAibWV0YWRhdGEiOiB7ImlzX2FkbWluIjogMCwgInJvbGVzIjogWyJjMmUwNWViOGRmODY0NmQ5OTQ0YWY1MGE0YmEwOThjNSJdfX19MYIBgTCCAX0CAQEwXDBXMQswCQYDVQQGEwJVUzEOMAwGA1UECAwFVW5zZXQxDjAMBgNVBAcMBVVuc2V0MQ4wDAYDVQQKDAVVbnNldDEYMBYGA1UEAwwPd3d3LmV4YW1wbGUuY29tAgEBMAcGBSsOAwIaMA0GCSqGSIb3DQEBAQUABIIBADQFal6QU24fdXtXoNd2rbsPVMvuiwWJvtoHgOaTqA7jQpsojIfSzya+XArWLUykDZq6U3x5ZM8TS6tGtOFQkA7LAhXN6qtH3p7Tgpufsl0c+PYFtKxrDGLQYk+F69z4bxAxszYJqcopnMdn2RdEznDI0tLPZK1bvlXXrfv6owJEh-Lv6HFVUautkCukpzK07pDE+AIkU9o0KPxDTWp97LiNhxZgJj9ocGTuuqBFSKsQnD92i4kOopr2p7gq62FAfs7+CEo1gxcJ73nHxzM3fhbc2GkVNAkm6vi5MJkOenol2c0gZwxVXzKJdAUzWMEXstzPWisg1oH5D6tDYwO8PR0=' -H 'Content-Type: application/octet-stream' -H 'x-image-meta-disk_format: qcow2' -H 'x-image-meta-name: cirros-0.3.2-x86_64' -d '<glanceclient.common.progressbar.VerboseFileWrapper object at 0x274eb10>' http://control:9292/v1/images
[=============================>] 100%

HTTP/1.1 500 Internal Server Error
date: Mon, 15 Sep 2014 07:03:36 GMT
content-length: 0
content-type: text/plain
connection: close

Request returned failure status.
HTTPInternalServerError (HTTP 500)

It seems glance token mismatch at I could see the time of connection. below error while I am doing db_sync.. Please help how I can fix this issue.me to guide the solution..

@control ~]# su -s /bin/sh -c "glance-manage db_sync" glance
/usr/lib64/python2.6/site-packages/Crypto/Util/number.py:57: PowmInsecureWarning: Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.
  _warn("Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning)

Getting 'HTTP 500' while creating image in Glance

Hi Experts,

I have configured Glance configuration step by step as per Openstack Officical Document. In the last step I am getting error while trying to create image.. Please guide to trouble shhot the error.

@control images]# grep ^[^#] /etc/glance/glance-api.conf
[DEFAULT]
[DEFAULT]
rpc_backend = qpid
qpid_hostname = control
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone
[store_type_location_strategy]

@control images]# grep ^[^#] /etc/glance/glance-registry.conf
[DEFAULT]
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone

Created glance service point..

-------+
|                id                |   region  |        publicurl         |       internalurl        |          adminurl         |            service_id            |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+
| 006f674412154aa4bf13a84bd05d1f26 | regionOne |   http://control:9292    |   http://control:9292    |    http://control:9292    | c3c6b999f5cf4dfc871019f3a8fd1e8a |
| 977ff0c49dec4cf6873804edf3fa6e34 | regionOne | http://control:5000/v2.0 | http://control:5000/v2.0 | http://control:35357/v2.0 | 808ee4f6b8944fc9895f5fa52ad2327f |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+

Still I am getting below error,, Please let me know is there any value se for enviroment..

@control images]# glance --debug image-create --name "cirros-0.3.2-x86_64" --disk-format qcow2 --container-format bare --is-public True --progress < cirros-0.3.2-x86_64-disk.img
curl -i -X POST -H 'x-image-meta-container_format: bare' -H 'Transfer-Encoding: chunked' -H 'User-Agent: python-glanceclient' -H 'x-image-meta-size: 13167616' -H 'x-image-meta-is_public: True' -H 'X-Auth-Token: MIIFpAYJKoZIhvcNAQcCoIIFlTCCBZECAQExCTAHBgUrDgMCGjCCA-oGCSqGSIb3DQEHAaCCA+sEggPneyJhY2Nlc3MiOiB7InRva2VuIjogeyJpc3N1ZWRfYXQiOiAiMjAxNC0wOS0xNVQwNzowMzozNi4wNzY1MjQiLCAiZXhwaXJlcyI6ICIyMDE0LTA5LTE1VDA4OjAzOjM2WiIsICJpZCI6ICJwbGFjZWhvbGRlciIsICJ0ZW5hbnQiOiB7ImRlc2NyaXB0aW9uIjogIkFkbWluIFRlbmFudCIsICJlbmFibGVkIjogdHJ1ZSwgImlkIjogImY4Nzc5MjY4NmY0OTRhOTU5YzdjMzEyZWNiYTJmMjMzIiwgIm5hbWUiOiAiYWRtaW4ifX0sICJzZXJ2aWNlQ2F0YWxvZyI6IFt7ImVuZHBvaW50cyI6IFt7ImFkbWluVVJMIjogImh0dHA6Ly9jb250cm9sOjkyOTIiLCAicmVnaW9uIjogInJlZ2lvbk9uZSIsICJpbnRlcm5hbFVSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIiwgImlkIjogIjE5MDQ2YWZkNGY4NzQyMzhhMTdhY2E5ZjE0MGMyZTY1IiwgInB1YmxpY1VSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImltYWdlIiwgIm5hbWUiOiAiZ2xhbmNlIn0sIHsiZW5kcG9pbnRzIjogW3siYWRtaW5VUkwiOiAiaHR0cDovL2NvbnRyb2w6MzUzNTcvdjIuMCIsICJyZWdpb24iOiAicmVnaW9uT25lIiwgImludGVybmFsVVJMIjogImh0dHA6Ly9jb250cm9sOjUwMDAvdjIuMCIsICJpZCI6ICIwYTY5ZGI4MGU4OWY0OTQ4OWUxNWQzYjM4ZjY5ZmEyYiIsICJwdWJsaWNVUkwiOiAiaHR0cDovL2NvbnRyb2w6NTAwMC92Mi4wIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImlkZW50aXR5IiwgIm5hbWUiOiAia2V5c3RvbmUifV0sICJ1c2VyIjogeyJ1c2VybmFtZSI6ICJhZG1pbiIsICJyb2xlc19saW5rcyI6IFtdLCAiaWQiOiAiZmU0MTIyOWE0Njc4NDgyMGFkZGViZjg2ZjQ3M2VlM2IiLCAicm9sZXMiOiBbeyJuYW1lIjogImFkbWluIn1dLCAibmFtZSI6ICJhZG1pbiJ9LCAibWV0YWRhdGEiOiB7ImlzX2FkbWluIjogMCwgInJvbGVzIjogWyJjMmUwNWViOGRmODY0NmQ5OTQ0YWY1MGE0YmEwOThjNSJdfX19MYIBgTCCAX0CAQEwXDBXMQswCQYDVQQGEwJVUzEOMAwGA1UECAwFVW5zZXQxDjAMBgNVBAcMBVVuc2V0MQ4wDAYDVQQKDAVVbnNldDEYMBYGA1UEAwwPd3d3LmV4YW1wbGUuY29tAgEBMAcGBSsOAwIaMA0GCSqGSIb3DQEBAQUABIIBADQFal6QU24fdXtXoNd2rbsPVMvuiwWJvtoHgOaTqA7jQpsojIfSzya+XArWLUykDZq6U3x5ZM8TS6tGtOFQkA7LAhXN6qtH3p7Tgpufsl0c+PYFtKxrDGLQYk+F69z4bxAxszYJqcopnMdn2RdEznDI0tLPZK1bvlXXrfv6owJEh-Lv6HFVUautkCukpzK07pDE+AIkU9o0KPxDTWp97LiNhxZgJj9ocGTuuqBFSKsQnD92i4kOopr2p7gq62FAfs7+CEo1gxcJ73nHxzM3fhbc2GkVNAkm6vi5MJkOenol2c0gZwxVXzKJdAUzWMEXstzPWisg1oH5D6tDYwO8PR0=' -H 'Content-Type: application/octet-stream' -H 'x-image-meta-disk_format: qcow2' -H 'x-image-meta-name: cirros-0.3.2-x86_64' -d '<glanceclient.common.progressbar.VerboseFileWrapper object at 0x274eb10>' http://control:9292/v1/images
[=============================>] 100%

HTTP/1.1 500 Internal Server Error
date: Mon, 15 Sep 2014 07:03:36 GMT
content-length: 0
content-type: text/plain
connection: close

Request returned failure status.
HTTPInternalServerError (HTTP 500)

I could see the below error while I am doing db_sync.. Please help me to guide the solution..

@control ~]# su -s /bin/sh -c "glance-manage db_sync" glance
/usr/lib64/python2.6/site-packages/Crypto/Util/number.py:57: PowmInsecureWarning: Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.
  _warn("Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning)

==================================================================================================

As per my understood I belive something messed up in glance-api configuration file.. So I am sharing api log details and database details for glance. Please suggest me..

[root@control ~]# keystone user-list
+----------------------------------+--------+---------+-----------------+
|                id                |  name  | enabled |      email      |
+----------------------------------+--------+---------+-----------------+
| fe41229a46784820addebf86f473ee3b | admin  |   True  |  admin@labs.com |
| 7ffefa6f64de43679241fb2870966092 | glance |   True  | glance@labs.com |
+----------------------------------+--------+---------+-----------------+
[root@control ~]# keystone tenant-list
+----------------------------------+---------+---------+
|                id                |   name  | enabled |
+----------------------------------+---------+---------+
| f87792686f494a959c7c312ecba2f233 |  admin  |   True  |
| 720ddd2e5f2f4084ae810734cf00cf40 | service |   True  |
+----------------------------------+---------+---------+
[root@control ~]# keystone service-list
+----------------------------------+----------+----------+---------------------------+
|                id                |   name   |   type   |        description        |
+----------------------------------+----------+----------+---------------------------+
| c3c6b999f5cf4dfc871019f3a8fd1e8a |  glance  |  image   |  OpenStack Image Service  |
| d8c36ce1cdb544c098f8b3f5d9332d3f |  glance  |  image   |  OpenStack Image Service  |
| 808ee4f6b8944fc9895f5fa52ad2327f | keystone | identity | Keystone Identity Service |
+----------------------------------+----------+----------+---------------------------+

API LOG

@control ~]# tail /var/log/glance/api.log
2014-09-16 20:15:28.948 1643 WARNING glance.store.base [-] Failed to configure store correctly: Store swift could not be configured correctly. Reason: Could not find swift_store_auth_address in configuration options. Disabling add method.
2014-09-16 20:15:28.951 1643 WARNING glance.store [-] Deprecated: glance.store.swift.Store not found in `known_store`. Stores need to be explicitly enabled in the configuration file.
2014-09-16 20:15:28.957 1643 WARNING glance.store.base [-] Failed to configure store correctly: Store s3 could not be configured correctly. Reason: Could not find s3_store_host in configuration options. Disabling add method.
2014-09-16 20:15:28.958 1643 WARNING glance.store [-] Deprecated: glance.store.s3.Store not found in `known_store`. Stores need to be explicitly enabled in the configuration file.
2014-09-16 20:15:29.671 1643 INFO keystoneclient.middleware.auth_token [-] Starting keystone auth_token middleware
2014-09-16 20:15:29.671 1643 WARNING keystoneclient.middleware.auth_token [-] Configuring admin URI using auth fragments. This is deprecated, use 'identity_uri' instead.
2014-09-16 20:15:29.672 1643 INFO keystoneclient.middleware.auth_token [-] Using /tmp/keystone-signing-4P8wBz as cache directory for signing certificate
2014-09-16 20:15:29.673 1643 INFO glance.wsgi.server [-] Starting 1 workers
2014-09-16 20:15:29.675 1643 INFO glance.wsgi.server [-] Started child 1681
2014-09-16 20:15:29.685 1681 INFO glance.wsgi.server [-] (1681) wsgi starting up on http://0.0.0.0:9292/

Getting 'HTTP 500' while creating image in Glance

Hi Experts,

I have configured Glance configuration step by step as per Openstack Officical Document. In the last step I am getting error while trying to create image.. Please guide to trouble shhot the error.

@control images]# grep ^[^#] /etc/glance/glance-api.conf
[DEFAULT]
[DEFAULT]
rpc_backend = qpid
qpid_hostname = control
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone
[store_type_location_strategy]

@control images]# grep ^[^#] /etc/glance/glance-registry.conf
[DEFAULT]
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone

Created glance service point..

-------+
|                id                |   region  |        publicurl         |       internalurl        |          adminurl         |            service_id            |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+
| 006f674412154aa4bf13a84bd05d1f26 | regionOne |   http://control:9292    |   http://control:9292    |    http://control:9292    | c3c6b999f5cf4dfc871019f3a8fd1e8a |
| 977ff0c49dec4cf6873804edf3fa6e34 | regionOne | http://control:5000/v2.0 | http://control:5000/v2.0 | http://control:35357/v2.0 | 808ee4f6b8944fc9895f5fa52ad2327f |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+

Still I am getting below error,, Please let me know is there any value se for enviroment..

@control images]# glance --debug image-create --name "cirros-0.3.2-x86_64" --disk-format qcow2 --container-format bare --is-public True --progress < cirros-0.3.2-x86_64-disk.img
curl -i -X POST -H 'x-image-meta-container_format: bare' -H 'Transfer-Encoding: chunked' -H 'User-Agent: python-glanceclient' -H 'x-image-meta-size: 13167616' -H 'x-image-meta-is_public: True' -H 'X-Auth-Token: MIIFpAYJKoZIhvcNAQcCoIIFlTCCBZECAQExCTAHBgUrDgMCGjCCA-oGCSqGSIb3DQEHAaCCA+sEggPneyJhY2Nlc3MiOiB7InRva2VuIjogeyJpc3N1ZWRfYXQiOiAiMjAxNC0wOS0xNVQwNzowMzozNi4wNzY1MjQiLCAiZXhwaXJlcyI6ICIyMDE0LTA5LTE1VDA4OjAzOjM2WiIsICJpZCI6ICJwbGFjZWhvbGRlciIsICJ0ZW5hbnQiOiB7ImRlc2NyaXB0aW9uIjogIkFkbWluIFRlbmFudCIsICJlbmFibGVkIjogdHJ1ZSwgImlkIjogImY4Nzc5MjY4NmY0OTRhOTU5YzdjMzEyZWNiYTJmMjMzIiwgIm5hbWUiOiAiYWRtaW4ifX0sICJzZXJ2aWNlQ2F0YWxvZyI6IFt7ImVuZHBvaW50cyI6IFt7ImFkbWluVVJMIjogImh0dHA6Ly9jb250cm9sOjkyOTIiLCAicmVnaW9uIjogInJlZ2lvbk9uZSIsICJpbnRlcm5hbFVSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIiwgImlkIjogIjE5MDQ2YWZkNGY4NzQyMzhhMTdhY2E5ZjE0MGMyZTY1IiwgInB1YmxpY1VSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImltYWdlIiwgIm5hbWUiOiAiZ2xhbmNlIn0sIHsiZW5kcG9pbnRzIjogW3siYWRtaW5VUkwiOiAiaHR0cDovL2NvbnRyb2w6MzUzNTcvdjIuMCIsICJyZWdpb24iOiAicmVnaW9uT25lIiwgImludGVybmFsVVJMIjogImh0dHA6Ly9jb250cm9sOjUwMDAvdjIuMCIsICJpZCI6ICIwYTY5ZGI4MGU4OWY0OTQ4OWUxNWQzYjM4ZjY5ZmEyYiIsICJwdWJsaWNVUkwiOiAiaHR0cDovL2NvbnRyb2w6NTAwMC92Mi4wIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImlkZW50aXR5IiwgIm5hbWUiOiAia2V5c3RvbmUifV0sICJ1c2VyIjogeyJ1c2VybmFtZSI6ICJhZG1pbiIsICJyb2xlc19saW5rcyI6IFtdLCAiaWQiOiAiZmU0MTIyOWE0Njc4NDgyMGFkZGViZjg2ZjQ3M2VlM2IiLCAicm9sZXMiOiBbeyJuYW1lIjogImFkbWluIn1dLCAibmFtZSI6ICJhZG1pbiJ9LCAibWV0YWRhdGEiOiB7ImlzX2FkbWluIjogMCwgInJvbGVzIjogWyJjMmUwNWViOGRmODY0NmQ5OTQ0YWY1MGE0YmEwOThjNSJdfX19MYIBgTCCAX0CAQEwXDBXMQswCQYDVQQGEwJVUzEOMAwGA1UECAwFVW5zZXQxDjAMBgNVBAcMBVVuc2V0MQ4wDAYDVQQKDAVVbnNldDEYMBYGA1UEAwwPd3d3LmV4YW1wbGUuY29tAgEBMAcGBSsOAwIaMA0GCSqGSIb3DQEBAQUABIIBADQFal6QU24fdXtXoNd2rbsPVMvuiwWJvtoHgOaTqA7jQpsojIfSzya+XArWLUykDZq6U3x5ZM8TS6tGtOFQkA7LAhXN6qtH3p7Tgpufsl0c+PYFtKxrDGLQYk+F69z4bxAxszYJqcopnMdn2RdEznDI0tLPZK1bvlXXrfv6owJEh-Lv6HFVUautkCukpzK07pDE+AIkU9o0KPxDTWp97LiNhxZgJj9ocGTuuqBFSKsQnD92i4kOopr2p7gq62FAfs7+CEo1gxcJ73nHxzM3fhbc2GkVNAkm6vi5MJkOenol2c0gZwxVXzKJdAUzWMEXstzPWisg1oH5D6tDYwO8PR0=' -H 'Content-Type: application/octet-stream' -H 'x-image-meta-disk_format: qcow2' -H 'x-image-meta-name: cirros-0.3.2-x86_64' -d '<glanceclient.common.progressbar.VerboseFileWrapper object at 0x274eb10>' http://control:9292/v1/images
[=============================>] 100%

HTTP/1.1 500 Internal Server Error
date: Mon, 15 Sep 2014 07:03:36 GMT
content-length: 0
content-type: text/plain
connection: close

Request returned failure status.
HTTPInternalServerError (HTTP 500)

I could see the below error while I am doing db_sync.. Please help me to guide the solution..

@control ~]# su -s /bin/sh -c "glance-manage db_sync" glance
/usr/lib64/python2.6/site-packages/Crypto/Util/number.py:57: PowmInsecureWarning: Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.
  _warn("Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning)

==================================================================================================

As per my understood I belive something messed up in glance-api configuration file.. So I am sharing api log details and database details for glance. Please suggest me..

[root@control ~]# keystone user-list
+----------------------------------+--------+---------+-----------------+
|                id                |  name  | enabled |      email      |
+----------------------------------+--------+---------+-----------------+
| fe41229a46784820addebf86f473ee3b | admin  |   True  |  admin@labs.com |
| 7ffefa6f64de43679241fb2870966092 | glance |   True  | glance@labs.com |
+----------------------------------+--------+---------+-----------------+
[root@control ~]# keystone tenant-list
+----------------------------------+---------+---------+
|                id                |   name  | enabled |
+----------------------------------+---------+---------+
| f87792686f494a959c7c312ecba2f233 |  admin  |   True  |
| 720ddd2e5f2f4084ae810734cf00cf40 | service |   True  |
+----------------------------------+---------+---------+
[root@control ~]# keystone service-list
+----------------------------------+----------+----------+---------------------------+
|                id                |   name   |   type   |        description        |
+----------------------------------+----------+----------+---------------------------+
| c3c6b999f5cf4dfc871019f3a8fd1e8a |  glance  |  image   |  OpenStack Image Service  |
| d8c36ce1cdb544c098f8b3f5d9332d3f |  glance  |  image   |  OpenStack Image Service  |
| 808ee4f6b8944fc9895f5fa52ad2327f | keystone | identity | Keystone Identity Service |
+----------------------------------+----------+----------+---------------------------+

API LOG

@control ~]# tail /var/log/glance/api.log
2014-09-16 20:15:28.948 1643 WARNING glance.store.base [-] Failed to configure store correctly: Store swift could not be configured correctly. Reason: Could not find swift_store_auth_address in configuration options. Disabling add method.
2014-09-16 20:15:28.951 1643 WARNING glance.store [-] Deprecated: glance.store.swift.Store not found in `known_store`. Stores need to be explicitly enabled in the configuration file.
2014-09-16 20:15:28.957 1643 WARNING glance.store.base [-] Failed to configure store correctly: Store s3 could not be configured correctly. Reason: Could not find s3_store_host in configuration options. Disabling add method.
2014-09-16 20:15:28.958 1643 WARNING glance.store [-] Deprecated: glance.store.s3.Store not found in `known_store`. Stores need to be explicitly enabled in the configuration file.
2014-09-16 20:15:29.671 1643 INFO keystoneclient.middleware.auth_token [-] Starting keystone auth_token middleware
2014-09-16 20:15:29.671 1643 WARNING keystoneclient.middleware.auth_token [-] Configuring admin URI using auth fragments. This is deprecated, use 'identity_uri' instead.
2014-09-16 20:15:29.672 1643 INFO keystoneclient.middleware.auth_token [-] Using /tmp/keystone-signing-4P8wBz as cache directory for signing certificate
2014-09-16 20:15:29.673 1643 INFO glance.wsgi.server [-] Starting 1 workers
2014-09-16 20:15:29.675 1643 INFO glance.wsgi.server [-] Started child 1681
2014-09-16 20:15:29.685 1681 INFO glance.wsgi.server [-] (1681) wsgi starting up on http://0.0.0.0:9292/

Getting 'HTTP 500' while creating image in Glance

Hi Experts,

I have configured Glance configuration step by step as per Openstack Officical Document. In the last step I am getting error while trying to create image.. Please guide to trouble shhot the error.

@control images]# grep ^[^#] /etc/glance/glance-api.conf
[DEFAULT]
[DEFAULT]
rpc_backend = qpid
qpid_hostname = control
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone
[store_type_location_strategy]

@control images]# grep ^[^#] /etc/glance/glance-registry.conf
[DEFAULT]
[database]
connection = mysql://glance:labs123@control/glance
[keystone_authtoken]
auth_uri = http://control:5000
auth_host = control
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = glance
admin_password = labs123
[paste_deploy]
flavor = keystone

Created glance service point..

-------+
|                id                |   region  |        publicurl         |       internalurl        |          adminurl         |            service_id            |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+
| 006f674412154aa4bf13a84bd05d1f26 | regionOne |   http://control:9292    |   http://control:9292    |    http://control:9292    | c3c6b999f5cf4dfc871019f3a8fd1e8a |
| 977ff0c49dec4cf6873804edf3fa6e34 | regionOne | http://control:5000/v2.0 | http://control:5000/v2.0 | http://control:35357/v2.0 | 808ee4f6b8944fc9895f5fa52ad2327f |
+----------------------------------+-----------+--------------------------+--------------------------+---------------------------+----------------------------------+

Still I am getting below error,, Please let me know is there any value se for enviroment..

@control images]# glance --debug image-create --name "cirros-0.3.2-x86_64" --disk-format qcow2 --container-format bare --is-public True --progress < cirros-0.3.2-x86_64-disk.img
curl -i -X POST -H 'x-image-meta-container_format: bare' -H 'Transfer-Encoding: chunked' -H 'User-Agent: python-glanceclient' -H 'x-image-meta-size: 13167616' -H 'x-image-meta-is_public: True' -H 'X-Auth-Token: MIIFpAYJKoZIhvcNAQcCoIIFlTCCBZECAQExCTAHBgUrDgMCGjCCA-oGCSqGSIb3DQEHAaCCA+sEggPneyJhY2Nlc3MiOiB7InRva2VuIjogeyJpc3N1ZWRfYXQiOiAiMjAxNC0wOS0xNVQwNzowMzozNi4wNzY1MjQiLCAiZXhwaXJlcyI6ICIyMDE0LTA5LTE1VDA4OjAzOjM2WiIsICJpZCI6ICJwbGFjZWhvbGRlciIsICJ0ZW5hbnQiOiB7ImRlc2NyaXB0aW9uIjogIkFkbWluIFRlbmFudCIsICJlbmFibGVkIjogdHJ1ZSwgImlkIjogImY4Nzc5MjY4NmY0OTRhOTU5YzdjMzEyZWNiYTJmMjMzIiwgIm5hbWUiOiAiYWRtaW4ifX0sICJzZXJ2aWNlQ2F0YWxvZyI6IFt7ImVuZHBvaW50cyI6IFt7ImFkbWluVVJMIjogImh0dHA6Ly9jb250cm9sOjkyOTIiLCAicmVnaW9uIjogInJlZ2lvbk9uZSIsICJpbnRlcm5hbFVSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIiwgImlkIjogIjE5MDQ2YWZkNGY4NzQyMzhhMTdhY2E5ZjE0MGMyZTY1IiwgInB1YmxpY1VSTCI6ICJodHRwOi8vY29udHJvbDo5MjkyIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImltYWdlIiwgIm5hbWUiOiAiZ2xhbmNlIn0sIHsiZW5kcG9pbnRzIjogW3siYWRtaW5VUkwiOiAiaHR0cDovL2NvbnRyb2w6MzUzNTcvdjIuMCIsICJyZWdpb24iOiAicmVnaW9uT25lIiwgImludGVybmFsVVJMIjogImh0dHA6Ly9jb250cm9sOjUwMDAvdjIuMCIsICJpZCI6ICIwYTY5ZGI4MGU4OWY0OTQ4OWUxNWQzYjM4ZjY5ZmEyYiIsICJwdWJsaWNVUkwiOiAiaHR0cDovL2NvbnRyb2w6NTAwMC92Mi4wIn1dLCAiZW5kcG9pbnRzX2xpbmtzIjogW10sICJ0eXBlIjogImlkZW50aXR5IiwgIm5hbWUiOiAia2V5c3RvbmUifV0sICJ1c2VyIjogeyJ1c2VybmFtZSI6ICJhZG1pbiIsICJyb2xlc19saW5rcyI6IFtdLCAiaWQiOiAiZmU0MTIyOWE0Njc4NDgyMGFkZGViZjg2ZjQ3M2VlM2IiLCAicm9sZXMiOiBbeyJuYW1lIjogImFkbWluIn1dLCAibmFtZSI6ICJhZG1pbiJ9LCAibWV0YWRhdGEiOiB7ImlzX2FkbWluIjogMCwgInJvbGVzIjogWyJjMmUwNWViOGRmODY0NmQ5OTQ0YWY1MGE0YmEwOThjNSJdfX19MYIBgTCCAX0CAQEwXDBXMQswCQYDVQQGEwJVUzEOMAwGA1UECAwFVW5zZXQxDjAMBgNVBAcMBVVuc2V0MQ4wDAYDVQQKDAVVbnNldDEYMBYGA1UEAwwPd3d3LmV4YW1wbGUuY29tAgEBMAcGBSsOAwIaMA0GCSqGSIb3DQEBAQUABIIBADQFal6QU24fdXtXoNd2rbsPVMvuiwWJvtoHgOaTqA7jQpsojIfSzya+XArWLUykDZq6U3x5ZM8TS6tGtOFQkA7LAhXN6qtH3p7Tgpufsl0c+PYFtKxrDGLQYk+F69z4bxAxszYJqcopnMdn2RdEznDI0tLPZK1bvlXXrfv6owJEh-Lv6HFVUautkCukpzK07pDE+AIkU9o0KPxDTWp97LiNhxZgJj9ocGTuuqBFSKsQnD92i4kOopr2p7gq62FAfs7+CEo1gxcJ73nHxzM3fhbc2GkVNAkm6vi5MJkOenol2c0gZwxVXzKJdAUzWMEXstzPWisg1oH5D6tDYwO8PR0=' -H 'Content-Type: application/octet-stream' -H 'x-image-meta-disk_format: qcow2' -H 'x-image-meta-name: cirros-0.3.2-x86_64' -d '<glanceclient.common.progressbar.VerboseFileWrapper object at 0x274eb10>' http://control:9292/v1/images
[=============================>] 100%

HTTP/1.1 500 Internal Server Error
date: Mon, 15 Sep 2014 07:03:36 GMT
content-length: 0
content-type: text/plain
connection: close

Request returned failure status.
HTTPInternalServerError (HTTP 500)

I could see the below error while I am doing db_sync.. Please help me to guide the solution..

@control ~]# su -s /bin/sh -c "glance-manage db_sync" glance
/usr/lib64/python2.6/site-packages/Crypto/Util/number.py:57: PowmInsecureWarning: Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.
  _warn("Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning)

==================================================================================================

As per my understood I belive something messed up in glance-api configuration file.. So I am sharing api log details and database details for glance. Please suggest me..

[root@control ~]# keystone user-list
+----------------------------------+--------+---------+-----------------+
|                id                |  name  | enabled |      email      |
+----------------------------------+--------+---------+-----------------+
| fe41229a46784820addebf86f473ee3b | admin  |   True  |  admin@labs.com |
| 7ffefa6f64de43679241fb2870966092 | glance |   True  | glance@labs.com |
+----------------------------------+--------+---------+-----------------+
[root@control ~]# keystone tenant-list
+----------------------------------+---------+---------+
|                id                |   name  | enabled |
+----------------------------------+---------+---------+
| f87792686f494a959c7c312ecba2f233 |  admin  |   True  |
| 720ddd2e5f2f4084ae810734cf00cf40 | service |   True  |
+----------------------------------+---------+---------+
[root@control ~]# keystone service-list
+----------------------------------+----------+----------+---------------------------+
|                id                |   name   |   type   |        description        |
+----------------------------------+----------+----------+---------------------------+
| c3c6b999f5cf4dfc871019f3a8fd1e8a |  glance  |  image   |  OpenStack Image Service  |
| d8c36ce1cdb544c098f8b3f5d9332d3f |  glance  |  image   |  OpenStack Image Service  |
| 808ee4f6b8944fc9895f5fa52ad2327f | keystone | identity | Keystone Identity Service |
+----------------------------------+----------+----------+---------------------------+

API LOG

@control ~]# tail /var/log/glance/api.log
2014-09-16 20:15:28.948 1643 WARNING glance.store.base [-] Failed to configure store correctly: Store swift could not be configured correctly. Reason: Could not find swift_store_auth_address in configuration options. Disabling add method.
2014-09-16 20:15:28.951 1643 WARNING glance.store [-] Deprecated: glance.store.swift.Store not found in `known_store`. Stores need to be explicitly enabled in the configuration file.
2014-09-16 20:15:28.957 1643 WARNING glance.store.base [-] Failed to configure store correctly: Store s3 could not be configured correctly. Reason: Could not find s3_store_host in configuration options. Disabling add method.
2014-09-16 20:15:28.958 1643 WARNING glance.store [-] Deprecated: glance.store.s3.Store not found in `known_store`. Stores need to be explicitly enabled in the configuration file.
2014-09-16 20:15:29.671 1643 INFO keystoneclient.middleware.auth_token [-] Starting keystone auth_token middleware
2014-09-16 20:15:29.671 1643 WARNING keystoneclient.middleware.auth_token [-] Configuring admin URI using auth fragments. This is deprecated, use 'identity_uri' instead.
2014-09-16 20:15:29.672 1643 INFO keystoneclient.middleware.auth_token [-] Using /tmp/keystone-signing-4P8wBz as cache directory for signing certificate
2014-09-16 20:15:29.673 1643 INFO glance.wsgi.server [-] Starting 1 workers
2014-09-16 20:15:29.675 1643 INFO glance.wsgi.server [-] Started child 1681
2014-09-16 20:15:29.685 1681 INFO glance.wsgi.server [-] (1681) wsgi starting up on http://0.0.0.0:9292/