Revision history [back]

click to hide/show revision 1
initial version

Devstack fails to start apache2 - "Address already in use" : "could not bind to address"

Tried to install devstack icehouse on Ubuntu 14.04 with the following "localrc" file:

DEST=/opt/stack

# Logging
LOGFILE=$DEST/logs/stack.sh.log
VERBOSE=True
LOG_COLOR=False
SCREEN_LOGDIR=$DEST/logs/screen

# Credentials
ADMIN_PASSWORD=openstack
MYSQL_PASSWORD=openstack
RABBIT_PASSWORD=openstack
SERVICE_PASSWORD=openstack
SERVICE_TOKEN=tokentoken

# Github's Branch
GLANCE_BRANCH=stable/icehouse
HORIZON_BRANCH=stable/icehouse
KEYSTONE_BRANCH=stable/icehouse
NOVA_BRANCH=stable/icehouse
NEUTRON_BRANCH=stable/icehouse
HEAT_BRANCH=stable/icehouse
CEILOMETER_BRANCH=stable/icehouse

# Neutron - Networking Service
DISABLED_SERVICES=n-net
ENABLED_SERVICES+=,q-svc,q-agt,q-dhcp,q-l3,q-meta,q-metering,neutron

# Neutron - Load Balancing
ENABLED_SERVICES+=,q-lbaas

# Heat - Orchestration Service
ENABLED_SERVICES+=,heat,h-api,h-api-cfn,h-api-cw,h-eng
HEAT_STANDALONE=True

# Ceilometer - Metering Service (metering + alarming)
ENABLED_SERVICES+=,ceilometer-acompute,ceilometer-acentral,ceilometer-collector,ceilometer-api
ENABLED_SERVICES+=,ceilometer-alarm-notify,ceilometer-alarm-eval

All seems to be going well until Horizon /Apache are being started up, then the following error appears: "(98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000" and i can't seem to figure out what's causing it.

The installation log where the error appears is below. The apache2 error logs are actually empty.

2014-09-09 23:02:39.113 | + start_horizon
2014-09-09 23:02:39.113 | + restart_apache_server
2014-09-09 23:02:39.113 | + restart_service apache2
2014-09-09 23:02:39.113 | + is_ubuntu
2014-09-09 23:02:39.113 | + [[ -z deb ]]
2014-09-09 23:02:39.113 | + '[' deb = deb ']'
2014-09-09 23:02:39.114 | + sudo /usr/sbin/service apache2 restart
2014-09-09 23:02:39.124 |  * Restarting web server apache2
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:5000
2014-09-09 23:02:39.232 | no listening sockets available, shutting down
2014-09-09 23:02:39.232 | AH00015: Unable to open logs
2014-09-09 23:02:39.245 | Action 'start' failed.
2014-09-09 23:02:39.245 | The Apache error log may have more information.
2014-09-09 23:02:59.335 |    ...fail!
2014-09-09 23:02:59.336 |  * The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
2014-09-09 23:02:59.336 | + exit_trap
2014-09-09 23:02:59.336 | + local r=1
2014-09-09 23:02:59.337 | ++ jobs -p
2014-09-09 23:02:39.113 | + '[' deb = deb ']'
2014-09-09 23:02:39.114 | + sudo /usr/sbin/service apache2 restart
2014-09-09 23:02:39.124 |  * Restarting web server apache2
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:5000
2014-09-09 23:02:39.232 | no listening sockets available, shutting down
2014-09-09 23:02:39.232 | AH00015: Unable to open logs
2014-09-09 23:02:39.245 | Action 'start' failed.
2014-09-09 23:02:39.245 | The Apache error log may have more information.
2014-09-09 23:02:59.335 |    ...fail!
2014-09-09 23:02:59.336 |  * The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
2014-09-09 23:02:59.336 | + exit_trap
2014-09-09 23:02:59.336 | + local r=1
2014-09-09 23:02:59.337 | ++ jobs -p
2014-09-09 23:02:59.337 | + jobs=
2014-09-09 23:02:59.337 | + [[ -n '' ]]
2014-09-09 23:02:59.338 | + exit 1

Any ideas on what could be causing this problem, or how to solve it? I've come across something related to this being a bug here (https://bugs.launchpad.net/devstack/+bug/1340660) but i'm not entirely sure it's the same thing and also I don't see a solution yet

Devstack fails to start apache2 - "Address already in use" : "could not bind to address"

Tried to install devstack icehouse on Ubuntu 14.04 with the following "localrc" file:

DEST=/opt/stack

# Logging
LOGFILE=$DEST/logs/stack.sh.log
VERBOSE=True
LOG_COLOR=False
SCREEN_LOGDIR=$DEST/logs/screen

# Credentials
ADMIN_PASSWORD=openstack
MYSQL_PASSWORD=openstack
RABBIT_PASSWORD=openstack
SERVICE_PASSWORD=openstack
SERVICE_TOKEN=tokentoken

# Github's Branch
GLANCE_BRANCH=stable/icehouse
HORIZON_BRANCH=stable/icehouse
KEYSTONE_BRANCH=stable/icehouse
NOVA_BRANCH=stable/icehouse
NEUTRON_BRANCH=stable/icehouse
HEAT_BRANCH=stable/icehouse
CEILOMETER_BRANCH=stable/icehouse

# Neutron - Networking Service
DISABLED_SERVICES=n-net
ENABLED_SERVICES+=,q-svc,q-agt,q-dhcp,q-l3,q-meta,q-metering,neutron

# Neutron - Load Balancing
ENABLED_SERVICES+=,q-lbaas

# Heat - Orchestration Service
ENABLED_SERVICES+=,heat,h-api,h-api-cfn,h-api-cw,h-eng
HEAT_STANDALONE=True

# Ceilometer - Metering Service (metering + alarming)
ENABLED_SERVICES+=,ceilometer-acompute,ceilometer-acentral,ceilometer-collector,ceilometer-api
ENABLED_SERVICES+=,ceilometer-alarm-notify,ceilometer-alarm-eval

All seems to be going well until Horizon /Apache are being started up, then the following error appears: "(98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000" and i can't seem to figure out what's causing it.

The installation log where the error appears is below. The apache2 error logs are actually empty.

2014-09-09 23:02:39.113 | + start_horizon
2014-09-09 23:02:39.113 | + restart_apache_server
2014-09-09 23:02:39.113 | + restart_service apache2
2014-09-09 23:02:39.113 | + is_ubuntu
2014-09-09 23:02:39.113 | + [[ -z deb ]]
2014-09-09 23:02:39.113 | + '[' deb = deb ']'
2014-09-09 23:02:39.114 | + sudo /usr/sbin/service apache2 restart
2014-09-09 23:02:39.124 |  * Restarting web server apache2
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:5000
2014-09-09 23:02:39.232 | no listening sockets available, shutting down
2014-09-09 23:02:39.232 | AH00015: Unable to open logs
2014-09-09 23:02:39.245 | Action 'start' failed.
2014-09-09 23:02:39.245 | The Apache error log may have more information.
2014-09-09 23:02:59.335 |    ...fail!
2014-09-09 23:02:59.336 |  * The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
2014-09-09 23:02:59.336 | + exit_trap
2014-09-09 23:02:59.336 | + local r=1
2014-09-09 23:02:59.337 | ++ jobs -p
2014-09-09 23:02:39.113 | + '[' deb = deb ']'
2014-09-09 23:02:39.114 | + sudo /usr/sbin/service apache2 restart
2014-09-09 23:02:39.124 |  * Restarting web server apache2
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:5000
2014-09-09 23:02:39.232 | no listening sockets available, shutting down
2014-09-09 23:02:39.232 | AH00015: Unable to open logs
2014-09-09 23:02:39.245 | Action 'start' failed.
2014-09-09 23:02:39.245 | The Apache error log may have more information.
2014-09-09 23:02:59.335 |    ...fail!
2014-09-09 23:02:59.336 |  * The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
2014-09-09 23:02:59.336 | + exit_trap
2014-09-09 23:02:59.336 | + local r=1
2014-09-09 23:02:59.337 | ++ jobs -p
2014-09-09 23:02:59.337 | + jobs=
2014-09-09 23:02:59.337 | + [[ -n '' ]]
2014-09-09 23:02:59.338 | + exit 1

Any ideas on what could be causing this problem, or how to solve it? I've come across something related to this being a bug here (https://bugs.launchpad.net/devstack/+bug/1340660) but i'm not entirely sure it's the same thing and also I don't see a solution yet

NB: The process behind port 5000, in my case is python (...and i have no idea why). If i kill it and restart apache, i can get to the horizon log-in page, but i can't log in with the given credentials.

Devstack fails to start apache2 - "Address already in use" : "could not bind to address"

Tried to install devstack icehouse on Ubuntu 14.04 with the following "localrc" file:

DEST=/opt/stack

# Logging
LOGFILE=$DEST/logs/stack.sh.log
VERBOSE=True
LOG_COLOR=False
SCREEN_LOGDIR=$DEST/logs/screen

# Credentials
ADMIN_PASSWORD=openstack
MYSQL_PASSWORD=openstack
RABBIT_PASSWORD=openstack
SERVICE_PASSWORD=openstack
SERVICE_TOKEN=tokentoken

# Github's Branch
GLANCE_BRANCH=stable/icehouse
HORIZON_BRANCH=stable/icehouse
KEYSTONE_BRANCH=stable/icehouse
NOVA_BRANCH=stable/icehouse
NEUTRON_BRANCH=stable/icehouse
HEAT_BRANCH=stable/icehouse
CEILOMETER_BRANCH=stable/icehouse

# Neutron - Networking Service
DISABLED_SERVICES=n-net
ENABLED_SERVICES+=,q-svc,q-agt,q-dhcp,q-l3,q-meta,q-metering,neutron

# Neutron - Load Balancing
ENABLED_SERVICES+=,q-lbaas

# Heat - Orchestration Service
ENABLED_SERVICES+=,heat,h-api,h-api-cfn,h-api-cw,h-eng
HEAT_STANDALONE=True

# Ceilometer - Metering Service (metering + alarming)
ENABLED_SERVICES+=,ceilometer-acompute,ceilometer-acentral,ceilometer-collector,ceilometer-api
ENABLED_SERVICES+=,ceilometer-alarm-notify,ceilometer-alarm-eval

All seems to be going well until Horizon /Apache are being started up, then the following error appears: "(98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000" and i can't seem to figure out what's causing it.

The installation log where the error appears is below. The apache2 error logs are actually empty.

2014-09-09 23:02:39.113 | + start_horizon
2014-09-09 23:02:39.113 | + restart_apache_server
2014-09-09 23:02:39.113 | + restart_service apache2
2014-09-09 23:02:39.113 | + is_ubuntu
2014-09-09 23:02:39.113 | + [[ -z deb ]]
2014-09-09 23:02:39.113 | + '[' deb = deb ']'
2014-09-09 23:02:39.114 | + sudo /usr/sbin/service apache2 restart
2014-09-09 23:02:39.124 |  * Restarting web server apache2
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:5000
2014-09-09 23:02:39.232 | no listening sockets available, shutting down
2014-09-09 23:02:39.232 | AH00015: Unable to open logs
2014-09-09 23:02:39.245 | Action 'start' failed.
2014-09-09 23:02:39.245 | The Apache error log may have more information.
2014-09-09 23:02:59.335 |    ...fail!
2014-09-09 23:02:59.336 |  * The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
2014-09-09 23:02:59.336 | + exit_trap
2014-09-09 23:02:59.336 | + local r=1
2014-09-09 23:02:59.337 | ++ jobs -p
2014-09-09 23:02:39.113 | + '[' deb = deb ']'
2014-09-09 23:02:39.114 | + sudo /usr/sbin/service apache2 restart
2014-09-09 23:02:39.124 |  * Restarting web server apache2
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:5000
2014-09-09 23:02:39.232 | no listening sockets available, shutting down
2014-09-09 23:02:39.232 | AH00015: Unable to open logs
2014-09-09 23:02:39.245 | Action 'start' failed.
2014-09-09 23:02:39.245 | The Apache error log may have more information.
2014-09-09 23:02:59.335 |    ...fail!
2014-09-09 23:02:59.336 |  * The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
2014-09-09 23:02:59.336 | + exit_trap
2014-09-09 23:02:59.336 | + local r=1
2014-09-09 23:02:59.337 | ++ jobs -p
2014-09-09 23:02:59.337 | + jobs=
2014-09-09 23:02:59.337 | + [[ -n '' ]]
2014-09-09 23:02:59.338 | + exit 1

Any ideas on what could be causing this problem, or how to solve it? I've come across something related to this being a bug here (https://bugs.launchpad.net/devstack/+bug/1340660) but i'm not entirely sure it's the same thing and also I don't see a solution yet

NB: The process behind port 5000, in my case is python (...and i have no idea why). If i kill it and restart apache, i can get to the horizon log-in page, but i can't log in with the given credentials.

The installation log where the error appears is below. The apache2 error logs are actually empty.

2014-09-09 23:02:39.113 | + start_horizon
2014-09-09 23:02:39.113 | + restart_apache_server
2014-09-09 23:02:39.113 | + restart_service apache2
2014-09-09 23:02:39.113 | + is_ubuntu
2014-09-09 23:02:39.113 | + [[ -z deb ]]
2014-09-09 23:02:39.113 | + '[' deb = deb ']'
2014-09-09 23:02:39.114 | + sudo /usr/sbin/service apache2 restart
2014-09-09 23:02:39.124 |  * Restarting web server apache2
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:5000
2014-09-09 23:02:39.232 | no listening sockets available, shutting down
2014-09-09 23:02:39.232 | AH00015: Unable to open logs
2014-09-09 23:02:39.245 | Action 'start' failed.
2014-09-09 23:02:39.245 | The Apache error log may have more information.
2014-09-09 23:02:59.335 |    ...fail!
2014-09-09 23:02:59.336 |  * The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
2014-09-09 23:02:59.336 | + exit_trap
2014-09-09 23:02:59.336 | + local r=1
2014-09-09 23:02:59.337 | ++ jobs -p
2014-09-09 23:02:39.113 | + '[' deb = deb ']'
2014-09-09 23:02:39.114 | + sudo /usr/sbin/service apache2 restart
2014-09-09 23:02:39.124 |  * Restarting web server apache2
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000
2014-09-09 23:02:39.231 | (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:5000
2014-09-09 23:02:39.232 | no listening sockets available, shutting down
2014-09-09 23:02:39.232 | AH00015: Unable to open logs
2014-09-09 23:02:39.245 | Action 'start' failed.
2014-09-09 23:02:39.245 | The Apache error log may have more information.
2014-09-09 23:02:59.335 |    ...fail!
2014-09-09 23:02:59.336 |  * The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
2014-09-09 23:02:59.336 | + exit_trap
2014-09-09 23:02:59.336 | + local r=1
2014-09-09 23:02:59.337 | ++ jobs -p
2014-09-09 23:02:59.337 | + jobs=
2014-09-09 23:02:59.337 | + [[ -n '' ]]
2014-09-09 23:02:59.338 | + exit 1