Revision history [back]

click to hide/show revision 1
initial version

checksum errors from internel vm NIC

anyone knows what this can be ? the vm not frozes just stucked waiting next tcp package ... mostly with ls /dev or top command

i already try to change NIC card driver and get errors too

checksum errors from internel vm NIC

root@compute1:~# tcpdump -i tapec1b492a-69 -vvv -XX | grep incorrect tcpdump: WARNING: tapec1b492a-69: no IPv4 address assigned tcpdump: listening on tapec1b492a-69, link-type EN10MB (Ethernet), capture size 65535 bytes

192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8947 (incorrect -> 0xab8a), seq 3787937642:3787939102, ack 2630473796, win 775, length 1460
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x20ba), seq 2112, ack 49, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x208a), seq 2112, ack 97, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x205a), seq 2112, ack 145, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x202a), seq 2112, ack 193, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1ffa), seq 2112, ack 241, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1fca), seq 2112, ack 289, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f9a), seq 2112, ack 337, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f6a), seq 2112, ack 385, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f3a), seq 2112, ack 433, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f0a), seq 2112, ack 481, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1eda), seq 2112, ack 529, win 775, length 0

checksum errors from internel vm NIC

anyone knows what this can be ? the vm not frozes just stucked waiting next tcp package ... mostly with ls /dev or top command

i already try to change NIC card driver and get errors too

checksum errors from internel vm NIC

root@compute1:~# tcpdump -i tapec1b492a-69 -vvv -XX | grep incorrect
tcpdump: WARNING: tapec1b492a-69: no IPv4 address assigned
tcpdump: listening on tapec1b492a-69, link-type EN10MB (Ethernet), capture size 65535 bytesbytes

192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8947 (incorrect -> 0xab8a), seq 3787937642:3787939102, ack 2630473796, win 775, length 1460
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x20ba), seq 2112, ack 49, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x208a), seq 2112, ack 97, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x205a), seq 2112, ack 145, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x202a), seq 2112, ack 193, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1ffa), seq 2112, ack 241, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1fca), seq 2112, ack 289, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f9a), seq 2112, ack 337, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f6a), seq 2112, ack 385, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f3a), seq 2112, ack 433, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f0a), seq 2112, ack 481, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1eda), seq 2112, ack 529, win 775, length 0

its looks like a TAP problem because he is droping ... before TAP is normal

here is my nova.conf

192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8947 (incorrect -> 0xab8a), seq 3787937642:3787939102, ack 2630473796, win 775, length 1460
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x20ba), seq 2112, ack 49, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x208a), seq 2112, ack 97, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x205a), seq 2112, ack 145, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x202a), seq 2112, ack 193, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1ffa), seq 2112, ack 241, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1fca), seq 2112, ack 289, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f9a), seq 2112, ack 337, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f6a), seq 2112, ack 385, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f3a), seq 2112, ack 433, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f0a), seq 2112, ack 481, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1eda), seq 2112, ack 529, win 775, length 0
    `    root@compute1:~# more /etc/nova/nova.conf
[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
iscsi_helper=tgtadm
libvirt_use_virtio_for_bridges=True
connection_type=libvirt
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
volumes_path=/var/lib/nova/volumes
enabled_apis=ec2,osapi_compute,metadata

auth_strategy = keystone

rpc_backend = rabbit
rabbit_host = controller
rabbit_password = tetudaTotosa

my_ip = 10.0.0.31
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.0.0.31
novncproxy_base_url = http://controller:6080/vnc_auto.html

glance_host = controller

network_api_class = nova.network.neutronv2.api.API
neutron_url = http://network:9696
neutron_auth_strategy = keystone
neutron_admin_tenant_name = service
neutron_admin_username = neutron
neutron_admin_password = tetudaTotosa
neutron_admin_auth_url = http://controller:35357/v2.0
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
security_group_api = neutron

compute_driver = libvirt.LibvirtDriver
cpu_mode=host-passthrough
cpu_allocation_ratio = 4.0

[libvirt]
virt_type = kvm

[database]
connection = mysql://nova:tetudaTotosa@controller/nova

[keystone_authtoken]
auth_uri = http://controller:5000
auth_host = controller
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = nova
admin_password = tetudaTotosa

`

checksum errors from internel vm NIC

anyone knows what this can be ? the vm not frozes just stucked waiting next tcp package ... mostly with ls /dev or top command

i already try to change NIC card driver and get errors too

checksum errors from internel vm NIC

root@compute1:~# tcpdump -i tapec1b492a-69 -vvv -XX | grep incorrect
tcpdump: WARNING: tapec1b492a-69: no IPv4 address assigned
tcpdump: listening on tapec1b492a-69, link-type EN10MB (Ethernet), capture size 65535 bytes

192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8947 (incorrect -> 0xab8a), seq 3787937642:3787939102, ack 2630473796, win 775, length 1460
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x20ba), seq 2112, ack 49, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x208a), seq 2112, ack 97, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x205a), seq 2112, ack 145, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x202a), seq 2112, ack 193, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1ffa), seq 2112, ack 241, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1fca), seq 2112, ack 289, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f9a), seq 2112, ack 337, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f6a), seq 2112, ack 385, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f3a), seq 2112, ack 433, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1f0a), seq 2112, ack 481, win 775, length 0
192.168.1.115.ssh > 192.168.0.181.20948: Flags [.], cksum 0x8393 (incorrect -> 0x1eda), seq 2112, ack 529, win 775, length 0

its looks like a TAP problem because he is droping ... before TAP is normal

here is my nova.conf

    `    root@compute1:~# more /etc/nova/nova.conf
[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
iscsi_helper=tgtadm
libvirt_use_virtio_for_bridges=True
connection_type=libvirt
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
volumes_path=/var/lib/nova/volumes
enabled_apis=ec2,osapi_compute,metadata

auth_strategy = keystone

rpc_backend = rabbit
rabbit_host = controller
rabbit_password = tetudaTotosa

my_ip = 10.0.0.31
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.0.0.31
novncproxy_base_url = http://controller:6080/vnc_auto.html

glance_host = controller

network_api_class = nova.network.neutronv2.api.API
neutron_url = http://network:9696
neutron_auth_strategy = keystone
neutron_admin_tenant_name = service
neutron_admin_username = neutron
neutron_admin_password = tetudaTotosa
neutron_admin_auth_url = http://controller:35357/v2.0
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
security_group_api = neutron

compute_driver = libvirt.LibvirtDriver
cpu_mode=host-passthrough
cpu_allocation_ratio = 4.0

[libvirt]
virt_type = kvm

[database]
connection = mysql://nova:tetudaTotosa@controller/nova

[keystone_authtoken]
auth_uri = http://controller:5000
auth_host = controller
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = nova
admin_password = tetudaTotosa

`
on ubuntu 14.04 - icehouse with neutron GRE