Ask Your Question

Revision history [back]

installation of packstack on FC20 fails with libselinux-ruby dependency

I am following the instructions at https://openstack.redhat.com/Quickstart. packstack --allinone tries to install puppet, which depends on rubygem-json. Installing the latter fails because the libselinux-ruby package on my system is too recent:

Error: Package: libselinux-ruby-2.1.13-19.fc20.x86_64 (fedora)
           Requires: libselinux = 2.1.13-19.fc20
           Installed: libselinux-2.2.1-6.fc20.i686 (installed)
               libselinux = 2.2.1-6.fc20
           Available: libselinux-2.1.13-19.fc20.i686 (fedora)
               libselinux = 2.1.13-19.fc20

I am running Fedora 20:

# cat /etc/fedora-release 
Fedora release 20 (Heisenbug)
# uname -a
Linux 5220.home 3.15.10-200.fc20.x86_64 #1 SMP Thu Aug 14 15:39:24 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Any suggestions what to do?