Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

./stack.sh creates problem with devstack

Hi,

I had my devstack running very good. Recently got some problem with lack of space in my VM when I sorted the problem and tried stacking devstack by ./stack.sh it gives me the following error. Please help

Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-root/python-heatclient Storing complete log in /home/student/.pip/pip.log ++ for reqs_file in '$1/requirements.txt' '$1/tools/pip-requires' ++ '[' -f /opt/stack/horizon/tools/pip-requires ']' ++ cd /opt/stack/horizon ++ python setup.py egg_info Traceback (most recent call last): File "setup.py", line 22, in <module> pbr=True) File "/usr/lib/python2.7/distutils/core.py", line 112, in setup _setup_distribution = dist = klass(attrs) File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 260, in __init__ File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 284, in fetch_build_eggs File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 569, in resolve dist = best.get(req.key) pkg_resources.VersionConflict: (pbr 0.5.18.6.gb24d4ca (/opt/stack/pbr), Requirement.parse('pbr>=0.5.21,<1.0')) ++ sudo HTTP_PROXY= HTTPS_PROXY= NO_PROXY= python setup.py develop Traceback (most recent call last): File "setup.py", line 22, in <module> pbr=True) File "/usr/lib/python2.7/distutils/core.py", line 112, in setup _setup_distribution = dist = klass(attrs) File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 260, in __init__ File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 284, in fetch_build_eggs File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 569, in resolve dist = best.get(req.key) pkg_resources.VersionConflict: (pbr 0.5.18.6.gb24d4ca (/opt/stack/pbr), Requirement.parse('pbr>=0.5.21,<1.0')) +++ failed +++ local r=1 ++++ jobs -p +++ kill +++ set +o xtrace

./stack.sh creates problem with devstack

Hi,

I had my devstack running very good. Recently got some problem with lack of space in my VM when I sorted the problem and tried stacking devstack by ./stack.sh it gives me the following error. Please help

Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-root/python-heatclient Storing complete log in /home/student/.pip/pip.log ++ for reqs_file in '$1/requirements.txt' '$1/tools/pip-requires' ++ '[' -f /opt/stack/horizon/tools/pip-requires ']' ++ cd /opt/stack/horizon ++ python setup.py egg_info Traceback (most recent call last): File "setup.py", line 22, in <module> pbr=True) File "/usr/lib/python2.7/distutils/core.py", line 112, in setup _setup_distribution = dist = klass(attrs) File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 260, in __init__ File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 284, in fetch_build_eggs fetch_build_eggs
File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 569, in resolve dist = best.get(req.key) pkg_resources.VersionConflict: (pbr 0.5.18.6.gb24d4ca (/opt/stack/pbr), Requirement.parse('pbr>=0.5.21,<1.0')) ++ sudo HTTP_PROXY= HTTPS_PROXY= NO_PROXY= python setup.py develop Traceback (most recent call last): File "setup.py", line 22, in <module> pbr=True) File "/usr/lib/python2.7/distutils/core.py", line 112, in setup _setup_distribution = dist = klass(attrs) File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 260, in __init__ File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 284, in fetch_build_eggs File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 569, in resolve dist = best.get(req.key) pkg_resources.VersionConflict: (pbr 0.5.18.6.gb24d4ca (/opt/stack/pbr), Requirement.parse('pbr>=0.5.21,<1.0')) +++ failed +++ local r=1 ++++ jobs -p +++ kill +++ set +o xtrace

./stack.sh creates problem with devstack

Hi,

I had my devstack running very good. Recently got some problem with lack of space in my VM when I sorted the problem and tried stacking devstack by ./stack.sh it gives me the following error. Please helphelp find the errror also in http://paste.openstack.org/show/45169/

Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-root/python-heatclient Storing complete log in /home/student/.pip/pip.log ++ for reqs_file in '$1/requirements.txt' '$1/tools/pip-requires' ++ '[' -f /opt/stack/horizon/tools/pip-requires ']' ++ cd /opt/stack/horizon ++ python setup.py egg_info Traceback (most recent call last): File "setup.py", line 22, in <module> pbr=True) File "/usr/lib/python2.7/distutils/core.py", line 112, in setup _setup_distribution = dist = klass(attrs) File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 260, in __init__ File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 284, in fetch_build_eggs
File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 569, in resolve dist = best.get(req.key) pkg_resources.VersionConflict: (pbr 0.5.18.6.gb24d4ca (/opt/stack/pbr), Requirement.parse('pbr>=0.5.21,<1.0')) ++ sudo HTTP_PROXY= HTTPS_PROXY= NO_PROXY= python setup.py develop Traceback (most recent call last): File "setup.py", line 22, in <module> pbr=True) File "/usr/lib/python2.7/distutils/core.py", line 112, in setup _setup_distribution = dist = klass(attrs) File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 260, in __init__ File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 284, in fetch_build_eggs File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 569, in resolve dist = best.get(req.key) pkg_resources.VersionConflict: (pbr 0.5.18.6.gb24d4ca (/opt/stack/pbr), Requirement.parse('pbr>=0.5.21,<1.0')) +++ failed +++ local r=1 ++++ jobs -p +++ kill +++ set +o xtrace

./stack.sh creates problem with devstack

Hi,

I had my devstack running very good. Recently got some problem with lack of space in my VM when I sorted the problem and tried stacking devstack by ./stack.sh it gives me the following error. Please help find the errror also in http://paste.openstack.org/show/45169/

Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-root/python-heatclient
Storing complete log in /home/student/.pip/pip.log
    ++ for reqs_file in '$1/requirements.txt' '$1/tools/pip-requires'
    ++ '[' -f /opt/stack/horizon/tools/pip-requires ']'
    ++ cd /opt/stack/horizon
    ++ python setup.py egg_info
    Traceback (most recent call last):
    File "setup.py", line 22, in <module>
    pbr=True)
    File "/usr/lib/python2.7/distutils/core.py", line 112, in setup
    _setup_distribution = dist = klass(attrs)
    File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 260, in     __init__
    File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 284, in          fetch_build_eggs 
File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 569, in resolve dist = best.get(req.key) pkg_resources.VersionConflict: (pbr 0.5.18.6.gb24d4ca (/opt/stack/pbr), Requirement.parse('pbr>=0.5.21,<1.0')) ++ sudo HTTP_PROXY= HTTPS_PROXY= NO_PROXY= python setup.py develop Traceback (most recent call last): File "setup.py", line 22, in <module> pbr=True) File "/usr/lib/python2.7/distutils/core.py", line 112, in setup _setup_distribution = dist = klass(attrs) File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 260, in __init__ File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/setuptools/dist.py", line 284, in fetch_build_eggs File "/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 569, in resolve dist = best.get(req.key) pkg_resources.VersionConflict: (pbr 0.5.18.6.gb24d4ca (/opt/stack/pbr), Requirement.parse('pbr>=0.5.21,<1.0')) +++ failed +++ local r=1 ++++ jobs -p +++ kill +++ set +o xtrace

xtrace