Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

OS Icehouse Networking Issue 3Nodesetup as VM with Neutron ML2 GRE

hello,

i am having trouble to get my Cloud working.

So first of all: i followed up the Training Guide to set up my 3 Nodes at Virtualbox and after this get on with the overall Installation Guide for Ubuntu Server 14.

After these steps my 3 Nodes knows each other and i can ping them by all.

I am using Openstack Neutron Networking with GRE and ML2.

I followed up the steps to creating my first internal network and get stuck on verifying connectivity at this...

I cannot ping the wanted router tenant gateway by any node of my setup.

The only way to connect to my internal net works from NetworkNode with following command:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ping 203.0.113.101

neutron agent list shows up smileys every where:

+--------------------------------------+--------------------+------------+-------+----------------+
| id                                   | agent_type         | host       | alive | admin_state_up |
+--------------------------------------+--------------------+------------+-------+----------------+
| 418d37e1-4e93-4075-9b59-0725cfd46144 | DHCP agent         | network    | :-)   | True           |
| 8d67f6d2-742f-4f3c-8622-598e7c86b861 | Metadata agent     | network    | :-)   | True           |
| cac088e6-9244-4083-86f4-5ce6223bd108 | L3 agent           | network    | :-)   | True           |
| d682e617-1e82-4d2c-9a27-b6ede2e68317 | Open vSwitch agent | network    | :-)   | True           |
| e88c8f0b-c471-4ff6-a3a5-ace6a68929c2 | Open vSwitch agent | computeone | :-)   | True           |
+--------------------------------------+--------------------+------------+-------+----------------+

all other services does works fine true:

I had setup tenant, some default rules for security group and setup of network shows up the mentioned informations. More over namespaces are used.

command: ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ip a show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever

and same for router shwos up:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
15: qr-f7463438-68: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:84:57:d4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-f7463438-68
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe84:57d4/64 scope link 
       valid_lft forever preferred_lft forever
16: qg-fa3fc507-5c: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:49:cb:c8 brd ff:ff:ff:ff:ff:ff
    inet 203.0.113.101/24 brd 203.0.113.255 scope global qg-fa3fc507-5c
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe49:cbc8/64 scope link 
       valid_lft forever preferred_lft forever

dunno if it does help but here are my networkconfigurations of

NetworkNode:

# The loopback network interface auto lo iface lo inet loopback

The primary network interface - VBOX Adapter 4 NAT

auto eth3
iface eth3 inet dhcp

# vboxnet0 MM
auto eth0
iface eth0 inet static
address 10.10.10.52
netmask 255.255.255.0

# vboxnet1 TN
auto eth1
iface eth1 inet static
address 10.20.20.52
netmask 255.255.255.0


# vboxnet2 API-Network
auto eth2
iface eth2 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
address 192.168.100.52
netmask 255.255.255.0
gateway 192.168.100.1
dns-nameservers 8.8.8.8

Controller Node:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface - VBOX Adapter 3 eth2 NAT
auto eth2
iface eth2 inet dhcp

#vboxnet0 Openstack Management - VBOX Adapter 1 eth0
auto eth0
iface eth0 inet static
address 10.10.10.51
netmask 255.255.255.0

#vboxnet2 Openstack API - VBOX Adapter 2 eth1
auto eth1
iface eth1 inet static
address 192.168.100.51
netmask 255.255.255.0

ComputeNode:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth2
iface eth2 inet dhcp

#vboxnet0 - VBOX Adapter 1 MM
auto eth0
iface eth0 inet static
address 10.10.10.53
netmask 255.255.255.0

#vboxnet1 - VBOX Adapter 2 TN
auto eth1
iface eth1 inet static
address 10.20.20.53
netmask 255.255.255.0

As you see my Management Network is 10.10.10.xx the Tunnel Network is 10.20.20.xx and the api/external network is 192.168.100.xx

the highst ethx is used for NAT to get in the internet by all vms

one last thing i mentioned:

In my Dashboard in looking networktopology the router-gateway (203.0.113.101) is DOWN!!! But router interface 192.168.1.1 is ACTIVE

Morover i am not be able to get an instance running. I hat setup all but after creation like in linked docu the state is error with "no valid hosts" found... Maybe it is reasoned by my not working network?

SO PLEASE help me i dunno what to do and what wrong, ... if you need additional information i can update. If Possible blz a nooby tut if you see a problem..

THANKS A LOT

Cannot ping router tenant gateway by OS Nodes and www by Instance

hello, setup-> OS Icehouse Networking Issue 3Nodesetup as VM with Neutron ML2 GRE

hello,

UPDATE: Changed some configs and uncomment rabbit_pass in each... So at now i can start an instance but nevertheless i am not able to ping tenant gateway with ping -c 4 203.0.113.101 or the vm itself it just works with defined namespace and netns command...

What do you think, maybe it is a problem of Virtualbox because of i cannot not even ping some internetaddress by the 3 OS Nodes... and anywhere i read that this is an issue of virtualbox. Do you think that can be a reason why i cannot ping my tenant gateway with normal ping command?

New Problem arrives... the startet instance is not be able to ping internetadresses!!!

i am having trouble to get my Cloud working.

So first of all: i followed up the Training Guide to set up my 3 Nodes at Virtualbox and after this get on with the overall Installation Guide for Ubuntu Server 14.

After these steps my 3 Nodes knows each other and i can ping them by all.

I am using Openstack Neutron Networking with GRE and ML2.

I followed up the steps to creating my first internal network and get stuck on verifying connectivity at this...

I cannot ping the wanted router tenant gateway by any node of my setup.

The only way to connect to my internal net works from NetworkNode with following command:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ping 203.0.113.101

neutron agent list shows up smileys every where:

+--------------------------------------+--------------------+------------+-------+----------------+
| id                                   | agent_type         | host       | alive | admin_state_up |
+--------------------------------------+--------------------+------------+-------+----------------+
| 418d37e1-4e93-4075-9b59-0725cfd46144 | DHCP agent         | network    | :-)   | True           |
| 8d67f6d2-742f-4f3c-8622-598e7c86b861 | Metadata agent     | network    | :-)   | True           |
| cac088e6-9244-4083-86f4-5ce6223bd108 | L3 agent           | network    | :-)   | True           |
| d682e617-1e82-4d2c-9a27-b6ede2e68317 | Open vSwitch agent | network    | :-)   | True           |
| e88c8f0b-c471-4ff6-a3a5-ace6a68929c2 | Open vSwitch agent | computeone | :-)   | True           |
+--------------------------------------+--------------------+------------+-------+----------------+

all other services does works fine true:

I had setup tenant, some default rules for security group and setup of network shows up the mentioned informations. More over namespaces are used.

command: ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ip a show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever

and same for router shwos up:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
15: qr-f7463438-68: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:84:57:d4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-f7463438-68
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe84:57d4/64 scope link 
       valid_lft forever preferred_lft forever
16: qg-fa3fc507-5c: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:49:cb:c8 brd ff:ff:ff:ff:ff:ff
    inet 203.0.113.101/24 brd 203.0.113.255 scope global qg-fa3fc507-5c
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe49:cbc8/64 scope link 
       valid_lft forever preferred_lft forever

dunno if it does help but here are my networkconfigurations of

NetworkNode:

# The loopback network interface auto lo iface lo inet loopback

The primary network interface - VBOX Adapter 4 NAT

auto eth3
iface eth3 inet dhcp

# vboxnet0 MM
auto eth0
iface eth0 inet static
address 10.10.10.52
netmask 255.255.255.0

# vboxnet1 TN
auto eth1
iface eth1 inet static
address 10.20.20.52
netmask 255.255.255.0


# vboxnet2 API-Network
auto eth2
iface eth2 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
address 192.168.100.52
netmask 255.255.255.0
gateway 192.168.100.1
dns-nameservers 8.8.8.8

Controller Node:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface - VBOX Adapter 3 eth2 NAT
auto eth2
iface eth2 inet dhcp

#vboxnet0 Openstack Management - VBOX Adapter 1 eth0
auto eth0
iface eth0 inet static
address 10.10.10.51
netmask 255.255.255.0

#vboxnet2 Openstack API - VBOX Adapter 2 eth1
auto eth1
iface eth1 inet static
address 192.168.100.51
netmask 255.255.255.0

ComputeNode:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth2
iface eth2 inet dhcp

#vboxnet0 - VBOX Adapter 1 MM
auto eth0
iface eth0 inet static
address 10.10.10.53
netmask 255.255.255.0

#vboxnet1 - VBOX Adapter 2 TN
auto eth1
iface eth1 inet static
address 10.20.20.53
netmask 255.255.255.0

As you see my Management Network is 10.10.10.xx the Tunnel Network is 10.20.20.xx and the api/external network is 192.168.100.xx

the highst ethx is used for NAT to get in the internet by all vms

one last thing i mentioned:

In my Dashboard in looking networktopology the router-gateway (203.0.113.101) is DOWN!!! But router interface 192.168.1.1 is ACTIVE

Morover i am not be able to get an instance running. I hat setup all but after creation like in linked docu the state is error with "no valid hosts" found... Maybe it is reasoned by my not working network?

SO PLEASE help me i dunno what to do and what wrong, ... if you need additional information i can update. If Possible blz a nooby tut if you see a problem..

THANKS A LOT

Cannot ping router tenant gateway by OS Nodes and www by Instance

hello, setup-> OS Icehouse Networking Issue 3Nodesetup as VM with Neutron ML2 GRE

UPDATE: Changed some configs and uncomment rabbit_pass in each... So at now i can start an instance but nevertheless i am not able to ping tenant gateway with ping -c 4 203.0.113.101 or the vm itself it just works with defined namespace and netns command...

What do you think, maybe it is a problem of Virtualbox because of i cannot not even ping some internetaddress by the 3 OS Nodes... and anywhere i read that this is an issue of virtualbox. Do you think that can be a reason why i cannot ping my tenant gateway with normal ping command?

New Problem arrives... the startet instance is not be able to ping internetadresses!!!

What works is to telnet google.com at port 80 by the 3 OS Nodes. But telnet by instance doesn´t work too with error message: bad adresss....


i am having trouble to get my Cloud working.

So first of all: i followed up the Training Guide to set up my 3 Nodes at Virtualbox and after this get on with the overall Installation Guide for Ubuntu Server 14.

After these steps my 3 Nodes knows each other and i can ping them by all.

I am using Openstack Neutron Networking with GRE and ML2.

I followed up the steps to creating my first internal network and get stuck on verifying connectivity at this...

I cannot ping the wanted router tenant gateway by any node of my setup.

The only way to connect to my internal net works from NetworkNode with following command:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ping 203.0.113.101

neutron agent list shows up smileys every where:

+--------------------------------------+--------------------+------------+-------+----------------+
| id                                   | agent_type         | host       | alive | admin_state_up |
+--------------------------------------+--------------------+------------+-------+----------------+
| 418d37e1-4e93-4075-9b59-0725cfd46144 | DHCP agent         | network    | :-)   | True           |
| 8d67f6d2-742f-4f3c-8622-598e7c86b861 | Metadata agent     | network    | :-)   | True           |
| cac088e6-9244-4083-86f4-5ce6223bd108 | L3 agent           | network    | :-)   | True           |
| d682e617-1e82-4d2c-9a27-b6ede2e68317 | Open vSwitch agent | network    | :-)   | True           |
| e88c8f0b-c471-4ff6-a3a5-ace6a68929c2 | Open vSwitch agent | computeone | :-)   | True           |
+--------------------------------------+--------------------+------------+-------+----------------+

all other services does works fine true:

I had setup tenant, some default rules for security group and setup of network shows up the mentioned informations. More over namespaces are used.

command: ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ip a show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever

and same for router shwos up:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
15: qr-f7463438-68: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:84:57:d4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-f7463438-68
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe84:57d4/64 scope link 
       valid_lft forever preferred_lft forever
16: qg-fa3fc507-5c: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:49:cb:c8 brd ff:ff:ff:ff:ff:ff
    inet 203.0.113.101/24 brd 203.0.113.255 scope global qg-fa3fc507-5c
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe49:cbc8/64 scope link 
       valid_lft forever preferred_lft forever

dunno if it does help but here are my networkconfigurations of

NetworkNode:

# The loopback network interface auto lo iface lo inet loopback

The primary network interface - VBOX Adapter 4 NAT

auto eth3
iface eth3 inet dhcp

# vboxnet0 MM
auto eth0
iface eth0 inet static
address 10.10.10.52
netmask 255.255.255.0

# vboxnet1 TN
auto eth1
iface eth1 inet static
address 10.20.20.52
netmask 255.255.255.0


# vboxnet2 API-Network
auto eth2
iface eth2 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
address 192.168.100.52
netmask 255.255.255.0
gateway 192.168.100.1
dns-nameservers 8.8.8.8

Controller Node:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface - VBOX Adapter 3 eth2 NAT
auto eth2
iface eth2 inet dhcp

#vboxnet0 Openstack Management - VBOX Adapter 1 eth0
auto eth0
iface eth0 inet static
address 10.10.10.51
netmask 255.255.255.0

#vboxnet2 Openstack API - VBOX Adapter 2 eth1
auto eth1
iface eth1 inet static
address 192.168.100.51
netmask 255.255.255.0

ComputeNode:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth2
iface eth2 inet dhcp

#vboxnet0 - VBOX Adapter 1 MM
auto eth0
iface eth0 inet static
address 10.10.10.53
netmask 255.255.255.0

#vboxnet1 - VBOX Adapter 2 TN
auto eth1
iface eth1 inet static
address 10.20.20.53
netmask 255.255.255.0

As you see my Management Network is 10.10.10.xx the Tunnel Network is 10.20.20.xx and the api/external network is 192.168.100.xx

the highst ethx is used for NAT to get in the internet by all vms

one last thing i mentioned:

In my Dashboard in looking networktopology the router-gateway (203.0.113.101) is DOWN!!! But router interface 192.168.1.1 is ACTIVE

Morover i am not be able to get an instance running. I hat setup all but after creation like in linked docu the state is error with "no valid hosts" found... Maybe it is reasoned by my not working network?

SO PLEASE help me i dunno what to do and what wrong, ... if you need additional information i can update. If Possible blz a nooby tut if you see a problem..

THANKS A LOT

Cannot ping router tenant gateway by OS Nodes and www by Instance

hello, setup-> OS Icehouse Networking Issue 3Nodesetup as VM with Neutron ML2 GRE

UPDATE: Changed some configs and uncomment rabbit_pass in each... So at now i can start an instance but nevertheless i am not able to ping tenant gateway with ping -c 4 203.0.113.101 or the vm itself it just works with defined namespace and netns command...

What do you think, maybe it is a problem of Virtualbox because of i cannot not even ping some internetaddress by the 3 OS Nodes... and anywhere i read that this is an issue of virtualbox. Do you think that can be a reason why i cannot ping my tenant gateway with normal ping command?

New Problem arrives... the startet instance is not be able to ping internetadresses!!!

What works is to telnet google.com at port 80 by the 3 OS Nodes. But telnet by instance doesn´t work too with error message: bad adresss....

i addressed some more: tried to get some information on qdhcp point with:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 tcpdump -ln -i tap87176921-56

so there are no packets captured at this point!?

NO_ONE with ideas?


i am having trouble to get my Cloud working.

So first of all: i followed up the Training Guide to set up my 3 Nodes at Virtualbox and after this get on with the overall Installation Guide for Ubuntu Server 14.

After these steps my 3 Nodes knows each other and i can ping them by all.

I am using Openstack Neutron Networking with GRE and ML2.

I followed up the steps to creating my first internal network and get stuck on verifying connectivity at this...

I cannot ping the wanted router tenant gateway by any node of my setup.

The only way to connect to my internal net works from NetworkNode with following command:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ping 203.0.113.101

neutron agent list shows up smileys every where:

+--------------------------------------+--------------------+------------+-------+----------------+
| id                                   | agent_type         | host       | alive | admin_state_up |
+--------------------------------------+--------------------+------------+-------+----------------+
| 418d37e1-4e93-4075-9b59-0725cfd46144 | DHCP agent         | network    | :-)   | True           |
| 8d67f6d2-742f-4f3c-8622-598e7c86b861 | Metadata agent     | network    | :-)   | True           |
| cac088e6-9244-4083-86f4-5ce6223bd108 | L3 agent           | network    | :-)   | True           |
| d682e617-1e82-4d2c-9a27-b6ede2e68317 | Open vSwitch agent | network    | :-)   | True           |
| e88c8f0b-c471-4ff6-a3a5-ace6a68929c2 | Open vSwitch agent | computeone | :-)   | True           |
+--------------------------------------+--------------------+------------+-------+----------------+

all other services does works fine true:

I had setup tenant, some default rules for security group and setup of network shows up the mentioned informations. More over namespaces are used.

command: ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ip a show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever

and same for router shwos up:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
15: qr-f7463438-68: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:84:57:d4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-f7463438-68
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe84:57d4/64 scope link 
       valid_lft forever preferred_lft forever
16: qg-fa3fc507-5c: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:49:cb:c8 brd ff:ff:ff:ff:ff:ff
    inet 203.0.113.101/24 brd 203.0.113.255 scope global qg-fa3fc507-5c
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe49:cbc8/64 scope link 
       valid_lft forever preferred_lft forever

dunno if it does help but here are my networkconfigurations of

NetworkNode:

# The loopback network interface auto lo iface lo inet loopback

The primary network interface - VBOX Adapter 4 NAT

auto eth3
iface eth3 inet dhcp

# vboxnet0 MM
auto eth0
iface eth0 inet static
address 10.10.10.52
netmask 255.255.255.0

# vboxnet1 TN
auto eth1
iface eth1 inet static
address 10.20.20.52
netmask 255.255.255.0


# vboxnet2 API-Network
auto eth2
iface eth2 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
address 192.168.100.52
netmask 255.255.255.0
gateway 192.168.100.1
dns-nameservers 8.8.8.8

Controller Node:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface - VBOX Adapter 3 eth2 NAT
auto eth2
iface eth2 inet dhcp

#vboxnet0 Openstack Management - VBOX Adapter 1 eth0
auto eth0
iface eth0 inet static
address 10.10.10.51
netmask 255.255.255.0

#vboxnet2 Openstack API - VBOX Adapter 2 eth1
auto eth1
iface eth1 inet static
address 192.168.100.51
netmask 255.255.255.0

ComputeNode:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth2
iface eth2 inet dhcp

#vboxnet0 - VBOX Adapter 1 MM
auto eth0
iface eth0 inet static
address 10.10.10.53
netmask 255.255.255.0

#vboxnet1 - VBOX Adapter 2 TN
auto eth1
iface eth1 inet static
address 10.20.20.53
netmask 255.255.255.0

As you see my Management Network is 10.10.10.xx the Tunnel Network is 10.20.20.xx and the api/external network is 192.168.100.xx

the highst ethx is used for NAT to get in the internet by all vms

one last thing i mentioned:

In my Dashboard in looking networktopology the router-gateway (203.0.113.101) is DOWN!!! But router interface 192.168.1.1 is ACTIVE

Morover i am not be able to get an instance running. I hat setup all but after creation like in linked docu the state is error with "no valid hosts" found... Maybe it is reasoned by my not working network?

SO PLEASE help me i dunno what to do and what wrong, ... if you need additional information i can update. If Possible blz a nooby tut if you see a problem..

THANKS A LOT

Cannot ping router tenant gateway by OS Nodes and www by Instance

hello, setup-> OS Icehouse Networking Issue 3Nodesetup as VM with Neutron ML2 GRE

UPDATE: Changed some configs and uncomment rabbit_pass in each... So at now i can start an instance but nevertheless i am not able to ping tenant gateway with ping -c 4 203.0.113.101 or the vm itself it just works with defined namespace and netns command...

What do you think, maybe it is a problem of Virtualbox because of i cannot not even ping some internetaddress by the 3 OS Nodes... and anywhere i read that this is an issue of virtualbox. Do you think that can be a reason why i cannot ping my tenant gateway with normal ping command?

New Problem arrives... the startet instance is not be able to ping internetadresses!!!

What works is to telnet google.com at port 80 by the 3 OS Nodes. But telnet by instance doesn´t work too with error message: bad adresss....

i addressed some more: tried to get some information on qdhcp point with:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 tcpdump -ln -i tap87176921-56

so there are no packets captured at this point!?

NO_ONE with ideas?

Update 3 (curl command by instance)

cannot upload the image because of carma:

$ uname -a
Linux cirros 3.2.0-60-.... #91-Ubuntu ...
$ curl http://169.254.169.254   (For what is this command?)
1.0
2007-01-19
2007-03-01
2007-08-29
2007-10-10
2007-12-15
2008-02-01
2008-09-01
2009-04-04

Basic information!!!

i am having trouble to get my Cloud working.

So first of all: i followed up the Training Guide to set up my 3 Nodes at Virtualbox and after this get on with the overall Installation Guide for Ubuntu Server 14.

After these steps my 3 Nodes knows each other and i can ping them by all.

I am using Openstack Neutron Networking with GRE and ML2.

I followed up the steps to creating my first internal network and get stuck on verifying connectivity at this...

I cannot ping the wanted router tenant gateway by any node of my setup.

The only way to connect to my internal net works from NetworkNode with following command:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ping 203.0.113.101

neutron agent list shows up smileys every where:

+--------------------------------------+--------------------+------------+-------+----------------+
| id                                   | agent_type         | host       | alive | admin_state_up |
+--------------------------------------+--------------------+------------+-------+----------------+
| 418d37e1-4e93-4075-9b59-0725cfd46144 | DHCP agent         | network    | :-)   | True           |
| 8d67f6d2-742f-4f3c-8622-598e7c86b861 | Metadata agent     | network    | :-)   | True           |
| cac088e6-9244-4083-86f4-5ce6223bd108 | L3 agent           | network    | :-)   | True           |
| d682e617-1e82-4d2c-9a27-b6ede2e68317 | Open vSwitch agent | network    | :-)   | True           |
| e88c8f0b-c471-4ff6-a3a5-ace6a68929c2 | Open vSwitch agent | computeone | :-)   | True           |
+--------------------------------------+--------------------+------------+-------+----------------+

all other services does works fine true:

I had setup tenant, some default rules for security group and setup of network shows up the mentioned informations. More over namespaces are used.

command: ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ip a show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever

and same for router shwos up:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
15: qr-f7463438-68: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:84:57:d4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-f7463438-68
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe84:57d4/64 scope link 
       valid_lft forever preferred_lft forever
16: qg-fa3fc507-5c: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:49:cb:c8 brd ff:ff:ff:ff:ff:ff
    inet 203.0.113.101/24 brd 203.0.113.255 scope global qg-fa3fc507-5c
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe49:cbc8/64 scope link 
       valid_lft forever preferred_lft forever

dunno if it does help but here are my networkconfigurations of

NetworkNode:

# The loopback network interface auto lo iface lo inet loopback

The primary network interface - VBOX Adapter 4 NAT

auto eth3
iface eth3 inet dhcp

# vboxnet0 MM
auto eth0
iface eth0 inet static
address 10.10.10.52
netmask 255.255.255.0

# vboxnet1 TN
auto eth1
iface eth1 inet static
address 10.20.20.52
netmask 255.255.255.0


# vboxnet2 API-Network
auto eth2
iface eth2 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
address 192.168.100.52
netmask 255.255.255.0
gateway 192.168.100.1
dns-nameservers 8.8.8.8

Controller Node:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface - VBOX Adapter 3 eth2 NAT
auto eth2
iface eth2 inet dhcp

#vboxnet0 Openstack Management - VBOX Adapter 1 eth0
auto eth0
iface eth0 inet static
address 10.10.10.51
netmask 255.255.255.0

#vboxnet2 Openstack API - VBOX Adapter 2 eth1
auto eth1
iface eth1 inet static
address 192.168.100.51
netmask 255.255.255.0

ComputeNode:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth2
iface eth2 inet dhcp

#vboxnet0 - VBOX Adapter 1 MM
auto eth0
iface eth0 inet static
address 10.10.10.53
netmask 255.255.255.0

#vboxnet1 - VBOX Adapter 2 TN
auto eth1
iface eth1 inet static
address 10.20.20.53
netmask 255.255.255.0

As you see my Management Network is 10.10.10.xx the Tunnel Network is 10.20.20.xx and the api/external network is 192.168.100.xx

the highst ethx is used for NAT to get in the internet by all vms

one last thing i mentioned:

In my Dashboard in looking networktopology the router-gateway (203.0.113.101) is DOWN!!! But router interface 192.168.1.1 is ACTIVE

Morover i am not be able to get an instance running. I hat setup all but after creation like in linked docu the state is error with "no valid hosts" found... Maybe it is reasoned by my not working network?

SO PLEASE help me i dunno what to do and what wrong, ... if you need additional information i can update. If Possible blz a nooby tut if you see a problem..

THANKS A LOT

Cannot ping router tenant gateway by OS Nodes and www by Instance

hello, setup-> OS Icehouse Networking Issue 3Nodesetup as VM with Neutron ML2 GRE

UPDATE: Changed some configs and uncomment rabbit_pass in each... So at now i can start an instance but nevertheless i am not able to ping tenant gateway with ping -c 4 203.0.113.101 or the vm itself it just works with defined namespace and netns command...

What do you think, maybe it is a problem of Virtualbox because of i cannot not even ping some internetaddress by the 3 OS Nodes... and anywhere i read that this is an issue of virtualbox. Do you think that can be a reason why i cannot ping my tenant gateway with normal ping command?

New Problem arrives... the startet instance is not be able to ping internetadresses!!!

What works is to telnet google.com at port 80 by the 3 OS Nodes. But telnet by instance doesn´t work too with error message: bad adresss....

i addressed some more: tried to get some information on qdhcp point with:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 tcpdump -ln -i tap87176921-56

so there are no packets captured at this point!?

NO_ONE with ideas?

Update 3 (curl command by instance)

cannot upload the image because of carma:

$ uname -a
Linux cirros 3.2.0-60-.... #91-Ubuntu ...
$ curl http://169.254.169.254   (For what is this command?)
1.0
2007-01-19
2007-03-01
2007-08-29
2007-10-10
2007-12-15
2008-02-01
2008-09-01
2009-04-04
$ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
...
3packets transmitted 0 packets received

Rules for security group are set:

root@controller:~# neutron security-group-list
+--------------------------------------+---------+-------------+
| id                                   | name    | description |
+--------------------------------------+---------+-------------+
| 38e7edaa-87cd-4c28-a4cf-c1f32d4bf11a | default | default     |
| 7e5d3f0b-84ce-448c-8b76-69ceab021e21 | default | default     |
+--------------------------------------+---------+-------------+
root@controller:~# neutron security-group-rule-list
+--------------------------------------+----------------+-----------+----------+------------------+--------------+
| id                                   | security_group | direction | protocol | remote_ip_prefix | remote_group |
+--------------------------------------+----------------+-----------+----------+------------------+--------------+
| 112161bf-95a2-4404-9ea7-042df57aa796 | default        | egress    | tcp      |                  |              |
| 1213d327-311f-4436-b385-8e3949f2cd15 | default        | egress    | icmp     |                  |              |
| 2c2b1140-df8d-47c9-998b-f5b3cc43272f | default        | egress    | tcp      |                  |              |
| 3532502f-e6d0-4342-a99e-e55204e635cf | default        | ingress   |          |                  | default      |
| 44e718a5-7c26-4970-9769-ceafe33add13 | default        | ingress   |          |                  | default      |
| 5a6123dd-7811-4efa-ada8-85b3f872b34f | default        | ingress   | tcp      |                  |              |
| 7ccc9707-58ea-46ee-b8e3-40769e395c38 | default        | ingress   | icmp     |                  |              |
| 85663bce-c777-4791-95ab-40143bb3e24d | default        | egress    |          |                  |              |
| 86baec12-302c-4915-b86b-fa71c444e69d | default        | ingress   | tcp      |                  |              |
| 93b579ae-25cf-4a03-9556-f2a7a05fe771 | default        | egress    |          |                  |              |
| 97fc51aa-7de0-4e99-ace1-081690e594c0 | default        | egress    | icmp     |                  |              |
| c948c663-e7a4-4fdd-be07-87338af09011 | default        | ingress   | icmp     |                  |              |
| d084fa39-7908-46a6-ae63-96d4e9b5a1b0 | default        | egress    |          |                  |              |
| d97d7977-c1f4-4fd7-a985-38b4aa2b8545 | default        | ingress   |          |                  | default      |
| ec0ba6a4-720b-44fa-84f1-ee227fb8124e | default        | ingress   |          |                  | default      |
| f5b898a0-ef90-424d-9df5-c734657974ef | default        | egress    |          |                  |              |
+--------------------------------------+----------------+-----------+----------+------------------+--------------+

So what is meant by availability zone?

THX

Basic information!!!

i am having trouble to get my Cloud working.

So first of all: i followed up the Training Guide to set up my 3 Nodes at Virtualbox and after this get on with the overall Installation Guide for Ubuntu Server 14.

After these steps my 3 Nodes knows each other and i can ping them by all.

I am using Openstack Neutron Networking with GRE and ML2.

I followed up the steps to creating my first internal network and get stuck on verifying connectivity at this...

I cannot ping the wanted router tenant gateway by any node of my setup.

The only way to connect to my internal net works from NetworkNode with following command:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ping 203.0.113.101

neutron agent list shows up smileys every where:

+--------------------------------------+--------------------+------------+-------+----------------+
| id                                   | agent_type         | host       | alive | admin_state_up |
+--------------------------------------+--------------------+------------+-------+----------------+
| 418d37e1-4e93-4075-9b59-0725cfd46144 | DHCP agent         | network    | :-)   | True           |
| 8d67f6d2-742f-4f3c-8622-598e7c86b861 | Metadata agent     | network    | :-)   | True           |
| cac088e6-9244-4083-86f4-5ce6223bd108 | L3 agent           | network    | :-)   | True           |
| d682e617-1e82-4d2c-9a27-b6ede2e68317 | Open vSwitch agent | network    | :-)   | True           |
| e88c8f0b-c471-4ff6-a3a5-ace6a68929c2 | Open vSwitch agent | computeone | :-)   | True           |
+--------------------------------------+--------------------+------------+-------+----------------+

all other services does works fine true:

I had setup tenant, some default rules for security group and setup of network shows up the mentioned informations. More over namespaces are used.

command: ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ip a show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever

and same for router shwos up:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
15: qr-f7463438-68: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:84:57:d4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-f7463438-68
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe84:57d4/64 scope link 
       valid_lft forever preferred_lft forever
16: qg-fa3fc507-5c: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:49:cb:c8 brd ff:ff:ff:ff:ff:ff
    inet 203.0.113.101/24 brd 203.0.113.255 scope global qg-fa3fc507-5c
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe49:cbc8/64 scope link 
       valid_lft forever preferred_lft forever

dunno if it does help but here are my networkconfigurations of

NetworkNode:

# The loopback network interface auto lo iface lo inet loopback

The primary network interface - VBOX Adapter 4 NAT

auto eth3
iface eth3 inet dhcp

# vboxnet0 MM
auto eth0
iface eth0 inet static
address 10.10.10.52
netmask 255.255.255.0

# vboxnet1 TN
auto eth1
iface eth1 inet static
address 10.20.20.52
netmask 255.255.255.0


# vboxnet2 API-Network
auto eth2
iface eth2 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
address 192.168.100.52
netmask 255.255.255.0
gateway 192.168.100.1
dns-nameservers 8.8.8.8

Controller Node:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface - VBOX Adapter 3 eth2 NAT
auto eth2
iface eth2 inet dhcp

#vboxnet0 Openstack Management - VBOX Adapter 1 eth0
auto eth0
iface eth0 inet static
address 10.10.10.51
netmask 255.255.255.0

#vboxnet2 Openstack API - VBOX Adapter 2 eth1
auto eth1
iface eth1 inet static
address 192.168.100.51
netmask 255.255.255.0

ComputeNode:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth2
iface eth2 inet dhcp

#vboxnet0 - VBOX Adapter 1 MM
auto eth0
iface eth0 inet static
address 10.10.10.53
netmask 255.255.255.0

#vboxnet1 - VBOX Adapter 2 TN
auto eth1
iface eth1 inet static
address 10.20.20.53
netmask 255.255.255.0

As you see my Management Network is 10.10.10.xx the Tunnel Network is 10.20.20.xx and the api/external network is 192.168.100.xx

the highst ethx is used for NAT to get in the internet by all vms

one last thing i mentioned:

In my Dashboard in looking networktopology the router-gateway (203.0.113.101) is DOWN!!! But router interface 192.168.1.1 is ACTIVE

Morover i am not be able to get an instance running. I hat setup all but after creation like in linked docu the state is error with "no valid hosts" found... Maybe it is reasoned by my not working network?

SO PLEASE help me i dunno what to do and what wrong, ... if you need additional information i can update. If Possible blz a nooby tut if you see a problem..

THANKS A LOT

Cannot ping router tenant gateway by OS Nodes and www by Instance

hello, setup-> OS Icehouse Networking Issue 3Nodesetup as VM with Neutron ML2 GRE

UPDATE: Changed some configs and uncomment rabbit_pass in each... So at now i can start an instance but nevertheless i am not able to ping tenant gateway with ping -c 4 203.0.113.101 or the vm itself it just works with defined namespace and netns command...

What do you think, maybe it is a problem of Virtualbox because of i cannot not even ping some internetaddress by the 3 OS Nodes... and anywhere i read that this is an issue of virtualbox. Do you think that can be a reason why i cannot ping my tenant gateway with normal ping command?

New Problem arrives... the startet instance is not be able to ping internetadresses!!!

What works is to telnet google.com at port 80 by the 3 OS Nodes. But telnet by instance doesn´t work too with error message: bad adresss....

i addressed some more: tried to get some information on qdhcp point with:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 tcpdump -ln -i tap87176921-56

so there are no packets captured at this point!?

NO_ONE with ideas?

Update 3 (curl command by instance)

cannot upload the image because of carma:

$ uname -a
Linux cirros 3.2.0-60-.... #91-Ubuntu ...
$ curl http://169.254.169.254   (For what is this command?)
1.0
2007-01-19
2007-03-01
2007-08-29
2007-10-10
2007-12-15
2008-02-01
2008-09-01
2009-04-04
$ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
...
3packets transmitted 0 packets received
 

Rules for security group are set: set:

root@controller:~# neutron security-group-list
+--------------------------------------+---------+-------------+
| id                                   | name    | description |
+--------------------------------------+---------+-------------+
| 38e7edaa-87cd-4c28-a4cf-c1f32d4bf11a | default | default     |
| 7e5d3f0b-84ce-448c-8b76-69ceab021e21 | default | default     |
+--------------------------------------+---------+-------------+
root@controller:~# neutron security-group-rule-list
+--------------------------------------+----------------+-----------+----------+------------------+--------------+
| id                                   | security_group | direction | protocol | remote_ip_prefix | remote_group |
+--------------------------------------+----------------+-----------+----------+------------------+--------------+
| 112161bf-95a2-4404-9ea7-042df57aa796 | default        | egress    | tcp      |                  |              |
| 1213d327-311f-4436-b385-8e3949f2cd15 | default        | egress    | icmp     |                  |              |
| 2c2b1140-df8d-47c9-998b-f5b3cc43272f | default        | egress    | tcp      |                  |              |
| 3532502f-e6d0-4342-a99e-e55204e635cf | default        | ingress   |          |                  | default      |
| 44e718a5-7c26-4970-9769-ceafe33add13 | default        | ingress   |          |                  | default      |
| 5a6123dd-7811-4efa-ada8-85b3f872b34f | default        | ingress   | tcp      |                  |              |
| 7ccc9707-58ea-46ee-b8e3-40769e395c38 | default        | ingress   | icmp     |                  |              |
| 85663bce-c777-4791-95ab-40143bb3e24d | default        | egress    |          |                  |              |
| 86baec12-302c-4915-b86b-fa71c444e69d | default        | ingress   | tcp      |                  |              |
| 93b579ae-25cf-4a03-9556-f2a7a05fe771 | default        | egress    |          |                  |              |
| 97fc51aa-7de0-4e99-ace1-081690e594c0 | default        | egress    | icmp     |                  |              |
| c948c663-e7a4-4fdd-be07-87338af09011 | default        | ingress   | icmp     |                  |              |
| d084fa39-7908-46a6-ae63-96d4e9b5a1b0 | default        | egress    |          |                  |              |
| d97d7977-c1f4-4fd7-a985-38b4aa2b8545 | default        | ingress   |          |                  | default      |
| ec0ba6a4-720b-44fa-84f1-ee227fb8124e | default        | ingress   |          |                  | default      |
| f5b898a0-ef90-424d-9df5-c734657974ef | default        | egress    |          |                  |              |
+--------------------------------------+----------------+-----------+----------+------------------+--------------+

root@controller:~# nova secgroup-list
+--------------------------------------+---------+-------------+
| Id                                   | Name    | Description |
+--------------------------------------+---------+-------------+
| 38e7edaa-87cd-4c28-a4cf-c1f32d4bf11a | default | default     |
+--------------------------------------+---------+-------------+
root@controller:~# nova secgroup-list-rules default
+-------------+-----------+---------+-----------+--------------+
| IP Protocol | From Port | To Port | IP Range  | Source Group |
+-------------+-----------+---------+-----------+--------------+
|             |           |         |           | default      |
| tcp         | 22        | 22      | 0.0.0.0/0 |              |
| icmp        | -1        | -1      | 0.0.0.0/0 |              |
|             |           |         |           | default      |
+-------------+-----------+---------+-----------+--------------+

So what is meant by availability zone?

THX


Basic information!!!

i am having trouble to get my Cloud working.

So first of all: i followed up the Training Guide to set up my 3 Nodes at Virtualbox and after this get on with the overall Installation Guide for Ubuntu Server 14.

After these steps my 3 Nodes knows each other and i can ping them by all.

I am using Openstack Neutron Networking with GRE and ML2.

I followed up the steps to creating my first internal network and get stuck on verifying connectivity at this...

I cannot ping the wanted router tenant gateway by any node of my setup.

The only way to connect to my internal net works from NetworkNode with following command:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ping 203.0.113.101

neutron agent list shows up smileys every where:

+--------------------------------------+--------------------+------------+-------+----------------+
| id                                   | agent_type         | host       | alive | admin_state_up |
+--------------------------------------+--------------------+------------+-------+----------------+
| 418d37e1-4e93-4075-9b59-0725cfd46144 | DHCP agent         | network    | :-)   | True           |
| 8d67f6d2-742f-4f3c-8622-598e7c86b861 | Metadata agent     | network    | :-)   | True           |
| cac088e6-9244-4083-86f4-5ce6223bd108 | L3 agent           | network    | :-)   | True           |
| d682e617-1e82-4d2c-9a27-b6ede2e68317 | Open vSwitch agent | network    | :-)   | True           |
| e88c8f0b-c471-4ff6-a3a5-ace6a68929c2 | Open vSwitch agent | computeone | :-)   | True           |
+--------------------------------------+--------------------+------------+-------+----------------+

all other services does works fine true:

I had setup tenant, some default rules for security group and setup of network shows up the mentioned informations. More over namespaces are used.

command: ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ip a show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever

and same for router shwos up:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
15: qr-f7463438-68: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:84:57:d4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-f7463438-68
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe84:57d4/64 scope link 
       valid_lft forever preferred_lft forever
16: qg-fa3fc507-5c: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:49:cb:c8 brd ff:ff:ff:ff:ff:ff
    inet 203.0.113.101/24 brd 203.0.113.255 scope global qg-fa3fc507-5c
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe49:cbc8/64 scope link 
       valid_lft forever preferred_lft forever

dunno if it does help but here are my networkconfigurations of

NetworkNode:

# The loopback network interface auto lo iface lo inet loopback

The primary network interface - VBOX Adapter 4 NAT

auto eth3
iface eth3 inet dhcp

# vboxnet0 MM
auto eth0
iface eth0 inet static
address 10.10.10.52
netmask 255.255.255.0

# vboxnet1 TN
auto eth1
iface eth1 inet static
address 10.20.20.52
netmask 255.255.255.0


# vboxnet2 API-Network
auto eth2
iface eth2 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
address 192.168.100.52
netmask 255.255.255.0
gateway 192.168.100.1
dns-nameservers 8.8.8.8

Controller Node:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface - VBOX Adapter 3 eth2 NAT
auto eth2
iface eth2 inet dhcp

#vboxnet0 Openstack Management - VBOX Adapter 1 eth0
auto eth0
iface eth0 inet static
address 10.10.10.51
netmask 255.255.255.0

#vboxnet2 Openstack API - VBOX Adapter 2 eth1
auto eth1
iface eth1 inet static
address 192.168.100.51
netmask 255.255.255.0

ComputeNode:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth2
iface eth2 inet dhcp

#vboxnet0 - VBOX Adapter 1 MM
auto eth0
iface eth0 inet static
address 10.10.10.53
netmask 255.255.255.0

#vboxnet1 - VBOX Adapter 2 TN
auto eth1
iface eth1 inet static
address 10.20.20.53
netmask 255.255.255.0

As you see my Management Network is 10.10.10.xx the Tunnel Network is 10.20.20.xx and the api/external network is 192.168.100.xx

the highst ethx is used for NAT to get in the internet by all vms

one last thing i mentioned:

In my Dashboard in looking networktopology the router-gateway (203.0.113.101) is DOWN!!! But router interface 192.168.1.1 is ACTIVE

Morover i am not be able to get an instance running. I hat setup all but after creation like in linked docu the state is error with "no valid hosts" found... Maybe it is reasoned by my not working network?

SO PLEASE help me i dunno what to do and what wrong, ... if you need additional information i can update. If Possible blz a nooby tut if you see a problem..

THANKS A LOT

Cannot ping router tenant gateway by OS Nodes and www by Instance

hello, setup-> OS Icehouse Networking Issue 3Nodesetup as VM with Neutron ML2 GRE

UPDATE: UPDATE1+2: Changed some configs and uncomment rabbit_pass in each... So at now i can start an instance but nevertheless i am not able to ping tenant gateway with ping -c 4 203.0.113.101 or the vm itself it just works with defined namespace and netns command...

What do you think, maybe it is a problem of Virtualbox because of i cannot not even ping some internetaddress by the 3 OS Nodes... and anywhere i read that this is an issue of virtualbox. Do you think that can be a reason why i cannot ping my tenant gateway with normal ping command?

New Problem arrives... the startet instance is not be able to ping internetadresses!!!

What works is to telnet google.com at port 80 by the 3 OS Nodes. But telnet by instance doesn´t work too with error message: bad adresss....

i addressed some more: tried to get some information on qdhcp point with:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 tcpdump -ln -i tap87176921-56

so there are no packets captured at this point!?

NO_ONE with ideas?

Update 3 3 (curl command by instance)

cannot upload the image because of carma:

$ uname -a
Linux cirros 3.2.0-60-.... #91-Ubuntu ...
$ curl http://169.254.169.254   (For what is this command?)
1.0
2007-01-19
2007-03-01
2007-08-29
2007-10-10
2007-12-15
2008-02-01
2008-09-01
2009-04-04
$ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
...
3packets transmitted 0 packets received

Rules for security group are set:

root@controller:~# neutron security-group-list
+--------------------------------------+---------+-------------+
| id                                   | name    | description |
+--------------------------------------+---------+-------------+
| 38e7edaa-87cd-4c28-a4cf-c1f32d4bf11a | default | default     |
| 7e5d3f0b-84ce-448c-8b76-69ceab021e21 | default | default     |
+--------------------------------------+---------+-------------+
root@controller:~# neutron security-group-rule-list
+--------------------------------------+----------------+-----------+----------+------------------+--------------+
| id                                   | security_group | direction | protocol | remote_ip_prefix | remote_group |
+--------------------------------------+----------------+-----------+----------+------------------+--------------+
| 112161bf-95a2-4404-9ea7-042df57aa796 | default        | egress    | tcp      |                  |              |
| 1213d327-311f-4436-b385-8e3949f2cd15 | default        | egress    | icmp     |                  |              |
| 2c2b1140-df8d-47c9-998b-f5b3cc43272f | default        | egress    | tcp      |                  |              |
| 3532502f-e6d0-4342-a99e-e55204e635cf | default        | ingress   |          |                  | default      |
| 44e718a5-7c26-4970-9769-ceafe33add13 | default        | ingress   |          |                  | default      |
| 5a6123dd-7811-4efa-ada8-85b3f872b34f | default        | ingress   | tcp      |                  |              |
| 7ccc9707-58ea-46ee-b8e3-40769e395c38 | default        | ingress   | icmp     |                  |              |
| 85663bce-c777-4791-95ab-40143bb3e24d | default        | egress    |          |                  |              |
| 86baec12-302c-4915-b86b-fa71c444e69d | default        | ingress   | tcp      |                  |              |
| 93b579ae-25cf-4a03-9556-f2a7a05fe771 | default        | egress    |          |                  |              |
| 97fc51aa-7de0-4e99-ace1-081690e594c0 | default        | egress    | icmp     |                  |              |
| c948c663-e7a4-4fdd-be07-87338af09011 | default        | ingress   | icmp     |                  |              |
| d084fa39-7908-46a6-ae63-96d4e9b5a1b0 | default        | egress    |          |                  |              |
| d97d7977-c1f4-4fd7-a985-38b4aa2b8545 | default        | ingress   |          |                  | default      |
| ec0ba6a4-720b-44fa-84f1-ee227fb8124e | default        | ingress   |          |                  | default      |
| f5b898a0-ef90-424d-9df5-c734657974ef | default        | egress    |          |                  |              |
+--------------------------------------+----------------+-----------+----------+------------------+--------------+

root@controller:~# nova secgroup-list
+--------------------------------------+---------+-------------+
| Id                                   | Name    | Description |
+--------------------------------------+---------+-------------+
| 38e7edaa-87cd-4c28-a4cf-c1f32d4bf11a | default | default     |
+--------------------------------------+---------+-------------+
root@controller:~# nova secgroup-list-rules default
+-------------+-----------+---------+-----------+--------------+
| IP Protocol | From Port | To Port | IP Range  | Source Group |
+-------------+-----------+---------+-----------+--------------+
|             |           |         |           | default      |
| tcp         | 22        | 22      | 0.0.0.0/0 |              |
| icmp        | -1        | -1      | 0.0.0.0/0 |              |
|             |           |         |           | default      |
+-------------+-----------+---------+-----------+--------------+

So what is meant by availability zone?UPDATE 4 (ovs)

ovs-vsctl show:

root@network:~# ovs-vsctl show
e5fcf9e6-74bc-4764-8acb-8ada5c7da200
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
        Port "tap87176921-56"
            tag: 1
            Interface "tap87176921-56"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qr-f7463438-68"
            tag: 1
            Interface "qr-f7463438-68"
                type: internal
    Bridge br-ex
        Port "qg-fa3fc507-5c"
            Interface "qg-fa3fc507-5c"
                type: internal
        Port "eth2"
            Interface "eth2"
        Port br-ex
            Interface br-ex
                type: internal
    Bridge br-tun
        Port "gre-0a141435"
            Interface "gre-0a141435"
                type: gre
                options: {in_key=flow, local_ip="10.20.20.52", out_key=flow, remote_ip="10.20.20.53"}
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    ovs_version: "2.0.1"

IFCONFIG:

root@network:~# ifconfig
br-ex     Link encap:Ethernet  Hardware Adresse 08:00:27:a5:c8:5e  
          inet Adresse:192.168.100.52  Bcast:192.168.100.255  Maske:255.255.255.0
          inet6-Adresse: fe80::e033:38ff:feab:375/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING  MTU:1500  Metrik:1
          RX-Pakete:79 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:16 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:12070 (12.0 KB)  TX-Bytes:5292 (5.2 KB)

br-int    Link encap:Ethernet  Hardware Adresse 16:30:98:44:f3:4b  
          inet6-Adresse: fe80::1453:94ff:fe85:6281/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING  MTU:1500  Metrik:1
          RX-Pakete:53 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:8 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:4334 (4.3 KB)  TX-Bytes:648 (648.0 B)

br-tun    Link encap:Ethernet  Hardware Adresse ae:60:49:c9:70:4c  
          inet6-Adresse: fe80::f46f:f3ff:fe53:aa4f/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING  MTU:1500  Metrik:1
          RX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:8 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:0 (0.0 B)  TX-Bytes:648 (648.0 B)

eth0      Link encap:Ethernet  Hardware Adresse 08:00:27:4e:6b:6f  
          inet Adresse:10.10.10.52  Bcast:10.10.10.255  Maske:255.255.255.0
          inet6-Adresse: fe80::a00:27ff:fe4e:6b6f/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:117821 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:81499 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:11799002 (11.7 MB)  TX-Bytes:8233453 (8.2 MB)

eth1      Link encap:Ethernet  Hardware Adresse 08:00:27:c7:c1:50  
          inet Adresse:10.20.20.52  Bcast:10.20.20.255  Maske:255.255.255.0
          inet6-Adresse: fe80::a00:27ff:fec7:c150/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:111 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:27 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:17487 (17.4 KB)  TX-Bytes:2390 (2.3 KB)

eth2      Link encap:Ethernet  Hardware Adresse 08:00:27:a5:c8:5e  
          inet6-Adresse: fe80::a00:27ff:fea5:c85e/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:697 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:36 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:561119 (561.1 KB)  TX-Bytes:6940 (6.9 KB)

eth3      Link encap:Ethernet  Hardware Adresse 08:00:27:cf:41:83  
          inet Adresse:10.0.5.15  Bcast:10.0.5.255  Maske:255.255.255.0
          inet6-Adresse: fe80::a00:27ff:fecf:4183/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:95 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:103 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:11653 (11.6 KB)  TX-Bytes:8673 (8.6 KB)

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX-Pakete:21 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:21 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:2978 (2.9 KB)  TX-Bytes:2978 (2.9 KB)

Both commands on NetworkNode (neutron)


Basic information!!!

i am having trouble to get my Cloud working.

So first of all: i followed up the Training Guide to set up my 3 Nodes at Virtualbox and after this get on with the overall Installation Guide for Ubuntu Server 14.

After these steps my 3 Nodes knows each other and i can ping them by all.

I am using Openstack Neutron Networking with GRE and ML2.

I followed up the steps to creating my first internal network and get stuck on verifying connectivity at this...

I cannot ping the wanted router tenant gateway by any node of my setup.

The only way to connect to my internal net works from NetworkNode with following command:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ping 203.0.113.101

neutron agent list shows up smileys every where:

+--------------------------------------+--------------------+------------+-------+----------------+
| id                                   | agent_type         | host       | alive | admin_state_up |
+--------------------------------------+--------------------+------------+-------+----------------+
| 418d37e1-4e93-4075-9b59-0725cfd46144 | DHCP agent         | network    | :-)   | True           |
| 8d67f6d2-742f-4f3c-8622-598e7c86b861 | Metadata agent     | network    | :-)   | True           |
| cac088e6-9244-4083-86f4-5ce6223bd108 | L3 agent           | network    | :-)   | True           |
| d682e617-1e82-4d2c-9a27-b6ede2e68317 | Open vSwitch agent | network    | :-)   | True           |
| e88c8f0b-c471-4ff6-a3a5-ace6a68929c2 | Open vSwitch agent | computeone | :-)   | True           |
+--------------------------------------+--------------------+------------+-------+----------------+

all other services does works fine true:

I had setup tenant, some default rules for security group and setup of network shows up the mentioned informations. More over namespaces are used.

command: ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ip a show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever

and same for router shwos up:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
15: qr-f7463438-68: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:84:57:d4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-f7463438-68
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe84:57d4/64 scope link 
       valid_lft forever preferred_lft forever
16: qg-fa3fc507-5c: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:49:cb:c8 brd ff:ff:ff:ff:ff:ff
    inet 203.0.113.101/24 brd 203.0.113.255 scope global qg-fa3fc507-5c
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe49:cbc8/64 scope link 
       valid_lft forever preferred_lft forever

dunno if it does help but here are my networkconfigurations of

NetworkNode:

# The loopback network interface auto lo iface lo inet loopback

The primary network interface - VBOX Adapter 4 NAT

auto eth3
iface eth3 inet dhcp

# vboxnet0 MM
auto eth0
iface eth0 inet static
address 10.10.10.52
netmask 255.255.255.0

# vboxnet1 TN
auto eth1
iface eth1 inet static
address 10.20.20.52
netmask 255.255.255.0


# vboxnet2 API-Network
auto eth2
iface eth2 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
address 192.168.100.52
netmask 255.255.255.0
gateway 192.168.100.1
dns-nameservers 8.8.8.8

Controller Node:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface - VBOX Adapter 3 eth2 NAT
auto eth2
iface eth2 inet dhcp

#vboxnet0 Openstack Management - VBOX Adapter 1 eth0
auto eth0
iface eth0 inet static
address 10.10.10.51
netmask 255.255.255.0

#vboxnet2 Openstack API - VBOX Adapter 2 eth1
auto eth1
iface eth1 inet static
address 192.168.100.51
netmask 255.255.255.0

ComputeNode:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth2
iface eth2 inet dhcp

#vboxnet0 - VBOX Adapter 1 MM
auto eth0
iface eth0 inet static
address 10.10.10.53
netmask 255.255.255.0

#vboxnet1 - VBOX Adapter 2 TN
auto eth1
iface eth1 inet static
address 10.20.20.53
netmask 255.255.255.0

As you see my Management Network is 10.10.10.xx the Tunnel Network is 10.20.20.xx and the api/external network is 192.168.100.xx

the highst ethx is used for NAT to get in the internet by all vms

one last thing i mentioned:

In my Dashboard in looking networktopology the router-gateway (203.0.113.101) is DOWN!!! But router interface 192.168.1.1 is ACTIVE

Morover i am not be able to get an instance running. I hat setup all but after creation like in linked docu the state is error with "no valid hosts" found... Maybe it is reasoned by my not working network?

SO PLEASE help me i dunno what to do and what wrong, ... if you need additional information i can update. If Possible blz a nooby tut if you see a problem..

THANKS A LOT

Cannot ping router tenant gateway by OS Nodes and www by Instance

hello, setup-> OS Icehouse Networking Issue 3Nodesetup as VM with Neutron ML2 GRE

UPDATE5 exec namespace qrouter

   root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 iptables -S -t nat
-P PREROUTING ACCEPT
-P INPUT ACCEPT
-P OUTPUT ACCEPT
-P POSTROUTING ACCEPT
-N neutron-l3-agent-OUTPUT
-N neutron-l3-agent-POSTROUTING
-N neutron-l3-agent-PREROUTING
-N neutron-l3-agent-float-snat
-N neutron-l3-agent-snat
-N neutron-postrouting-bottom
-A PREROUTING -j neutron-l3-agent-PREROUTING
-A OUTPUT -j neutron-l3-agent-OUTPUT
-A POSTROUTING -j neutron-l3-agent-POSTROUTING
-A POSTROUTING -j neutron-postrouting-bottom
-A neutron-l3-agent-POSTROUTING ! -i qg-fa3fc507-5c ! -o qg-fa3fc507-5c -m conntrack ! --ctstate DNAT -j ACCEPT
-A neutron-l3-agent-PREROUTING -d 169.254.169.254/32 -p tcp -m tcp --dport 80 -j REDIRECT --to-ports 9697
-A neutron-l3-agent-snat -j neutron-l3-agent-float-snat
-A neutron-l3-agent-snat -s 192.168.1.0/24 -j SNAT --to-source 203.0.113.101
-A neutron-postrouting-bottom -j neutron-l3-agent-snat
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 iptables -S -t nat | grep 169.254 
-A neutron-l3-agent-PREROUTING -d 169.254.169.254/32 -p tcp -m tcp --dport 80 -j REDIRECT --to-ports 9697
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 iptables netstat -antp
Bad argument `netstat'
Try `iptables -h' or 'iptables --help' for more information.
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 iptables -netstat -antp
iptables v1.4.21: unknown option "iptables"

by starting the instance i saw in log

checking http://169.254.169.254/2009-04-04/instance-id
failed 1/20: up 4.87. request failed
...
failed 20/20: up 46.93. request failed

UPDATE1+2: Changed some configs and uncomment rabbit_pass in each... So at now i can start an instance but nevertheless i am not able to ping tenant gateway with ping -c 4 203.0.113.101 or the vm itself it just works with defined namespace and netns command...

What do you think, maybe it is a problem of Virtualbox because of i cannot not even ping some internetaddress by the 3 OS Nodes... and anywhere i read that this is an issue of virtualbox. Do you think that can be a reason why i cannot ping my tenant gateway with normal ping command?

New Problem arrives... the startet instance is not be able to ping internetadresses!!!

What works is to telnet google.com at port 80 by the 3 OS Nodes. But telnet by instance doesn´t work too with error message: bad adresss....

i addressed some more: tried to get some information on qdhcp point with:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 tcpdump -ln -i tap87176921-56

so there are no packets captured at this point!?

NO_ONE with ideas?

Update 3 (curl command by instance)

cannot upload the image because of carma:

$ uname -a
Linux cirros 3.2.0-60-.... #91-Ubuntu ...
$ curl http://169.254.169.254   (For what is this command?)
1.0
2007-01-19
2007-03-01
2007-08-29
2007-10-10
2007-12-15
2008-02-01
2008-09-01
2009-04-04
$ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
...
3packets transmitted 0 packets received

Rules for security group are set:

root@controller:~# neutron security-group-list
+--------------------------------------+---------+-------------+
| id                                   | name    | description |
+--------------------------------------+---------+-------------+
| 38e7edaa-87cd-4c28-a4cf-c1f32d4bf11a | default | default     |
| 7e5d3f0b-84ce-448c-8b76-69ceab021e21 | default | default     |
+--------------------------------------+---------+-------------+
root@controller:~# neutron security-group-rule-list
+--------------------------------------+----------------+-----------+----------+------------------+--------------+
| id                                   | security_group | direction | protocol | remote_ip_prefix | remote_group |
+--------------------------------------+----------------+-----------+----------+------------------+--------------+
| 112161bf-95a2-4404-9ea7-042df57aa796 | default        | egress    | tcp      |                  |              |
| 1213d327-311f-4436-b385-8e3949f2cd15 | default        | egress    | icmp     |                  |              |
| 2c2b1140-df8d-47c9-998b-f5b3cc43272f | default        | egress    | tcp      |                  |              |
| 3532502f-e6d0-4342-a99e-e55204e635cf | default        | ingress   |          |                  | default      |
| 44e718a5-7c26-4970-9769-ceafe33add13 | default        | ingress   |          |                  | default      |
| 5a6123dd-7811-4efa-ada8-85b3f872b34f | default        | ingress   | tcp      |                  |              |
| 7ccc9707-58ea-46ee-b8e3-40769e395c38 | default        | ingress   | icmp     |                  |              |
| 85663bce-c777-4791-95ab-40143bb3e24d | default        | egress    |          |                  |              |
| 86baec12-302c-4915-b86b-fa71c444e69d | default        | ingress   | tcp      |                  |              |
| 93b579ae-25cf-4a03-9556-f2a7a05fe771 | default        | egress    |          |                  |              |
| 97fc51aa-7de0-4e99-ace1-081690e594c0 | default        | egress    | icmp     |                  |              |
| c948c663-e7a4-4fdd-be07-87338af09011 | default        | ingress   | icmp     |                  |              |
| d084fa39-7908-46a6-ae63-96d4e9b5a1b0 | default        | egress    |          |                  |              |
| d97d7977-c1f4-4fd7-a985-38b4aa2b8545 | default        | ingress   |          |                  | default      |
| ec0ba6a4-720b-44fa-84f1-ee227fb8124e | default        | ingress   |          |                  | default      |
| f5b898a0-ef90-424d-9df5-c734657974ef | default        | egress    |          |                  |              |
+--------------------------------------+----------------+-----------+----------+------------------+--------------+

root@controller:~# nova secgroup-list
+--------------------------------------+---------+-------------+
| Id                                   | Name    | Description |
+--------------------------------------+---------+-------------+
| 38e7edaa-87cd-4c28-a4cf-c1f32d4bf11a | default | default     |
+--------------------------------------+---------+-------------+
root@controller:~# nova secgroup-list-rules default
+-------------+-----------+---------+-----------+--------------+
| IP Protocol | From Port | To Port | IP Range  | Source Group |
+-------------+-----------+---------+-----------+--------------+
|             |           |         |           | default      |
| tcp         | 22        | 22      | 0.0.0.0/0 |              |
| icmp        | -1        | -1      | 0.0.0.0/0 |              |
|             |           |         |           | default      |
+-------------+-----------+---------+-----------+--------------+

UPDATE 4 (ovs)

ovs-vsctl show:

root@network:~# ovs-vsctl show
e5fcf9e6-74bc-4764-8acb-8ada5c7da200
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
        Port "tap87176921-56"
            tag: 1
            Interface "tap87176921-56"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qr-f7463438-68"
            tag: 1
            Interface "qr-f7463438-68"
                type: internal
    Bridge br-ex
        Port "qg-fa3fc507-5c"
            Interface "qg-fa3fc507-5c"
                type: internal
        Port "eth2"
            Interface "eth2"
        Port br-ex
            Interface br-ex
                type: internal
    Bridge br-tun
        Port "gre-0a141435"
            Interface "gre-0a141435"
                type: gre
                options: {in_key=flow, local_ip="10.20.20.52", out_key=flow, remote_ip="10.20.20.53"}
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    ovs_version: "2.0.1"

IFCONFIG:

root@network:~# ifconfig
br-ex     Link encap:Ethernet  Hardware Adresse 08:00:27:a5:c8:5e  
          inet Adresse:192.168.100.52  Bcast:192.168.100.255  Maske:255.255.255.0
          inet6-Adresse: fe80::e033:38ff:feab:375/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING  MTU:1500  Metrik:1
          RX-Pakete:79 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:16 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:12070 (12.0 KB)  TX-Bytes:5292 (5.2 KB)

br-int    Link encap:Ethernet  Hardware Adresse 16:30:98:44:f3:4b  
          inet6-Adresse: fe80::1453:94ff:fe85:6281/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING  MTU:1500  Metrik:1
          RX-Pakete:53 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:8 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:4334 (4.3 KB)  TX-Bytes:648 (648.0 B)

br-tun    Link encap:Ethernet  Hardware Adresse ae:60:49:c9:70:4c  
          inet6-Adresse: fe80::f46f:f3ff:fe53:aa4f/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING  MTU:1500  Metrik:1
          RX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:8 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:0 (0.0 B)  TX-Bytes:648 (648.0 B)

eth0      Link encap:Ethernet  Hardware Adresse 08:00:27:4e:6b:6f  
          inet Adresse:10.10.10.52  Bcast:10.10.10.255  Maske:255.255.255.0
          inet6-Adresse: fe80::a00:27ff:fe4e:6b6f/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:117821 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:81499 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:11799002 (11.7 MB)  TX-Bytes:8233453 (8.2 MB)

eth1      Link encap:Ethernet  Hardware Adresse 08:00:27:c7:c1:50  
          inet Adresse:10.20.20.52  Bcast:10.20.20.255  Maske:255.255.255.0
          inet6-Adresse: fe80::a00:27ff:fec7:c150/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:111 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:27 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:17487 (17.4 KB)  TX-Bytes:2390 (2.3 KB)

eth2      Link encap:Ethernet  Hardware Adresse 08:00:27:a5:c8:5e  
          inet6-Adresse: fe80::a00:27ff:fea5:c85e/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:697 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:36 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:561119 (561.1 KB)  TX-Bytes:6940 (6.9 KB)

eth3      Link encap:Ethernet  Hardware Adresse 08:00:27:cf:41:83  
          inet Adresse:10.0.5.15  Bcast:10.0.5.255  Maske:255.255.255.0
          inet6-Adresse: fe80::a00:27ff:fecf:4183/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:95 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:103 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:11653 (11.6 KB)  TX-Bytes:8673 (8.6 KB)

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX-Pakete:21 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:21 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:2978 (2.9 KB)  TX-Bytes:2978 (2.9 KB)

Both commands on NetworkNode (neutron)


Basic information!!!

i am having trouble to get my Cloud working.

So first of all: i followed up the Training Guide to set up my 3 Nodes at Virtualbox and after this get on with the overall Installation Guide for Ubuntu Server 14.

After these steps my 3 Nodes knows each other and i can ping them by all.

I am using Openstack Neutron Networking with GRE and ML2.

I followed up the steps to creating my first internal network and get stuck on verifying connectivity at this...

I cannot ping the wanted router tenant gateway by any node of my setup.

The only way to connect to my internal net works from NetworkNode with following command:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ping 203.0.113.101

neutron agent list shows up smileys every where:

+--------------------------------------+--------------------+------------+-------+----------------+
| id                                   | agent_type         | host       | alive | admin_state_up |
+--------------------------------------+--------------------+------------+-------+----------------+
| 418d37e1-4e93-4075-9b59-0725cfd46144 | DHCP agent         | network    | :-)   | True           |
| 8d67f6d2-742f-4f3c-8622-598e7c86b861 | Metadata agent     | network    | :-)   | True           |
| cac088e6-9244-4083-86f4-5ce6223bd108 | L3 agent           | network    | :-)   | True           |
| d682e617-1e82-4d2c-9a27-b6ede2e68317 | Open vSwitch agent | network    | :-)   | True           |
| e88c8f0b-c471-4ff6-a3a5-ace6a68929c2 | Open vSwitch agent | computeone | :-)   | True           |
+--------------------------------------+--------------------+------------+-------+----------------+

all other services does works fine true:

I had setup tenant, some default rules for security group and setup of network shows up the mentioned informations. More over namespaces are used.

command: ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ip a show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever

and same for router shwos up:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
15: qr-f7463438-68: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:84:57:d4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-f7463438-68
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe84:57d4/64 scope link 
       valid_lft forever preferred_lft forever
16: qg-fa3fc507-5c: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:49:cb:c8 brd ff:ff:ff:ff:ff:ff
    inet 203.0.113.101/24 brd 203.0.113.255 scope global qg-fa3fc507-5c
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe49:cbc8/64 scope link 
       valid_lft forever preferred_lft forever

dunno if it does help but here are my networkconfigurations of

NetworkNode:

# The loopback network interface auto lo iface lo inet loopback

The primary network interface - VBOX Adapter 4 NAT

auto eth3
iface eth3 inet dhcp

# vboxnet0 MM
auto eth0
iface eth0 inet static
address 10.10.10.52
netmask 255.255.255.0

# vboxnet1 TN
auto eth1
iface eth1 inet static
address 10.20.20.52
netmask 255.255.255.0


# vboxnet2 API-Network
auto eth2
iface eth2 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
address 192.168.100.52
netmask 255.255.255.0
gateway 192.168.100.1
dns-nameservers 8.8.8.8

Controller Node:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface - VBOX Adapter 3 eth2 NAT
auto eth2
iface eth2 inet dhcp

#vboxnet0 Openstack Management - VBOX Adapter 1 eth0
auto eth0
iface eth0 inet static
address 10.10.10.51
netmask 255.255.255.0

#vboxnet2 Openstack API - VBOX Adapter 2 eth1
auto eth1
iface eth1 inet static
address 192.168.100.51
netmask 255.255.255.0

ComputeNode:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth2
iface eth2 inet dhcp

#vboxnet0 - VBOX Adapter 1 MM
auto eth0
iface eth0 inet static
address 10.10.10.53
netmask 255.255.255.0

#vboxnet1 - VBOX Adapter 2 TN
auto eth1
iface eth1 inet static
address 10.20.20.53
netmask 255.255.255.0

As you see my Management Network is 10.10.10.xx the Tunnel Network is 10.20.20.xx and the api/external network is 192.168.100.xx

the highst ethx is used for NAT to get in the internet by all vms

one last thing i mentioned:

In my Dashboard in looking networktopology the router-gateway (203.0.113.101) is DOWN!!! But router interface 192.168.1.1 is ACTIVE

Morover i am not be able to get an instance running. I hat setup all but after creation like in linked docu the state is error with "no valid hosts" found... Maybe it is reasoned by my not working network?

SO PLEASE help me i dunno what to do and what wrong, ... if you need additional information i can update. If Possible blz a nooby tut if you see a problem..

THANKS A LOT

Cannot ping router tenant gateway by OS Nodes and www by Instance

hello, setup-> OS Icehouse Networking Issue 3Nodesetup as VM with Neutron ML2 GRE

UPDATE6

curl command does work now! Still cannot ping router tenannt gateway by any cloud node!

UPDATE5 exec namespace qrouter

   root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 iptables -S -t nat
-P PREROUTING ACCEPT
-P INPUT ACCEPT
-P OUTPUT ACCEPT
-P POSTROUTING ACCEPT
-N neutron-l3-agent-OUTPUT
-N neutron-l3-agent-POSTROUTING
-N neutron-l3-agent-PREROUTING
-N neutron-l3-agent-float-snat
-N neutron-l3-agent-snat
-N neutron-postrouting-bottom
-A PREROUTING -j neutron-l3-agent-PREROUTING
-A OUTPUT -j neutron-l3-agent-OUTPUT
-A POSTROUTING -j neutron-l3-agent-POSTROUTING
-A POSTROUTING -j neutron-postrouting-bottom
-A neutron-l3-agent-POSTROUTING ! -i qg-fa3fc507-5c ! -o qg-fa3fc507-5c -m conntrack ! --ctstate DNAT -j ACCEPT
-A neutron-l3-agent-PREROUTING -d 169.254.169.254/32 -p tcp -m tcp --dport 80 -j REDIRECT --to-ports 9697
-A neutron-l3-agent-snat -j neutron-l3-agent-float-snat
-A neutron-l3-agent-snat -s 192.168.1.0/24 -j SNAT --to-source 203.0.113.101
-A neutron-postrouting-bottom -j neutron-l3-agent-snat
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 iptables -S -t nat | grep 169.254 
-A neutron-l3-agent-PREROUTING -d 169.254.169.254/32 -p tcp -m tcp --dport 80 -j REDIRECT --to-ports 9697
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 iptables netstat -antp
Bad argument `netstat'
Try `iptables -h' or 'iptables --help' for more information.
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 iptables -netstat -antp
iptables v1.4.21: unknown option "iptables"

by starting the instance i saw in log

checking http://169.254.169.254/2009-04-04/instance-id
failed 1/20: up 4.87. request failed
...
failed 20/20: up 46.93. request failed

UPDATE1+2: Changed some configs and uncomment rabbit_pass in each... So at now i can start an instance but nevertheless i am not able to ping tenant gateway with ping -c 4 203.0.113.101 or the vm itself it just works with defined namespace and netns command...

What do you think, maybe it is a problem of Virtualbox because of i cannot not even ping some internetaddress by the 3 OS Nodes... and anywhere i read that this is an issue of virtualbox. Do you think that can be a reason why i cannot ping my tenant gateway with normal ping command?

New Problem arrives... the startet instance is not be able to ping internetadresses!!!

What works is to telnet google.com at port 80 by the 3 OS Nodes. But telnet by instance doesn´t work too with error message: bad adresss....

i addressed some more: tried to get some information on qdhcp point with:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 tcpdump -ln -i tap87176921-56

so there are no packets captured at this point!?

NO_ONE with ideas?

Update 3 (curl command by instance)

cannot upload the image because of carma:

$ uname -a
Linux cirros 3.2.0-60-.... #91-Ubuntu ...
$ curl http://169.254.169.254   (For what is this command?)
1.0
2007-01-19
2007-03-01
2007-08-29
2007-10-10
2007-12-15
2008-02-01
2008-09-01
2009-04-04
$ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
...
3packets transmitted 0 packets received

Rules for security group are set:

root@controller:~# neutron security-group-list
+--------------------------------------+---------+-------------+
| id                                   | name    | description |
+--------------------------------------+---------+-------------+
| 38e7edaa-87cd-4c28-a4cf-c1f32d4bf11a | default | default     |
| 7e5d3f0b-84ce-448c-8b76-69ceab021e21 | default | default     |
+--------------------------------------+---------+-------------+
root@controller:~# neutron security-group-rule-list
+--------------------------------------+----------------+-----------+----------+------------------+--------------+
| id                                   | security_group | direction | protocol | remote_ip_prefix | remote_group |
+--------------------------------------+----------------+-----------+----------+------------------+--------------+
| 112161bf-95a2-4404-9ea7-042df57aa796 | default        | egress    | tcp      |                  |              |
| 1213d327-311f-4436-b385-8e3949f2cd15 | default        | egress    | icmp     |                  |              |
| 2c2b1140-df8d-47c9-998b-f5b3cc43272f | default        | egress    | tcp      |                  |              |
| 3532502f-e6d0-4342-a99e-e55204e635cf | default        | ingress   |          |                  | default      |
| 44e718a5-7c26-4970-9769-ceafe33add13 | default        | ingress   |          |                  | default      |
| 5a6123dd-7811-4efa-ada8-85b3f872b34f | default        | ingress   | tcp      |                  |              |
| 7ccc9707-58ea-46ee-b8e3-40769e395c38 | default        | ingress   | icmp     |                  |              |
| 85663bce-c777-4791-95ab-40143bb3e24d | default        | egress    |          |                  |              |
| 86baec12-302c-4915-b86b-fa71c444e69d | default        | ingress   | tcp      |                  |              |
| 93b579ae-25cf-4a03-9556-f2a7a05fe771 | default        | egress    |          |                  |              |
| 97fc51aa-7de0-4e99-ace1-081690e594c0 | default        | egress    | icmp     |                  |              |
| c948c663-e7a4-4fdd-be07-87338af09011 | default        | ingress   | icmp     |                  |              |
| d084fa39-7908-46a6-ae63-96d4e9b5a1b0 | default        | egress    |          |                  |              |
| d97d7977-c1f4-4fd7-a985-38b4aa2b8545 | default        | ingress   |          |                  | default      |
| ec0ba6a4-720b-44fa-84f1-ee227fb8124e | default        | ingress   |          |                  | default      |
| f5b898a0-ef90-424d-9df5-c734657974ef | default        | egress    |          |                  |              |
+--------------------------------------+----------------+-----------+----------+------------------+--------------+

root@controller:~# nova secgroup-list
+--------------------------------------+---------+-------------+
| Id                                   | Name    | Description |
+--------------------------------------+---------+-------------+
| 38e7edaa-87cd-4c28-a4cf-c1f32d4bf11a | default | default     |
+--------------------------------------+---------+-------------+
root@controller:~# nova secgroup-list-rules default
+-------------+-----------+---------+-----------+--------------+
| IP Protocol | From Port | To Port | IP Range  | Source Group |
+-------------+-----------+---------+-----------+--------------+
|             |           |         |           | default      |
| tcp         | 22        | 22      | 0.0.0.0/0 |              |
| icmp        | -1        | -1      | 0.0.0.0/0 |              |
|             |           |         |           | default      |
+-------------+-----------+---------+-----------+--------------+

UPDATE 4 (ovs)

ovs-vsctl show:

root@network:~# ovs-vsctl show
e5fcf9e6-74bc-4764-8acb-8ada5c7da200
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
        Port "tap87176921-56"
            tag: 1
            Interface "tap87176921-56"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qr-f7463438-68"
            tag: 1
            Interface "qr-f7463438-68"
                type: internal
    Bridge br-ex
        Port "qg-fa3fc507-5c"
            Interface "qg-fa3fc507-5c"
                type: internal
        Port "eth2"
            Interface "eth2"
        Port br-ex
            Interface br-ex
                type: internal
    Bridge br-tun
        Port "gre-0a141435"
            Interface "gre-0a141435"
                type: gre
                options: {in_key=flow, local_ip="10.20.20.52", out_key=flow, remote_ip="10.20.20.53"}
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    ovs_version: "2.0.1"

IFCONFIG:

root@network:~# ifconfig
br-ex     Link encap:Ethernet  Hardware Adresse 08:00:27:a5:c8:5e  
          inet Adresse:192.168.100.52  Bcast:192.168.100.255  Maske:255.255.255.0
          inet6-Adresse: fe80::e033:38ff:feab:375/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING  MTU:1500  Metrik:1
          RX-Pakete:79 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:16 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:12070 (12.0 KB)  TX-Bytes:5292 (5.2 KB)

br-int    Link encap:Ethernet  Hardware Adresse 16:30:98:44:f3:4b  
          inet6-Adresse: fe80::1453:94ff:fe85:6281/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING  MTU:1500  Metrik:1
          RX-Pakete:53 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:8 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:4334 (4.3 KB)  TX-Bytes:648 (648.0 B)

br-tun    Link encap:Ethernet  Hardware Adresse ae:60:49:c9:70:4c  
          inet6-Adresse: fe80::f46f:f3ff:fe53:aa4f/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING  MTU:1500  Metrik:1
          RX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:8 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:0 (0.0 B)  TX-Bytes:648 (648.0 B)

eth0      Link encap:Ethernet  Hardware Adresse 08:00:27:4e:6b:6f  
          inet Adresse:10.10.10.52  Bcast:10.10.10.255  Maske:255.255.255.0
          inet6-Adresse: fe80::a00:27ff:fe4e:6b6f/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:117821 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:81499 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:11799002 (11.7 MB)  TX-Bytes:8233453 (8.2 MB)

eth1      Link encap:Ethernet  Hardware Adresse 08:00:27:c7:c1:50  
          inet Adresse:10.20.20.52  Bcast:10.20.20.255  Maske:255.255.255.0
          inet6-Adresse: fe80::a00:27ff:fec7:c150/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:111 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:27 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:17487 (17.4 KB)  TX-Bytes:2390 (2.3 KB)

eth2      Link encap:Ethernet  Hardware Adresse 08:00:27:a5:c8:5e  
          inet6-Adresse: fe80::a00:27ff:fea5:c85e/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:697 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:36 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:561119 (561.1 KB)  TX-Bytes:6940 (6.9 KB)

eth3      Link encap:Ethernet  Hardware Adresse 08:00:27:cf:41:83  
          inet Adresse:10.0.5.15  Bcast:10.0.5.255  Maske:255.255.255.0
          inet6-Adresse: fe80::a00:27ff:fecf:4183/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:95 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:103 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:11653 (11.6 KB)  TX-Bytes:8673 (8.6 KB)

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX-Pakete:21 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:21 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:2978 (2.9 KB)  TX-Bytes:2978 (2.9 KB)

Both commands on NetworkNode (neutron)


Basic information!!!

i am having trouble to get my Cloud working.

So first of all: i followed up the Training Guide to set up my 3 Nodes at Virtualbox and after this get on with the overall Installation Guide for Ubuntu Server 14.

After these steps my 3 Nodes knows each other and i can ping them by all.

I am using Openstack Neutron Networking with GRE and ML2.

I followed up the steps to creating my first internal network and get stuck on verifying connectivity at this...

I cannot ping the wanted router tenant gateway by any node of my setup.

The only way to connect to my internal net works from NetworkNode with following command:

ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ping 203.0.113.101

neutron agent list shows up smileys every where:

+--------------------------------------+--------------------+------------+-------+----------------+
| id                                   | agent_type         | host       | alive | admin_state_up |
+--------------------------------------+--------------------+------------+-------+----------------+
| 418d37e1-4e93-4075-9b59-0725cfd46144 | DHCP agent         | network    | :-)   | True           |
| 8d67f6d2-742f-4f3c-8622-598e7c86b861 | Metadata agent     | network    | :-)   | True           |
| cac088e6-9244-4083-86f4-5ce6223bd108 | L3 agent           | network    | :-)   | True           |
| d682e617-1e82-4d2c-9a27-b6ede2e68317 | Open vSwitch agent | network    | :-)   | True           |
| e88c8f0b-c471-4ff6-a3a5-ace6a68929c2 | Open vSwitch agent | computeone | :-)   | True           |
+--------------------------------------+--------------------+------------+-------+----------------+

all other services does works fine true:

I had setup tenant, some default rules for security group and setup of network shows up the mentioned informations. More over namespaces are used.

command: ip netns exec qdhcp-200c9ced-eb47-4f94-99f3-73e3a555d4f9 ip a show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever

and same for router shwos up:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
14: tap610365b7-d2: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:32:4a:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global tap610365b7-d2
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe32:4af5/64 scope link 
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-560eb2f3-1034-48d6-85e6-1525da6c3d46 ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
15: qr-f7463438-68: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:84:57:d4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-f7463438-68
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe84:57d4/64 scope link 
       valid_lft forever preferred_lft forever
16: qg-fa3fc507-5c: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    link/ether fa:16:3e:49:cb:c8 brd ff:ff:ff:ff:ff:ff
    inet 203.0.113.101/24 brd 203.0.113.255 scope global qg-fa3fc507-5c
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe49:cbc8/64 scope link 
       valid_lft forever preferred_lft forever

dunno if it does help but here are my networkconfigurations of

NetworkNode:

# The loopback network interface auto lo iface lo inet loopback

The primary network interface - VBOX Adapter 4 NAT

auto eth3
iface eth3 inet dhcp

# vboxnet0 MM
auto eth0
iface eth0 inet static
address 10.10.10.52
netmask 255.255.255.0

# vboxnet1 TN
auto eth1
iface eth1 inet static
address 10.20.20.52
netmask 255.255.255.0


# vboxnet2 API-Network
auto eth2
iface eth2 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
address 192.168.100.52
netmask 255.255.255.0
gateway 192.168.100.1
dns-nameservers 8.8.8.8

Controller Node:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface - VBOX Adapter 3 eth2 NAT
auto eth2
iface eth2 inet dhcp

#vboxnet0 Openstack Management - VBOX Adapter 1 eth0
auto eth0
iface eth0 inet static
address 10.10.10.51
netmask 255.255.255.0

#vboxnet2 Openstack API - VBOX Adapter 2 eth1
auto eth1
iface eth1 inet static
address 192.168.100.51
netmask 255.255.255.0

ComputeNode:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth2
iface eth2 inet dhcp

#vboxnet0 - VBOX Adapter 1 MM
auto eth0
iface eth0 inet static
address 10.10.10.53
netmask 255.255.255.0

#vboxnet1 - VBOX Adapter 2 TN
auto eth1
iface eth1 inet static
address 10.20.20.53
netmask 255.255.255.0

As you see my Management Network is 10.10.10.xx the Tunnel Network is 10.20.20.xx and the api/external network is 192.168.100.xx

the highst ethx is used for NAT to get in the internet by all vms

one last thing i mentioned:

In my Dashboard in looking networktopology the router-gateway (203.0.113.101) is DOWN!!! But router interface 192.168.1.1 is ACTIVE

Morover i am not be able to get an instance running. I hat setup all but after creation like in linked docu the state is error with "no valid hosts" found... Maybe it is reasoned by my not working network?

SO PLEASE help me i dunno what to do and what wrong, ... if you need additional information i can update. If Possible blz a nooby tut if you see a problem..

THANKS A LOT