Revision history [back]

click to hide/show revision 1
initial version

Instance forever spawning with RDO quickstart example "running an instance"

Hi there,

I've followed RDO's quickstart example, specifically to get to know what Openstack has to offer. I'm running this on a supported server (HP DL380 G5) and RHEL6.5. The installation went as described. A few days later I wanted to continue with the rest of the quick start guide, for example the running an instance part. At Step 5: Launch the instance, I've launched the F19 image, and anxious to see what happens next, I'm waiting and waiting for the task "spawning" to complete. The instance F19-1 I've created is in that state for 40 minutes now. I've selected a sizing of m1.small with no additional settings on a server that has 8GB of RAM and a quad-core Xeon with a 72GB hard drive.

I've tried googling this issue "stuck at spawning" and found very little metoo's that are comparable to my set up. It's either a situation where things have worked before, or with a multi node setup, or after an upgrade. I'm following a quick start guide to the letter and have no clue of where to start looking.

For example, I've found this question and see the do_aug_close: you must call 'aug-init' first to initialize Augeas error too, but from what I understand, the symlink that's supposed to be missing, is already there.

The other issue I found tell's me nothing I can relate to since that seems to be a multi node setup with a lot of (debug) logging that's new to me and doesn't give me any lead.

I'd be happy to show logs, but which one? I can add everything but don't want to make this site less usable by dumping a load of logfiles which only mean something to the more experienced.

One thing I'd like to add, which might, or might not be related, or give an additional clue: While I was waiting for the instance to spawn, I continued with the next part of the quickstart: which is setting up a floating ip-range. I determined I had to use neutron, instead of nova after reading this explanation. So I:

  1. sourced the keystone file,
  2. and started the command: neutron net-create public --router:external=True

and that command is also waiting for about 30 minutes now to complete. I've looked in the neutron logs, they're new to me and don't seem to contain any obvious errors. When looking at the load: load average: 0.68, 0.61, 0.60 and memory usage:

[root@ceres nova(keystone_admin)]# free
             total       used       free     shared    buffers     cached
Mem:       8057236    7783404     273832          0     142996    2547512
-/+ buffers/cache:    5092896    2964340
Swap:      2097144         52    2097092

and iostat I don't see a resource problem on the server itself:

[root@ceres nova(keystone_admin)]# iostat
Linux 2.6.32-431.20.5.el6.x86_64 (ceres.example.com)    06-08-14    _x86_64_    (4 CPU)

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
          12,06    0,04   19,88    0,01    0,00   68,00

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
cciss/c0d0       11,68         9,17       368,35    6354672  255366632
dm-0              1,90         1,30        14,46     902018   10023944
dm-1              0,08         0,67         0,00     465576          0
dm-2              8,68         1,41       220,01     978276  152530016
dm-3              0,63         1,40         4,19     969186    2904840
dm-4              0,46         0,68         3,01     469266    2087760
dm-5             12,72         0,68       101,10     474066   70090944
dm-6              3,27         0,91        25,50     632178   17676840
dm-7              0,08         0,67         0,00     464762         32
dm-8              0,09         0,67         0,08     464882      52016

Can someone please help me to get the RDO quickstart guide for the demo user working?