Revision history [back]

click to hide/show revision 1
initial version

neutron stops working with multiple compute nodes

Hey guys,

Overview

I am working on a small set-up using 1 controller, 1 neutron networking node and 3 compute nodes. The set-up worked well with one compute node but as soon as I started the other two the networking stopped working... no errors in log files (even with verbose on). The only thing that worked was reinstalling the demo network and router but this only fixed things for a few mins....

DETAIL

I followed the wiki here with a single compute node and everything worked perfectly. I was able to launch the test instance, ping external networks and ssh into it from external networks. I then processed to build out the last two compute nodes in the exact same way I did on the first. (with the slight change of the IPs for my_ip and vncserver_proxyclient_address in noca.conf).

When I attempted to start a new VM it refused to DHCP and the original VM was no longer able to ping anything including the virtual router...

After messing around with all the logs files, seeing nothing, i reinstalled the demo router and network... this worked for a few mins but then stopped again... The only error I could find was to do with nova showing:

2014-07-27 19:25:04.599 1698 WARNING keystoneclient.middleware.auth_token [-] Authorization failed for token

I have checked all the config files on each host and the only thing diffrent in them was the IPs

6c6
< my_ip = 10.10.0.32
---
> my_ip = 10.10.0.31
9c9
< vncserver_proxyclient_address = 10.10.0.32
---
> vncserver_proxyclient_address = 10.10.0.31

Question

Is there anything i need to be changing for multi node to be supported?