Revision history [back]

click to hide/show revision 1
initial version

keystone setup adding admin user 'NoneType' object has no attribute 'encode'

I'm following the Openstack Icehouse Install Guide. So far so good but when configuring the keystone service I'm having issues adding the admin user:

[root@controller keystone]# keystone user-create --name=admin --pass=$ADMIN_PASS 'NoneType' object has no attribute 'encode'

There are no errors in /var/log/keystone/keystone.log, I tried uninstalling and dropping the keystone database then restarting but I have the same problem.

Thanks, Ryan

keystone setup adding admin user 'NoneType' object has no attribute 'encode'

I'm following the Openstack Icehouse Install Guide. So far so good but when configuring the keystone service I'm having issues adding the admin user:

[root@controller keystone]# keystone user-create --name=admin --pass=$ADMIN_PASS 'NoneType' object has no attribute 'encode'

There are no errors in /var/log/keystone/keystone.log, I tried uninstalling and dropping the keystone database then restarting but I have the same problem.

Here's the output with debug on:

[root@rlx7001 keystone]# keystone --debug user-create --name=admin --pass=$ADMIN_PASS DEBUG:keystoneclient.session:REQ: curl -i -X POST http:rlx7001.corp.ads:35357/v2.0/users -H "User-Agent: python-keystoneclient" -H "Content-Type: application/json" -H "X-Auth-Token: 0efa132694af466ccc7d" -d '{"user": {"email": null, "password": "1574aa7235ff", "enabled": true, "name": "admin", "tenantId": null}}' INFO:urllib3.connectionpool:Starting new HTTP connection (1): None 'NoneType' object has no attribute 'encode'

Thanks, Ryan

click to hide/show revision 3
No.3 Revision

keystone setup adding admin user 'NoneType' object has no attribute 'encode'

I'm following the Openstack Icehouse Install Guide. So far so good but when configuring the keystone service I'm having issues adding the admin user:

[root@controller keystone]# keystone user-create --name=admin --pass=$ADMIN_PASS
'NoneType' **'NoneType' object has no attribute 'encode'

'encode'**

There are no errors in /var/log/keystone/keystone.log, I tried uninstalling and dropping the keystone database then restarting but I have the same problem.

Here's the output with debug on:

[root@rlx7001 keystone]# keystone --debug user-create --name=admin --pass=$ADMIN_PASS
DEBUG:keystoneclient.session:REQ: curl -i -X POST http:rlx7001.corp.ads:35357/v2.0/users -H "User-Agent: python-keystoneclient" -H "Content-Type: application/json" -H "X-Auth-Token: 0efa132694af466ccc7d" -d '{"user": {"email": null, "password": "1574aa7235ff", "enabled": true, "name": "admin", "tenantId": null}}'
INFO:urllib3.connectionpool:Starting new HTTP connection (1): None
'NoneType' object has no attribute 'encode'

'encode'

Thanks, Ryan