Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Adding Ubuntu Image to XenServer Powered Openstack

I installed devstack on top of xenserver. Now I want to add a ubuntu image to openstack. I downloaded qcow2 image from here and used the guideline here to convert the image to vhd format and added to openstack using glance.

But when I start the instance, it got shut-off automatically. When I try to restart the instance in Xensenver, it got stuck at the messages:

[ 1.612617] EXT4-fs (xvda1): mounted filesystem with ordered data mode. Opts: (null) [ 2.245259] EXT4-fs (xvda1): re-mounted. Opts: (null)

One thing to mention is I successfully added a cirros image to xenserver using the steps above

So what's the problem here? Could any one give any suggestions?

Thanks in advance!

Adding Ubuntu Image to XenServer Powered Openstack

I installed devstack on top of xenserver. Now I want to add a ubuntu image to openstack. I downloaded qcow2 image from here and used the guideline here to convert the image to vhd format and added to openstack using glance.

But when I start the instance, it got shut-off automatically. When I try to restart the instance in Xensenver, it got stuck at the messages:

[ 1.612617] EXT4-fs (xvda1): mounted filesystem with ordered data mode. Opts: (null) (null)

[ 2.245259] EXT4-fs (xvda1): re-mounted. Opts: (null)

One thing to mention is I successfully added a cirros image to xenserver using the steps above

So what's the problem here? Could any one give any suggestions?

Thanks in advance!

Adding Ubuntu Image to XenServer Powered Openstack

I installed devstack on top of xenserver. Now I want to add a ubuntu image to openstack. I downloaded qcow2 image from here here (http://cloud-images.ubuntu.com/precise/current/) and used the guideline here here (http://blogs.citrix.com/2012/10/17/upload-custom-images-to-a-xenserver-powered-openstack-cloud/) to convert the image to vhd format and added to openstack using glance.

But when I start the instance, it got shut-off automatically. When I try to restart the instance in Xensenver, it got stuck at the messages:

[ 1.612617] EXT4-fs (xvda1): mounted filesystem with ordered data mode. Opts: (null)

[ 2.245259] EXT4-fs (xvda1): re-mounted. Opts: (null)

One thing to mention is I successfully added a cirros image to xenserver using the steps above

So what's the problem here? Could any one give any suggestions?

Thanks in advance!

Adding Ubuntu Image to XenServer Powered Openstack

I installed devstack on top of xenserver. Now I want to add a ubuntu image to openstack. I downloaded qcow2 image from here (http://cloud-images.ubuntu.com/precise/current/) and used the guideline here (http://blogs.citrix.com/2012/10/17/upload-custom-images-to-a-xenserver-powered-openstack-cloud/) to convert the image to vhd format and added to openstack using glance.

But when I start the instance, it got shut-off automatically. When I try to restart the instance in Xensenver, it got stuck at the messages:

[ 1.612617] EXT4-fs (xvda1): mounted filesystem with ordered data mode. Opts: (null)

[ 2.245259] EXT4-fs (xvda1): re-mounted. Opts: (null)

One thing to mention is I successfully added a cirros image to xenserver using the steps above

So what's the problem here? Could any one give any suggestions?

Thanks in advance!

Adding Ubuntu Image to XenServer Powered OpenstackOpenstack filesystem already mounted

I installed devstack on top of xenserver. Now I want to add a ubuntu image to openstack. I downloaded qcow2 image from here (http://cloud-images.ubuntu.com/precise/current/) here and used the guideline here (http://blogs.citrix.com/2012/10/17/upload-custom-images-to-a-xenserver-powered-openstack-cloud/) here to convert the image to vhd format and added to openstack using glance.

But when I start the instance, it got shut-off automatically. When I try to restart the instance in Xensenver, it got stuck at the messages:

[    1.612617] EXT4-fs (xvda1): mounted filesystem with ordered data mode. Opts: (null)

(null) [ 2.245259] EXT4-fs (xvda1): re-mounted. Opts: (null)

(null)

One thing to mention is I successfully added a cirros image to xenserver using the steps above

So what's the problem here? Could any one give any suggestions?

Thanks in advance!

click to hide/show revision 6
No.6 Revision

Adding Ubuntu Image to XenServer Powered Openstack filesystem already mounted

I installed devstack on top of xenserver. Now I want to add a ubuntu image to openstack. I downloaded qcow2 image from here and used the guideline here to convert the image to vhd format and added to openstack using glance.

But when I start the instance, it got shut-off automatically. When I try to restart the instance in Xensenver, it got stuck at the messages:

[    1.612617] EXT4-fs (xvda1): mounted filesystem with ordered data mode. Opts: (null)
[    2.245259] EXT4-fs (xvda1): re-mounted. Opts: (null)

One thing to mention is I successfully added a cirros image to xenserver using the steps above

above, So what's the problem here? Could any one give any suggestions?

Thanks in advance!