Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Using an OpenBSD image

Hello, Is it possible to use OpenBSD images in OpenStack? I only see the following in the guide: CirrOS (test) images Official Ubuntu images Official Red Hat Enterprise Linux images Official Fedora images Official openSUSE and SLES images Rackspace Cloud Builders (multiple distros) images

I created an OpenBSD image through virt-manager and resulted image has the follwing format: root@terabit-server-6:/var/lib/libvirt/images# file vm1-OpenBSD.img vm1-OpenBSD.img: x86 boot sector; partition 4: ID=0xa6, active, starthead 1, startsector 64, 8385866 sectors, code offset 0x5

I changed its format to qcow2 using: qemu-img convert -O qcow2 vm1-OpenBSD.img vm1-OpenBSD-qcow.img

And the new image has the following format vm1-OpenBSD-qcow.img: QEMU QCOW Image (v2), 4294967296 bytes

Then I followed these instructions to add the image to OpenStack glance http://docs.openstack.org/icehouse/install-guide/install/apt/content/glance-verify.html

I can launch the VM but its network interfaces showed as not configured. There is no vm log can be seen though nova log-console vm1 So I am not sure where to look or if I am doing somwthing wrong with creating and launchung OpenBSD vms.

P.S I can create VMs using other images such as Ubuntu and CentOS.

Using an OpenBSD image

Hello, Is it possible to use OpenBSD images in OpenStack? I only see the following in the guide: CirrOS (test) images Official Ubuntu images Official Red Hat Enterprise Linux images Official Fedora images Official openSUSE and SLES images Rackspace Cloud Builders (multiple distros) images

I created an OpenBSD image through virt-manager and resulted image has the follwing format: root@terabit-server-6:/var/lib/libvirt/images# file vm1-OpenBSD.img vm1-OpenBSD.img: x86 boot sector; partition 4: ID=0xa6, active, starthead 1, startsector 64, 8385866 sectors, code offset 0x5

I changed its format to qcow2 using: qemu-img convert -O qcow2 vm1-OpenBSD.img vm1-OpenBSD-qcow.img

And the new image has the following format vm1-OpenBSD-qcow.img: QEMU QCOW Image (v2), 4294967296 bytes

Then I followed these instructions to add the image to OpenStack glance http://docs.openstack.org/icehouse/install-guide/install/apt/content/glance-verify.html

I can launch the VM but its network interfaces showed as not configured. There is no vm log can be seen though nova log-console vm1 So I am not sure where to look or if I am doing somwthing wrong with creating and launchung OpenBSD vms.

P.S I can create VMs using other images such as Ubuntu and CentOS.CentOS and they can get their IPs with no problems.