Revision history [back]

click to hide/show revision 1
initial version

Problem with getting a token in keystone

Dear All there, I am deploying keystone from the source code. After running keystone by the command : "tools/with_venv.sh bin/keystone-all". I want to get a token following the example at openstack document site: I am using this command: http://docs.openstack.org/developer/keystone/api_curl_examples.html curl -i \ -H "Content-Type: application/json" \ -d ' { "auth": { "identity": { "methods": ["password"], "password": { "user": { "name": "admin", "domain": { "id": "default" }, "password": "adminpwd" } } } } }' \ http://localhost:5000/v3/auth/tokens ; echo

But my result is : <quote> HTTP/1.1 401 Unauthorized Www-Authenticate: Keystone uri="http://localhost:5000" Vary: X-Auth-Token Content-Type: application/json Content-Length: 114 Date: Mon, 07 Jul 2014 09:54:18 GMT

{"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}} </quote>

I dont know why? Maybe the password for admin is not correct? How can i change the password...? Please help me! Thanks so much

Problem with getting a token in keystone

Dear All there, I am deploying keystone from the source code. After running keystone by the command : "tools/with_venv.sh bin/keystone-all". I want to get a token following the example at openstack document site: I am using this command: http://docs.openstack.org/developer/keystone/api_curl_examples.html curl -i \ -H "Content-Type: application/json" \ -d ' { "auth": { "identity": { "methods": ["password"], "password": { "user": { "name": "admin", "domain": { "id": "default" }, "password": "adminpwd" } } } } }' \ http://localhost:5000/v3/auth/tokens ; echo

But my result is : <quote> HTTP/1.1 401 Unauthorized Www-Authenticate: Keystone uri="http://localhost:5000" Vary: X-Auth-Token Content-Type: application/json Content-Length: 114 Date: Mon, 07 Jul 2014 09:54:18 GMT

{"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}} </quote>

I dont know why? Maybe the password for admin is not correct? How can i change the password...? Please help me! Thanks so much

Problem with getting a token in keystone

Dear All there, I am deploying keystone from the source code. After running keystone by the command : "tools/with_venv.sh bin/keystone-all". I want to get a token following the example at openstack document site: I am using this command: http://docs.openstack.org/developer/keystone/api_curl_examples.html curl -i \ -H "Content-Type: application/json" \ -d ' { "auth": { "identity": { "methods": ["password"], "password": { "user": { "name": "admin", "domain": { "id": "default" }, "password": "adminpwd" } } } } }' \ http://localhost:5000/v3/auth/tokens ; echo

But my result is : HTTP/1.1 401 Unauthorized Www-Authenticate: Keystone uri="http://localhost:5000" Vary: X-Auth-Token Content-Type: application/json Content-Length: 114 Date: Mon, 07 Jul 2014 09:54:18 GMT

GMT {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}}

I dont know why? Maybe the password for admin is not correct? How can i change the password...? Please help me! Thanks so much

Problem with getting a token in keystone

Dear All there, I am deploying keystone from the source code. After running keystone by the command : "tools/with_venv.sh bin/keystone-all". I want to get a token following the example at openstack document site: I am using this command: http://docs.openstack.org/developer/keystone/api_curl_examples.html the command from Keystone API curl examples

 curl -i \
  -H "Content-Type: application/json" \
  -d '
{ "auth": {
    "identity": {
      "methods": ["password"],
      "password": {
        "user": {
          "name": "admin",
          "domain": { "id": "default" },
          "password": "adminpwd"
        }
      }
    }
  }
}' \
  http://localhost:5000/v3/auth/tokens ; echo

But my result is : :

 HTTP/1.1 401 Unauthorized
Www-Authenticate: Keystone uri="http://localhost:5000"
Vary: X-Auth-Token
Content-Type: application/json
Content-Length: 114
Date: Mon, 07 Jul 2014 09:54:18 GMT
{"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}}
 

I dont know why? Maybe the password for admin is not correct? How can i change the password...? Please help me! Thanks so much