Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Keystone MySQL problem after setting up Apache/mod_wsgi

I've been configuring Icehouse Keystone to use Apache/mod_wsgi, following the various guides that are around, including on the OpenStack wiki. That appears to be working, but I'm now seeing a weird MySQL error when I issue Keystone queries. It's a MySQL 1045 Access Denied message, but the odd thing is that the error is:

2014-06-27 18:26:16.930 8113 TRACE keystone.common.wsgi OperationalError: (OperationalError) (1045, "Access denied for user 'keystone'@'localhost' (using password: YES)") None None

but the user configured in /etc/keystone/keystone.conf is 'keystone_admin' (as setup in the original RDO installation):

connection = mysql://keystone_admin:<password>@<ip address="">/keystone

I've added a 'keystone' MySQL account with the same privileges and credentials as the 'keystone_admin' one and the error is still there.

Keystone MySQL problem after setting up Apache/mod_wsgi

I've been configuring Icehouse Keystone to use Apache/mod_wsgi, following the various guides that are around, including on the OpenStack wiki. That appears to be working, but I'm now seeing a weird MySQL error when I issue Keystone queries. It's a MySQL 1045 Access Denied message, but the odd thing is that the error is:

2014-06-27 18:26:16.930 8113 TRACE keystone.common.wsgi OperationalError: (OperationalError) (1045, "Access denied for user 'keystone'@'localhost' (using password: YES)") None None

but the user configured in /etc/keystone/keystone.conf is 'keystone_admin' (as setup in the original RDO installation):

connection = mysql://keystone_admin:<password>@<ip address="">/keystone

I've added a 'keystone' MySQL account with the same privileges and credentials as the 'keystone_admin' one and the error is still there.

Keystone MySQL problem after setting up Apache/mod_wsgi

I've been configuring Icehouse Keystone to use Apache/mod_wsgi, following the various guides that are around, including on the OpenStack wiki. That appears to be working, but I'm now seeing a weird MySQL error when I issue Keystone queries. It's a MySQL 1045 Access Denied message, but the odd thing is that the error is:

2014-06-27 18:26:16.930 8113 TRACE keystone.common.wsgi OperationalError: (OperationalError) (1045, "Access denied for user 'keystone'@'localhost' (using password: YES)") None None

None

but the user configured in /etc/keystone/keystone.conf is 'keystone_admin' (as setup in the original RDO installation):

connection = mysql://keystone_admin:<password>@<ip address="">/keystone

mysql://keystone_admin:<password>@<IP address>/keystone

I've added a 'keystone' MySQL account with the same privileges and credentials as the 'keystone_admin' one and the error is still there.