Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

neutron net-list doesn't work, but net-create successes

Hi all, I'm deploying openstack icehouse version with three-node architecture (controller node, network node, and compute node1) on Debian wheezy.

Now, I have the problem that neutron net-create works. see the neutron-server.log

 2014-06-27 09:55:58.618 15656 INFO neutron.wsgi [req-063d6f5a-1ffc-4da2-8c64-bbeb10c4fd4a None] (15656)       accepted ('192.168.0.11', 40015)
 2014-06-27 09:55:58.622 15656 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 09:55:58.706 15656 INFO neutron.openstack.common.rpc.common [req-e0609c0f-0d12-4241-8a30-7ce398c9a919 None] Connected to AMQP server on localhost:5672
 2014-06-27 09:55:58.723 15656 INFO neutron.quota [req-e0609c0f-0d12-4241-8a30-7ce398c9a919 None] Loaded quota_driver: <neutron.db.quota_db.DbQuotaDriver object at 0x3ec7850>.
 2014-06-27 09:55:58.790 15656 INFO neutron.wsgi [req-e0609c0f-0d12-4241-8a30-7ce398c9a919 None] 192.168.0.11 - - [27/Jun/2014 09:55:58] "POST /v2.0/networks.json HTTP/1.1" 201 521 0.170241

But when i try to use the command "neutron net-list" to list the network I created, it prompts "request failed: internal server error while processing your request". Following is the log in neutron-server.log.

 2014-06-27 10:05:28.843 16448 INFO neutron.wsgi [-] (16448) accepted ('192.168.0.11', 40692)
 2014-06-27 10:05:28.860 16448 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 10:05:29.073 16448 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 10:05:29.298 16448 ERROR neutron.api.v2.resource [req-90a60609-f7d3-4b1d-8878-7e163ba0d937 None] index failed
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource Traceback (most recent call last):
 ...
2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/dist-    packages/neutron/plugins/openvswitch/ovs_neutron_plugin.py", line 379, in _extend_network_dict_provider_ovs
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource     network[provider.NETWORK_TYPE] = binding.network_type
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource AttributeError: 'NoneType' object has no attribute 'network_type'
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource
 2014-06-27 10:05:29.302 16448 INFO neutron.wsgi [req-90a60609-f7d3-4b1d-8878-7e163ba0d937 None] 192.168.0.11 - - [27/Jun/2014 10:05:29] "GET /v2.0/networks.json HTTP/1.1" 500 296 0.457172

or see the figureimage description (this will be more clear).

I notice there are two errors: 1) ERROR neutron.api.v2.resource [req- None] index failed; 2) TRACE neutron.api.v2.resource network[provider.NETWORK_TYPE] = binding.network_type, AttributeError: 'NoneType' object has no attribute 'network_type'.

The first error may indicates the some errors with database. I use the keywords to search on Google engine, most of the information suggest me to drop the neutron db and recreate it. I haven't tried this one. The second error network_type, I doubt whether it refers as to tenant_network_type. After I use "neutron net-create", it prompts me "Created a new network", see the figureimage description

Do you have some ideas? Thanks a lot, Dwyane.

neutron net-list doesn't work, but net-create successessuccesses (request failed: internal server error while processing your request)

Hi all, I'm deploying openstack icehouse version with three-node architecture (controller node, network node, and compute node1) on Debian wheezy.

Now, I have the problem that neutron net-create works. see the neutron-server.log

 2014-06-27 09:55:58.618 15656 INFO neutron.wsgi [req-063d6f5a-1ffc-4da2-8c64-bbeb10c4fd4a None] (15656)       accepted ('192.168.0.11', 40015)
 2014-06-27 09:55:58.622 15656 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 09:55:58.706 15656 INFO neutron.openstack.common.rpc.common [req-e0609c0f-0d12-4241-8a30-7ce398c9a919 None] Connected to AMQP server on localhost:5672
 2014-06-27 09:55:58.723 15656 INFO neutron.quota [req-e0609c0f-0d12-4241-8a30-7ce398c9a919 None] Loaded quota_driver: <neutron.db.quota_db.DbQuotaDriver object at 0x3ec7850>.
 2014-06-27 09:55:58.790 15656 INFO neutron.wsgi [req-e0609c0f-0d12-4241-8a30-7ce398c9a919 None] 192.168.0.11 - - [27/Jun/2014 09:55:58] "POST /v2.0/networks.json HTTP/1.1" 201 521 0.170241

But when i try to use the command "neutron net-list" to list the network I created, it prompts "request failed: internal server error while processing your request". Following is the log in neutron-server.log.

 2014-06-27 10:05:28.843 16448 INFO neutron.wsgi [-] (16448) accepted ('192.168.0.11', 40692)
 2014-06-27 10:05:28.860 16448 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 10:05:29.073 16448 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 10:05:29.298 16448 ERROR neutron.api.v2.resource [req-90a60609-f7d3-4b1d-8878-7e163ba0d937 None] index failed
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource Traceback (most recent call last):
 ...
2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/dist-    packages/neutron/plugins/openvswitch/ovs_neutron_plugin.py", line 379, in _extend_network_dict_provider_ovs
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource     network[provider.NETWORK_TYPE] = binding.network_type
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource AttributeError: 'NoneType' object has no attribute 'network_type'
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource
 2014-06-27 10:05:29.302 16448 INFO neutron.wsgi [req-90a60609-f7d3-4b1d-8878-7e163ba0d937 None] 192.168.0.11 - - [27/Jun/2014 10:05:29] "GET /v2.0/networks.json HTTP/1.1" 500 296 0.457172

or see the figureimage description (this will be more clear).

I notice there are two errors: 1) ERROR neutron.api.v2.resource [req- None] index failed; 2) TRACE neutron.api.v2.resource network[provider.NETWORK_TYPE] = binding.network_type, AttributeError: 'NoneType' object has no attribute 'network_type'.

The first error may indicates the some errors with database. I use the keywords to search on Google engine, most of the information suggest me to drop the neutron db and recreate it. I haven't tried this one. The second error network_type, I doubt whether it refers as to tenant_network_type. After I use "neutron net-create", it prompts me "Created a new network", see the figureimage description

Do you have some ideas? Thanks a lot, Dwyane.

neutron net-list doesn't work, but net-create successes & net-delete are fine (request failed: internal server error while processing your request)

Hi all, I'm deploying openstack icehouse version with three-node architecture (controller node, network node, and compute node1) on Debian wheezy.

Now, I have the problem that neutron net-create works. see the neutron-server.log

 2014-06-27 09:55:58.618 15656 INFO neutron.wsgi [req-063d6f5a-1ffc-4da2-8c64-bbeb10c4fd4a None] (15656)       accepted ('192.168.0.11', 40015)
 2014-06-27 09:55:58.622 15656 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 09:55:58.706 15656 INFO neutron.openstack.common.rpc.common [req-e0609c0f-0d12-4241-8a30-7ce398c9a919 None] Connected to AMQP server on localhost:5672
 2014-06-27 09:55:58.723 15656 INFO neutron.quota [req-e0609c0f-0d12-4241-8a30-7ce398c9a919 None] Loaded quota_driver: <neutron.db.quota_db.DbQuotaDriver object at 0x3ec7850>.
 2014-06-27 09:55:58.790 15656 INFO neutron.wsgi [req-e0609c0f-0d12-4241-8a30-7ce398c9a919 None] 192.168.0.11 - - [27/Jun/2014 09:55:58] "POST /v2.0/networks.json HTTP/1.1" 201 521 0.170241
and net-delete work fine.

But when i try to use the command "neutron net-list" to list the network I created, it prompts "request failed: internal server error while processing your request". Following is the log in neutron-server.log.

 2014-06-27 10:05:28.843 16448 INFO neutron.wsgi [-] (16448) accepted ('192.168.0.11', 40692)
 2014-06-27 10:05:28.860 16448 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 10:05:29.073 16448 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 10:05:29.298 16448 ERROR neutron.api.v2.resource [req-90a60609-f7d3-4b1d-8878-7e163ba0d937 None] index failed
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource Traceback (most recent call last):
 ...
2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/dist-    packages/neutron/plugins/openvswitch/ovs_neutron_plugin.py", line 379, in _extend_network_dict_provider_ovs
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource     network[provider.NETWORK_TYPE] = binding.network_type
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource AttributeError: 'NoneType' object has no attribute 'network_type'
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource
 2014-06-27 10:05:29.302 16448 INFO neutron.wsgi [req-90a60609-f7d3-4b1d-8878-7e163ba0d937 None] 192.168.0.11 - - [27/Jun/2014 10:05:29] "GET /v2.0/networks.json HTTP/1.1" 500 296 0.457172

or see the figureimage description (this will be more clear).

I notice there are two errors: 1) ERROR neutron.api.v2.resource [req- None] index failed; 2) TRACE neutron.api.v2.resource network[provider.NETWORK_TYPE] = binding.network_type, AttributeError: 'NoneType' object has no attribute 'network_type'.

The first error may indicates the some errors with database. I use the keywords to search on Google engine, most of the information suggest me to drop the neutron db and recreate it. I haven't tried this one. The second error network_type, I doubt whether it refers as to tenant_network_type. After I use "neutron net-create", it prompts me "Created a new network", see the figureimage description

Do you have some ideas? Thanks a lot, Dwyane.

neutron net-list doesn't work, but net-create & net-delete are fine (request failed: internal server error while processing your request)but neutron net-list throws error

Hi all, I'm deploying openstack icehouse version with three-node architecture (controller node, network node, and compute node1) on Debian wheezy.

Now, I have the problem that neutron net-create and net-delete work fine.

But when i try to use the command "neutron net-list" to list the network I created, it prompts "request failed: internal server error while processing your request". Following is the log in neutron-server.log.

 2014-06-27 10:05:28.843 16448 INFO neutron.wsgi [-] (16448) accepted ('192.168.0.11', 40692)
 2014-06-27 10:05:28.860 16448 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 10:05:29.073 16448 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 10:05:29.298 16448 ERROR neutron.api.v2.resource [req-90a60609-f7d3-4b1d-8878-7e163ba0d937 None] index failed
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource Traceback (most recent call last):
 ...
2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/dist-    packages/neutron/plugins/openvswitch/ovs_neutron_plugin.py", line 379, in _extend_network_dict_provider_ovs
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource     network[provider.NETWORK_TYPE] = binding.network_type
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource AttributeError: 'NoneType' object has no attribute 'network_type'
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource
 2014-06-27 10:05:29.302 16448 INFO neutron.wsgi [req-90a60609-f7d3-4b1d-8878-7e163ba0d937 None] 192.168.0.11 - - [27/Jun/2014 10:05:29] "GET /v2.0/networks.json HTTP/1.1" 500 296 0.457172

or see the figurefigure!

image description

(this will be more clear).

I notice there are two errors: 1) ERROR neutron.api.v2.resource [req- None] index failed; 2) TRACE neutron.api.v2.resource network[provider.NETWORK_TYPE] = binding.network_type, AttributeError: 'NoneType' object has no attribute 'network_type'.

The first error may indicates the some errors with database. I use the keywords to search on Google engine, most of the information suggest me to drop the neutron db and recreate it. I haven't tried this one. The second error network_type, I doubt whether it refers as to tenant_network_type. After I use "neutron net-create", it prompts me "Created a new network", see the figurefigure!

image description

Do you have some ideas? Thanks a lot, Dwyane.

net-create & net-delete are fine but neutron net-list throws error

I'm deploying openstack icehouse version with three-node architecture (controller node, network node, and compute node1) on Debian wheezy.

Now, I have the problem that neutron net-create and net-delete work fine.

But when i try to use the command "neutron net-list" to list the network I created, it prompts "request failed: internal server error while processing your request". Following is the log in neutron-server.log.

 2014-06-27 10:05:28.843 16448 INFO neutron.wsgi [-] (16448) accepted ('192.168.0.11', 40692)
 2014-06-27 10:05:28.860 16448 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 10:05:29.073 16448 INFO requests.packages.urllib3.connectionpool [-] Starting new HTTP connection (1): hadoop01
 2014-06-27 10:05:29.298 16448 ERROR neutron.api.v2.resource [req-90a60609-f7d3-4b1d-8878-7e163ba0d937 None] index failed
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource Traceback (most recent call last):
 ...
2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/dist-    packages/neutron/plugins/openvswitch/ovs_neutron_plugin.py", line 379, in _extend_network_dict_provider_ovs
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource     network[provider.NETWORK_TYPE] = binding.network_type
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource AttributeError: 'NoneType' object has no attribute 'network_type'
 2014-06-27 10:05:29.298 16448 TRACE neutron.api.v2.resource
 2014-06-27 10:05:29.302 16448 INFO neutron.wsgi [req-90a60609-f7d3-4b1d-8878-7e163ba0d937 None] 192.168.0.11 - - [27/Jun/2014 10:05:29] "GET /v2.0/networks.json HTTP/1.1" 500 296 0.457172

or see the figure!

image description

(this will be more clear).

I notice there are two errors: 1) ERROR neutron.api.v2.resource [req- None] index failed; 2) TRACE neutron.api.v2.resource network[provider.NETWORK_TYPE] = binding.network_type, AttributeError: 'NoneType' object has no attribute 'network_type'.

The first error may indicates the some errors with database. I use the keywords to search on Google engine, most of the information suggest me to drop the neutron db and recreate it. I haven't tried this one. The second error network_type, I doubt whether it refers as to tenant_network_type. After I use "neutron net-create", it prompts me "Created a new network", see the figure!

image description

this is the result of table networks status:

mysql> show table status from neutrondb11 like'networks';
+----------+--------+---------+------------+------+----------------+-------------+-----------------+--------------+-----------+----------------+---------------------+-------------+------------+-----------------+----------+----------------+---------+

| Name | Engine | Version | Row_format | Rows | Avg_row_length | Data_length | Max_data_length | Index_length | Data_free | Auto_increment | Create_time | Update_time | Check_time | Collation | Checksum | Create_options | Comment |

+----------+--------+---------+------------+------+----------------+-------------+-----------------+--------------+-----------+----------------+---------------------+-------------+------------+-----------------+----------+----------------+---------+

| networks | InnoDB | 10 | Compact | 3 | 5461 | 16384 | 0 | 0 | 0 | NULL | 2014-06-25 16:32:24 | NULL | NULL | utf8_unicode_ci | NULL | | |

+----------+--------+---------+------------+------+----------------+-------------+-----------------+--------------+-----------+----------------+---------------------+-------------+------------+-----------------+----------+----------------+---------+ 1 row in set (0.00 sec)

Do you have some ideas? Thanks a lot, Dwyane.