Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

virsh not running VM automatically

Hi 

I'm trying to run VM from controller node onto compute node and it is stucking at spawning state.I'm able to get the libvirt.xml in /opt/stack/data/nova/instances/729482302900..... on the compute node  and below is the libvirt.xml file..

domain type="kvm">
  <uuid>7210aa10-6c98-418a-b97e-94ef2dcbb7f3</uuid>Hi

I'm trying to run VM from controller node onto compute node and it is stucking at spawning state.I'm able to get the libvirt.xml in /opt/stack/data/nova/instances/729482302900..... on the compute node and below is the libvirt.xml file..

domain type="kvm"> <uuid>7210aa10-6c98-418a-b97e-94ef2dcbb7f3</uuid> <name>instance-00000003</name> <memory>524288</memory> <vcpu>1</vcpu> <os> <type machine="ppce500">hvm</type> <kernel>/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/kernel</kernel> <initrd>/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/ramdisk</initrd> <cmdline>root=/dev/vda console=tty0 console=ttyS0</cmdline> </os> <features> <acpi/> <apic/> </features> <clock offset="utc"> <timer name="pit" tickpolicy="delay"/> <timer name="rtc" tickpolicy="catchup"/> </clock> <devices> <disk type="file" device="disk"> <driver name="qemu" type="qcow2" cache="none"/> <source file="/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/disk"/> <target bus="virtio" dev="vda"/> </disk> <interface> <model type="virtio"/> <source bridge="qbr5d2ebebf-03"/> <target dev="tap5d2ebebf-03"/> <filterref filter="nova-instance-instance-00000003-fa163ebb2b75"/> </interface> <serial type="file"> <source path="/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/console.log"/> </serial> <serial type="pty"/> </devices> </domain>

I'm able to manually run VM through virsh and it is appearing running in virsh list but I'm not able to understand that why it is not able to run automatically from the cloud itself.

Below are the steps for running VM manually through virsh..

virsh undefine instance-00000003 virsh define libvirt.xml virsh start instance-00000003

Please help regarding this.

Thanks <name>instance-00000003</name> <memory>524288</memory> <vcpu>1</vcpu> <os> <type machine="ppce500">hvm</type> <kernel>/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/kernel</kernel> <initrd>/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/ramdisk</initrd> <cmdline>root=/dev/vda console=tty0 console=ttyS0</cmdline> </os> <features> <acpi/> <apic/> </features> <clock offset="utc"> <timer name="pit" tickpolicy="delay"/> <timer name="rtc" tickpolicy="catchup"/> </clock> <devices> <disk type="file" device="disk"> <driver name="qemu" type="qcow2" cache="none"/> <source file="/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/disk"/> <target bus="virtio" dev="vda"/> </disk> <interface> <model type="virtio"/> <source bridge="qbr5d2ebebf-03"/> <target dev="tap5d2ebebf-03"/> <filterref filter="nova-instance-instance-00000003-fa163ebb2b75"/> </interface> <serial type="file"> <source path="/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/console.log"/> </serial> <serial type="pty"/> </devices> </domain>

I'm able to manually run VM through virsh and it is appearing running in virsh list but I'm not able to understand that why it is not able to run automatically from the cloud itself.

Below are the steps for running VM manually through virsh..

virsh undefine instance-00000003
virsh define libvirt.xml
virsh start  instance-00000003

Please help regarding this.

Thanks

virsh not running VM automatically

 Hi  

I'm trying to run VM from controller node onto compute node and it is stucking at spawning state.I'm able to get the libvirt.xml in /opt/stack/data/nova/instances/729482302900..... on the compute node  and below is the libvirt.xml file..

domain type="kvm">
  <uuid>7210aa10-6c98-418a-b97e-94ef2dcbb7f3</uuid>Hi

I'm trying to run VM from controller node onto compute node and it is stucking at spawning state.I'm able to get the libvirt.xml in /opt/stack/data/nova/instances/729482302900..... on the compute node and below is the libvirt.xml file..

domain type="kvm"> <uuid>7210aa10-6c98-418a-b97e-94ef2dcbb7f3</uuid> <name>instance-00000003</name> <memory>524288</memory> <vcpu>1</vcpu> <os> <type machine="ppce500">hvm</type> <kernel>/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/kernel</kernel> <initrd>/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/ramdisk</initrd> <cmdline>root=/dev/vda console=tty0 console=ttyS0</cmdline> </os> <features> <acpi/> <apic/> </features> <clock offset="utc"> <timer name="pit" tickpolicy="delay"/> <timer name="rtc" tickpolicy="catchup"/> </clock> <devices> <disk type="file" device="disk"> <driver name="qemu" type="qcow2" cache="none"/> <source file="/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/disk"/> <target bus="virtio" dev="vda"/> </disk> <interface> <model type="virtio"/> <source bridge="qbr5d2ebebf-03"/> <target dev="tap5d2ebebf-03"/> <filterref filter="nova-instance-instance-00000003-fa163ebb2b75"/> </interface> <serial type="file"> <source path="/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/console.log"/> </serial> <serial type="pty"/> </devices> </domain>

</domain> I'm able to manually run VM through virsh and it is appearing running in virsh list but I'm not able to understand that why it is not able to run automatically from the cloud itself.

Below are the steps for running VM manually through virsh..

virsh undefine instance-00000003 virsh define libvirt.xml virsh start instance-00000003

Please help regarding this.

Thanks <name>instance-00000003</name> <memory>524288</memory> <vcpu>1</vcpu> <os> <type machine="ppce500">hvm</type> <kernel>/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/kernel</kernel> <initrd>/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/ramdisk</initrd> <cmdline>root=/dev/vda console=tty0 console=ttyS0</cmdline> </os> <features> <acpi/> <apic/> </features> <clock offset="utc"> <timer name="pit" tickpolicy="delay"/> <timer name="rtc" tickpolicy="catchup"/> </clock> <devices> <disk type="file" device="disk"> <driver name="qemu" type="qcow2" cache="none"/> <source file="/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/disk"/> <target bus="virtio" dev="vda"/> </disk> <interface> <model type="virtio"/> <source bridge="qbr5d2ebebf-03"/> <target dev="tap5d2ebebf-03"/> <filterref filter="nova-instance-instance-00000003-fa163ebb2b75"/> </interface> <serial type="file"> <source path="/opt/stack/data/nova/instances/7210aa10-6c98-418a-b97e-94ef2dcbb7f3/console.log"/> </serial> <serial type="pty"/> </devices> </domain>

I'm able to manually run VM through virsh and it is appearing running in virsh list but I'm not able to understand that why it is not able to run automatically from the cloud itself.

Below are the steps for running VM manually through virsh..

virsh undefine instance-00000003
virsh define libvirt.xml
virsh start  instance-00000003

Please help regarding this.

Thanks