Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

yum command equivalent for Swift Installation.

Hi, I am following the site:- http://www.server-world.info/en/ for Openstack Ubuntu 14.04 installation. There are no specific steps for Swift Installation. So I referred the CentOS section here:- http://www.server-world.info/en/note?os=CentOS_6&p=openstack_havana&f=18. The command for installing Swift-Proxy is as follows:- yum --enablerepo=openstack-havana,epel -y install openstack-swift-proxy memcached openssh-clients .

Is there an equivalent apt-get command for this. I am finding trouble with this command. I installed yum on Ubuntu but the command is giving the following errors:-

Error: Package: 1:python-oslo-config-1.2.1-1.el6.noarch (openstack-havana) Requires: python-setuptools Error: Package: 1:python-keystoneclient-0.7.1-2.el6.noarch (openstack-havana) Requires: python-keyring Error: Package: 1:python-keystoneclient-0.7.1-2.el6.noarch (openstack-havana) Requires: python-netaddr Error: Package: openstack-swift-proxy-1.10.0-2.el6.noarch (openstack-havana) Requires: openstack-swift-plugin-swift3 Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: /bin/sh Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: python-configobj Error: Package: 1:python-keystoneclient-0.7.1-2.el6.noarch (openstack-havana) Requires: python-argparse Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: /usr/bin/python Error: Package: 1:python-keystoneclient-0.7.1-2.el6.noarch (openstack-havana) Requires: python-setuptools Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: python-netifaces Error: Package: 1:python-oslo-config-1.2.1-1.el6.noarch (openstack-havana) Requires: python(abi) = 2.6 Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: initscripts Error: Package: python-swiftclient-2.0.2-1.el6.noarch (openstack-havana) Requires: python-requests Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: python(abi) = 2.6 Error: Package: 1:python-keystoneclient-0.7.1-2.el6.noarch (openstack-havana) Requires: python(abi) = 2.6 Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: chkconfig Error: Package: python-swiftclient-2.0.2-1.el6.noarch (openstack-havana) Requires: python(abi) = 2.6 Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: python-simplejson Error: Package: openstack-swift-proxy-1.10.0-2.el6.noarch (openstack-havana) Requires: /bin/sh Error: Package: 1:python-keystoneclient-0.7.1-2.el6.noarch (openstack-havana) Requires: /usr/bin/python Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: shadow-utils Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: python-eventlet >= 0.9.15 Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: python-setuptools Error: Package: 1:python-keystoneclient-0.7.1-2.el6.noarch (openstack-havana) Requires: python-requests >= 0.8.8 Error: Package: python-iso8601-0.1.8-1.el6.noarch (openstack-havana) Requires: python(abi) = 2.6 Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: python-greenlet >= 0.3.1 Error: Package: 1:python-keystoneclient-0.7.1-2.el6.noarch (openstack-havana) Requires: python-babel Error: Package: openstack-swift-proxy-1.10.0-2.el6.noarch (openstack-havana) Requires: /usr/bin/python Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: pyxattr Error: Package: openstack-swift-1.10.0-2.el6.noarch (openstack-havana) Requires: python-paste-deploy1.5 Error: Package: python-six-1.5.2-1.el6.noarch (openstack-havana) Requires: python(abi) = 2.6 Error: Package: 1:python-oslo-config-1.2.1-1.el6.noarch (openstack-havana) Requires: python-argparse Error: Package: 1:python-keystoneclient-0.7.1-2.el6.noarch (openstack-havana) Requires: python-prettytable Error: Package: python-swiftclient-2.0.2-1.el6.noarch (openstack-havana) Requires: /usr/bin/python Error: Package: openstack-swift-proxy-1.10.0-2.el6.noarch (openstack-havana) Requires: python(abi) = 2.6 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

Please help me on this.