Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

RDO Icehouse: Can't boot from volume

I have a configuration with separate machines for compute and controller nodes. RHEL 6.5, RDO Icehouse.

When I try to boot from boot volume (both in dashboard and console), I get the following error:

2014-05-19 12:37:56.491 4145 WARNING nova.virt.libvirt.driver [req-62c6aada-c059-4945-bd5b-95aa6d771c28 995970258750465496fed29039c3f4c9 11fdc52234914c3ebf3f565b8a94339f] [instance: 7ca49563-5a88-4f2d-9f59-0cd3ce888e3f] File injection into a boot from volume instance is not supported

Then it waits for 5 minutes, then instance start fails (KVM VM is in 'paused' mode). Cinder works with iSCSI NetApp plugin (C-mode direct), but with the standard LVM the problem remains. Volumes themselves work and get mapped. If I mount boot volume to an already started instance, it has the files.

I tried to boot from RAW volume - same result.

Boot from volume is turned on in nova settings.

What can it be?