Revision history [back]

click to hide/show revision 1
initial version

Openstack VM is not accessible on LAN

I am facing issue with accessing Open stack VM's on LAN.

  • I have setup single machine(192.168.2.15) opensatck using devstack, so all VM's are running inside this machine My machine(192.168.2.15) has one network card(eth0) and
  • I have installed neutron.
  • I have assigned static IP on eth0 of all the LAN machine( such as 192.168.2.15 and 192.168.2.16) in /etc/network/interfaces

Below works fine

  1. I can access internet from VM1(10.0.0.2 which is auto assigned IP).
  2. I can ping LAN machine(192.168.2.16) from VM1.
  3. Openstack machine(192.168.2.15) can ping VM1(10.0.0.2). VM1(10.0.0.2) can ping VM2(10.0.0.3).

But LAN machine 192.168.2.16 is not able to ping VM1(10.0.0.2)

So please suggest how can it be achieved ? And Please consider me as very new to Openstack and networking.

Thanks !!!

Openstack VM is not accessible on LAN

I am facing issue with accessing Open stack VM's on LAN.

  • I have setup single machine(192.168.2.15) opensatck using devstack, so all VM's are running inside this machine My machine(192.168.2.15) has one network card(eth0) and
  • I have installed neutron.neutron on same machine (192.168.2.15).
  • I have assigned static IP on eth0 of all the LAN machine( such as 192.168.2.15 and 192.168.2.16) in /etc/network/interfaces

Below works fine

  1. I can access internet from VM1(10.0.0.2 which is auto assigned IP).
  2. I can ping LAN machine(192.168.2.16) from VM1.
  3. Openstack machine(192.168.2.15) can ping VM1(10.0.0.2). VM1(10.0.0.2) can ping VM2(10.0.0.3).

But LAN machine 192.168.2.16 is not able to ping VM1(10.0.0.2)

So please suggest how can it be achieved ? And Please consider me as very new to Openstack and networking.

Thanks !!!