Revision history [back]

click to hide/show revision 1
initial version

Nova cannot create network

Hello All,

I followed all the steps of installing openstack on Debian Wheezy using this documentation (http://docs.openstack.org/icehouse/install-guide/install/apt-debian/content/index.html). I am trying to setup the legacy network scenario where I have two nodes (one acting as controller and the latter acting as compute node). I have successfully setup Keystone, Image service and Nova controller. However, when the time comes to create the network by using legacy nova-network scenario, the following happens (i am just pasting the highlight of the logs);

2014-04-29 18:59:59.295 4844 DEBUG nova.api.openstack.compute.contrib.os_networks [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] Creating network with label demo-net create /usr/lib/python2.7/dist-packages/nova/api/openstack/compute/contrib/os_networks.py:126

2014-04-29 18:59:59.308 4844 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on localhost:5672

2014-04-29 18:59:59.324 4844 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on localhost:5672

2014-04-29 19:00:59.385 4844 TRACE nova.api.openstack MessagingTimeout: Timed out waiting for a reply to message ID 38c920b0890341069d85556bd28f07a0

2014-04-29 19:00:59.385 4844 TRACE nova.api.openstack

2014-04-29 19:00:59.389 4844 INFO nova.api.openstack [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] http://10.20.30.113:8774/v2/2188d77d01974be99f0390a273dff8e3/os-networks returned with HTTP 500

2014-04-29 19:00:59.390 4844 DEBUG nova.api.openstack.wsgi [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] Returning 500 to user: The server has either erred or is incapable of performing the requested operation. __call__ /usr/lib/python2.7/dist-packages/nova/api/openstack/wsgi.py:1215

2014-04-29 19:00:59.390 4844 INFO nova.osapi_compute.wsgi.server [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] 10.20.30.113 "POST /v2/2188d77d01974be99f0390a273dff8e3/os-networks HTTP/1.1" status: 500 len: 335 time: 60.7838590

I am using the following command;

nova network-create demo-net --bridge br100 --multi-host T --fixed-range-v4 203.0.113.24/29

Following is the output to make sure OpenStack has been setup correctly as per the guide till this point;

# keystone user-list
+----------------------------------+-------+---------+----------------+ | id | name | enabled | email | +----------------------------------+-------+---------+----------------+ | 3f31b75b621d42849e6f90983120ac81 | admin | True | root@localhost | +----------------------------------+-------+---------+----------------+

# glance image-list
+--------------------------------------+---------------------+-------------+------------------+----------+--------+ | ID | Name | Disk Format | Container Format | Size | Status | +--------------------------------------+---------------------+-------------+------------------+----------+--------+ | 88dfb568-92b5-4112-9eba-a36a39f3641b | cirros-0.3.2-x86_64 | qcow2 | bare | 13167616 | active | +--------------------------------------+---------------------+-------------+------------------+----------+--------+

#nova image-list
+--------------------------------------+---------------------+--------+--------+ | ID | Name | Status | Server | +--------------------------------------+---------------------+--------+--------+ | 88dfb568-92b5-4112-9eba-a36a39f3641b | cirros-0.3.2-x86_64 | ACTIVE | | +--------------------------------------+---------------------+--------+--------+

# nova network-create demo-net --bridge br100 --multi-host T --fixed-range-v4 203.0.113.24/29 ERROR: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-2acbaa01-b401-43d4-8360-9d58cf12ae05)

My hosts file is correctly setup as the guide suggests. What I have done so far;

1) Rebooted the controller
2) restarted RabbitMQ multiple times
3) Checked/Resetted the rabbitMQ passord (log tells it is connected)

Following is the rabbitMQ config from nova.conf;

#

# RABBITMQ #

#

rabbit_host = localhost fake_rabbit=false rabbit_virtual_host=/ rabbit_userid = guest rabbit_password = guest rabbit_port=5672 rabbit_use_ssl=false rabbit_retry_interval=3 **# The messaging module to use, defaults to kombu (works for rabbit).

You can also use qpid: nova.rpc.impl_qpid**

rpc_backend = nova.openstack.common.rpc.impl_kombu

Neutron is not setup since I intend to use legacy network. Any hints?

Nova cannot create network

Hello All,

I followed all the steps of installing openstack on Debian Wheezy using this documentation (http://docs.openstack.org/icehouse/install-guide/install/apt-debian/content/index.html). I am trying to setup the legacy network scenario where I have two nodes (one acting as controller and the latter acting as compute node). I have successfully setup Keystone, Image service and Nova controller. However, when the time comes to create the network by using legacy nova-network scenario, the following happens (i am just pasting the highlight of the logs);

2014-04-29 18:59:59.295 4844 DEBUG nova.api.openstack.compute.contrib.os_networks [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] Creating network with label demo-net create /usr/lib/python2.7/dist-packages/nova/api/openstack/compute/contrib/os_networks.py:126

2014-04-29 18:59:59.308 4844 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on localhost:5672

2014-04-29 18:59:59.324 4844 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on localhost:5672

2014-04-29 19:00:59.385 4844 TRACE nova.api.openstack MessagingTimeout: Timed out waiting for a reply to message ID 38c920b0890341069d85556bd28f07a0

2014-04-29 19:00:59.385 4844 TRACE nova.api.openstack

2014-04-29 19:00:59.389 4844 INFO nova.api.openstack [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] http://10.20.30.113:8774/v2/2188d77d01974be99f0390a273dff8e3/os-networks returned with HTTP 500

2014-04-29 19:00:59.390 4844 DEBUG nova.api.openstack.wsgi [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] Returning 500 to user: The server has either erred or is incapable of performing the requested operation. __call__ /usr/lib/python2.7/dist-packages/nova/api/openstack/wsgi.py:1215

2014-04-29 19:00:59.390 4844 INFO nova.osapi_compute.wsgi.server [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] 10.20.30.113 "POST /v2/2188d77d01974be99f0390a273dff8e3/os-networks HTTP/1.1" status: 500 len: 335 time: 60.7838590

I am using the following command;

nova network-create demo-net --bridge br100 --multi-host T --fixed-range-v4 203.0.113.24/29

Following is the output to make sure OpenStack has been setup correctly as per the guide till this point;

# keystone user-list
+----------------------------------+-------+---------+----------------+ | id | name | enabled | email | +----------------------------------+-------+---------+----------------+ | 3f31b75b621d42849e6f90983120ac81 | admin | True | root@localhost | +----------------------------------+-------+---------+----------------+

# glance image-list
+--------------------------------------+---------------------+-------------+------------------+----------+--------+ | ID | Name | Disk Format | Container Format | Size | Status | +--------------------------------------+---------------------+-------------+------------------+----------+--------+ | 88dfb568-92b5-4112-9eba-a36a39f3641b | cirros-0.3.2-x86_64 | qcow2 | bare | 13167616 | active | +--------------------------------------+---------------------+-------------+------------------+----------+--------+

#nova image-list
+--------------------------------------+---------------------+--------+--------+ | ID | Name | Status | Server | +--------------------------------------+---------------------+--------+--------+ | 88dfb568-92b5-4112-9eba-a36a39f3641b | cirros-0.3.2-x86_64 | ACTIVE | | +--------------------------------------+---------------------+--------+--------+

# nova network-create demo-net --bridge br100 --multi-host T --fixed-range-v4 203.0.113.24/29 ERROR: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-2acbaa01-b401-43d4-8360-9d58cf12ae05)

My hosts file is correctly setup as the guide suggests. What I have done so far;

1) Rebooted the controller
2) restarted RabbitMQ multiple times
3) Checked/Resetted the rabbitMQ passord (log tells it is connected)

Following is the rabbitMQ config from nova.conf;

#

# RABBITMQ #

#

rabbit_host = localhost fake_rabbit=false rabbit_virtual_host=/ rabbit_userid = guest rabbit_password = guest rabbit_port=5672 rabbit_use_ssl=false rabbit_retry_interval=3 **# # The messaging module to use, defaults to kombu (works for rabbit).

rabbit). *# You can also use qpid: nova.rpc.impl_qpid**

nova.rpc.impl_qpid* rpc_backend = nova.openstack.common.rpc.impl_kombu

Neutron is not setup since I intend to use legacy network. Any hints?

Nova cannot create network

Hello All,

I followed all the steps of installing openstack on Debian Wheezy using this documentation (http://docs.openstack.org/icehouse/install-guide/install/apt-debian/content/index.html). documentation. I am trying to setup the legacy network scenario where I have two nodes (one acting as controller and the latter acting as compute node). I have successfully setup Keystone, Image service and Nova controller. However, when the time comes to create the network by using legacy nova-network scenario, the following happens (i am just pasting the highlight of the logs);

2014-04-29 18:59:59.295 4844 DEBUG nova.api.openstack.compute.contrib.os_networks [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] Creating network with label demo-net create /usr/lib/python2.7/dist-packages/nova/api/openstack/compute/contrib/os_networks.py:126

/usr/lib/python2.7/dist-packages/nova/api/openstack/compute/contrib/os_networks.py:126 2014-04-29 18:59:59.308 4844 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on localhost:5672

localhost:5672 2014-04-29 18:59:59.324 4844 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on localhost:5672

localhost:5672 2014-04-29 19:00:59.385 4844 TRACE nova.api.openstack MessagingTimeout: Timed out waiting for a reply to message ID 38c920b0890341069d85556bd28f07a0

38c920b0890341069d85556bd28f07a0 2014-04-29 19:00:59.385 4844 TRACE nova.api.openstack

2014-04-29 19:00:59.389 4844 INFO nova.api.openstack [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] http://10.20.30.113:8774/v2/2188d77d01974be99f0390a273dff8e3/os-networks returned with HTTP 500

500 2014-04-29 19:00:59.390 4844 DEBUG nova.api.openstack.wsgi [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] Returning 500 to user: The server has either erred or is incapable of performing the requested operation. __call__ /usr/lib/python2.7/dist-packages/nova/api/openstack/wsgi.py:1215

/usr/lib/python2.7/dist-packages/nova/api/openstack/wsgi.py:1215 2014-04-29 19:00:59.390 4844 INFO nova.osapi_compute.wsgi.server [req-54fef079-4796-4b5c-851f-0960d6a2e323 3f31b75b621d42849e6f90983120ac81 2188d77d01974be99f0390a273dff8e3] 10.20.30.113 "POST /v2/2188d77d01974be99f0390a273dff8e3/os-networks HTTP/1.1" status: 500 len: 335 time: 60.7838590

60.7838590

I am using the following command;

nova network-create demo-net --bridge br100 --multi-host T   --fixed-range-v4 203.0.113.24/29

203.0.113.24/29

Following is the output to make sure OpenStack has been setup correctly as per the guide till this point;

#

**# keystone user-list
user-list<br>** +----------------------------------+-------+---------+----------------+ | id | name | enabled | email | +----------------------------------+-------+---------+----------------+ | 3f31b75b621d42849e6f90983120ac81 | admin | True | root@localhost | +----------------------------------+-------+---------+----------------+

# +----------------------------------+-------+---------+----------------+ **# glance image-list
image-list<br>** +--------------------------------------+---------------------+-------------+------------------+----------+--------+ | ID | Name | Disk Format | Container Format | Size | Status | +--------------------------------------+---------------------+-------------+------------------+----------+--------+ | 88dfb568-92b5-4112-9eba-a36a39f3641b | cirros-0.3.2-x86_64 | qcow2 | bare | 13167616 | active | +--------------------------------------+---------------------+-------------+------------------+----------+--------+

#nova image-list
+--------------------------------------+---------------------+-------------+------------------+----------+--------+ **#nova image-list<br>** +--------------------------------------+---------------------+--------+--------+ | ID | Name | Status | Server | +--------------------------------------+---------------------+--------+--------+ | 88dfb568-92b5-4112-9eba-a36a39f3641b | cirros-0.3.2-x86_64 | ACTIVE | | +--------------------------------------+---------------------+--------+--------+

# +--------------------------------------+---------------------+--------+--------+ **# nova network-create demo-net --bridge br100 --multi-host T --fixed-range-v4 203.0.113.24/29 ERROR: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-2acbaa01-b401-43d4-8360-9d58cf12ae05)

req-2acbaa01-b401-43d4-8360-9d58cf12ae05)**

My hosts file is correctly setup as the guide suggests. What I have done so far;

1) Rebooted the controller
2) restarted RabbitMQ multiple times
3) Checked/Resetted the rabbitMQ passord (log tells it is connected)

Following is the rabbitMQ config from nova.conf;

#

#

############
**# RABBITMQ #

#

#** ############ rabbit_host = localhost fake_rabbit=false rabbit_virtual_host=/ rabbit_userid = guest rabbit_password = guest rabbit_port=5672 rabbit_use_ssl=false rabbit_retry_interval=3 # **# The messaging module to use, defaults to kombu (works for rabbit). *# **# You can also use qpid: nova.rpc.impl_qpid* nova.rpc.impl_qpid**** rpc_backend = nova.openstack.common.rpc.impl_kombu

nova.openstack.common.rpc.impl_kombu

Neutron is not setup since I intend to use legacy network. Any hints?