Revision history [back]

click to hide/show revision 1
initial version

[Havana] [Nova] [Ubuntu] Nova services do not start

I am following this guide - http://docs.openstack.org/havana/install-guide/install/apt/content/nova-compute.html

I am unable to start the nova-* services on the compute node. I get an entry in the syslog saying: "init: nova-compute main process (2940) terminated with status 1"

I believe this bug was documented here - https://bugs.launchpad.net/ubuntu/+source/nova/+bug/991901. But this is a very old bug and the solutions that are mentioned in the comments don't work for me.

Because the nova services don't start, there are no logs in /var/log/nova/ But I find the following in /var/log/upstart/nova-compute.log:

Traceback (most recent call last):
  File "/usr/bin/nova-compute", line 6, in <module>
    from nova.cmd.compute import main
ImportError: No module named cmd.compute
Traceback (most recent call last):
  File "/usr/bin/nova-compute", line 6, in <module>
    from nova.cmd.compute import main
ImportError: No module named cmd.compute

Same goes for nova-network and nova-api-metadata

I don't know if this is a migration issue from grizzle to havana or a permissions issue. I'd appreciate help here. I've already posted on the openstack mailing list and IRC chats

Naman

[Havana] [Nova] [Ubuntu] Nova services do not start

I am following this guide - http://docs.openstack.org/havana/install-guide/install/apt/content/nova-compute.html

I am unable to start the nova-* services on the compute node. I get an entry in the syslog saying: "init: saying:

init: nova-compute main process (2940) terminated with status 1"

1

I believe this bug was documented here - https://bugs.launchpad.net/ubuntu/+source/nova/+bug/991901. But this is a very old bug and the solutions that are mentioned in the comments don't work for me.

Because the nova services don't start, there are no logs in /var/log/nova/ But I find the following in /var/log/upstart/nova-compute.log:

Traceback (most recent call last):
  File "/usr/bin/nova-compute", line 6, in <module>
    from nova.cmd.compute import main
ImportError: No module named cmd.compute
Traceback (most recent call last):
  File "/usr/bin/nova-compute", line 6, in <module>
    from nova.cmd.compute import main
ImportError: No module named cmd.compute

Same goes for nova-network and nova-api-metadata

I don't know if this is a migration issue from grizzle to havana or a permissions issue. I'd appreciate help here. I've already posted on the openstack mailing list and IRC chats

Naman