Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

simple network configuration

Hi All,

I try to configure neutron/open-switch to work only with my local network, but without any effect.

My physical local net: 192.168.1.0/24

All OpenStack modules are installed on the same node. OpenStack Node networks: eth0: static 192.168.1.50 eth1: in this moment not configured ? only allow-hotplug eth1

openstack# ovs-vsctl list-br
br-eth1
br-int

openstack# ovs-vsctl list-ports br-eth1
eth1
phy-br-eth1


 openstack#  neutron net-show b009e731-aa82-4adb-a02a-c3b1f2b0b2d0
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | b009e731-aa82-4adb-a02a-c3b1f2b0b2d0 |
| name                      | Public                               |
| provider:network_type     | vlan                                 |
| provider:physical_network | physnet1                             |
| provider:segmentation_id  | 3                                    |
| router:external           | True                                 |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   | c1411c10-833b-4dd6-8aac-f371b029d9dd |
| tenant_id                 | 24ed12f3ac7143158e538250b1358e7d     |
+---------------------------+--------------------------------------+

 openstack#  neutron subnet-show c1411c10-833b-4dd6-8aac-f371b029d9dd
+------------------+----------------------------------------------------+
| Field            | Value                                              |
+------------------+----------------------------------------------------+
| allocation_pools | {"start": "192.168.1.100", "end": "192.168.1.222"} |
| cidr             | 192.168.1.0/24                                     |
| dns_nameservers  |                                                    |
| enable_dhcp      | False                                              |
| gateway_ip       | 192.168.1.1                                        |
| host_routes      |                                                    |
| id               | c1411c10-833b-4dd6-8aac-f371b029d9dd               |
| ip_version       | 4                                                  |
| name             |                                                    |
| network_id       | b009e731-aa82-4adb-a02a-c3b1f2b0b2d0               |
| tenant_id        | 24ed12f3ac7143158e538250b1358e7d                   |
+------------------+----------------------------------------------------+


openstack# cat /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
[ovs]
tenant_network_type = vlan
network_vlan_ranges = physnet1:1:4094
bridge_mappings = physnet1:br-eth1

I launch instance with IP 192.168.1.100

    openstack# arp
        Address                  HWtype  HWaddress           Flags Mask            Iface
        192.168.1.100                    (incomplete)                              eth0
             .....

But I can't ping or nmap this VM ?

Where I make mistake ?

Or what I should read ?

I read everything on openstack page, but this guides for me are seems incomplete

I'm new in virtual networks.

Please help :)

simple network configuration

Hi All,

I try to configure neutron/open-switch to work only with my local network, but without any effect.

My physical local net: 192.168.1.0/24

All OpenStack modules are installed on the same node. OpenStack Node networks: networks:

eth0: static 192.168.1.50
eth1: in this moment not configured ? only allow-hotplug eth1

eth1

openstack# ovs-vsctl list-br
br-eth1
br-int

openstack# ovs-vsctl list-ports br-eth1
eth1
phy-br-eth1


 openstack#  neutron net-show b009e731-aa82-4adb-a02a-c3b1f2b0b2d0
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | b009e731-aa82-4adb-a02a-c3b1f2b0b2d0 |
| name                      | Public                               |
| provider:network_type     | vlan                                 |
| provider:physical_network | physnet1                             |
| provider:segmentation_id  | 3                                    |
| router:external           | True                                 |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   | c1411c10-833b-4dd6-8aac-f371b029d9dd |
| tenant_id                 | 24ed12f3ac7143158e538250b1358e7d     |
+---------------------------+--------------------------------------+

 openstack#  neutron subnet-show c1411c10-833b-4dd6-8aac-f371b029d9dd
+------------------+----------------------------------------------------+
| Field            | Value                                              |
+------------------+----------------------------------------------------+
| allocation_pools | {"start": "192.168.1.100", "end": "192.168.1.222"} |
| cidr             | 192.168.1.0/24                                     |
| dns_nameservers  |                                                    |
| enable_dhcp      | False                                              |
| gateway_ip       | 192.168.1.1                                        |
| host_routes      |                                                    |
| id               | c1411c10-833b-4dd6-8aac-f371b029d9dd               |
| ip_version       | 4                                                  |
| name             |                                                    |
| network_id       | b009e731-aa82-4adb-a02a-c3b1f2b0b2d0               |
| tenant_id        | 24ed12f3ac7143158e538250b1358e7d                   |
+------------------+----------------------------------------------------+


openstack# cat /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
[ovs]
tenant_network_type = vlan
network_vlan_ranges = physnet1:1:4094
bridge_mappings = physnet1:br-eth1

I launch instance with IP 192.168.1.100

    openstack# arp
        Address                  HWtype  HWaddress           Flags Mask            Iface
        192.168.1.100                    (incomplete)                              eth0
             .....

But I can't ping or nmap this VM ?

Where I make mistake ?

Or what I should read ?

I read everything on openstack page, but this guides for me are seems incomplete

I'm new in virtual networks.

Please help :)