Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

HA: not able to connect with virtualIP

HA setup with mysql and galera

LB1: 192.168.2.139

Controller1: 192.168.2.151

Controller2: 192.168.2.152

Controller3: 192.168.2.153

VirtualIP: 192.168.2.221

On Controller1 or on Controller2 , when i am starting neutron-server it is stopping automatically. In log, i am getting error:

TRACE neutron OperationalError: (OperationalError) (2013, "Lost connection to MySQL server at 'reading initial communication packet', system error: 0") None None

On LB, when i am executing, mysql -u root -ppassword -h 192.168.2.151 it is working fine but when i am connecting with virtual Ip i.e.mysql -u root -ppassword -h 192.168.2.221

ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 0

and output of telnet 192.168.2.221 3306 is

Trying 192.168.2.221...
Connected to 192.168.2.221.
Escape character is '^]'.
Connection closed by foreign host.

HA: neutron-server not able to connect with virtualIP

HA setup with mysql and galera

LB1: 192.168.2.139

Controller1: 192.168.2.151

Controller2: 192.168.2.152

Controller3: 192.168.2.153

VirtualIP: 192.168.2.221

On Controller1 or on Controller2 , when i am starting neutron-server it is stopping automatically. In log, i am getting error:

TRACE neutron OperationalError: (OperationalError) (2013, "Lost connection to MySQL server at 'reading initial communication packet', system error: 0") None None

On LB, when i am executing, mysql -u root -ppassword -h 192.168.2.151 it is working fine but when i am connecting with virtual Ip i.e.mysql -u root -ppassword -h 192.168.2.221

ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 0

and output of telnet 192.168.2.221 3306 is

Trying 192.168.2.221...
Connected to 192.168.2.221.
Escape character is '^]'.
Connection closed by foreign host.

HA: neutron-server not able to connect with virtualIP

HA setup with mysql and galera

LB1: 192.168.2.139

Controller1: 192.168.2.151

Controller2: 192.168.2.152

Controller3: 192.168.2.153

VirtualIP: 192.168.2.221

On Controller1 or on Controller2 , when i am starting neutron-server it is stopping automatically. In log, i am getting error:

TRACE neutron OperationalError: (OperationalError) (2013, "Lost connection to MySQL server at 'reading initial communication packet', system error: 0") None None

On LB, when i am executing, mysql -u root -ppassword -h 192.168.2.151 it is working fine but when i am connecting with virtual Ip i.e.mysql -u root -ppassword -h 192.168.2.221

ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 0

and output of telnet 192.168.2.221 3306 is

Trying 192.168.2.221...
Connected to 192.168.2.221.
Escape character is '^]'.
Connection closed by foreign host.

HA: neutron-server not able to connect with virtualIP

HA setup with mysql and galera

LB1: 192.168.2.139

Controller1: 192.168.2.151

Controller2: 192.168.2.152

Controller3: 192.168.2.153

VirtualIP: 192.168.2.221

On Controller1 or on Controller2 , when i am starting neutron-server it is stopping automatically. In log, i am getting error:

TRACE neutron OperationalError: (OperationalError) (2013, "Lost connection to MySQL server at 'reading initial communication packet', system error: 0") None None

On LB, when i am executing, mysql -u root -ppassword -h 192.168.2.151 it is working fine but when i am connecting with virtual Ip i.e.mysql -u root -ppassword -h 192.168.2.221

ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 0

and output of telnet 192.168.2.221 3306 is

Trying 192.168.2.221...
Connected to 192.168.2.221.
Escape character is '^]'.
Connection closed by foreign host.

mysql-galera is working properly on control01 and control02 i.e. database are syncing between control01 and control02