Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

AttributeError: 'Client' object has no attribute 'software_configs'

Hi Gurus....

I meant one problem when draft the HOT template. For user_data part.. Please see below for the key tags..


heat_template_version: 2013-05-23
....
resources:
  volume_format_init:
    type: OS::Heat::SoftwareConfig
    properties:
      config: |
        !/bin/bash
        mkdir -p /opt/mysql3
....

  OPPA:
    type: OS::Nova::Server
    properties:
      admin_user: lps
      key_name: { get_param : key_name }
....
      user_data_format: RAW
      user_data: |

get_resource: volume_format_init

With above template I could pass the template-validation but when I try to do the stack-create it will fail with message as below.

AttributeError: 'Client' object has no attribute 'software_configs'

[root@vNode3 v3]# heat --version
0.2.6

Highly appreciate any hint/clue.

Thanks,

AttributeError: 'Client' object has no attribute 'software_configs'

Hi Gurus....

I meant one problem when draft the HOT template. For user_data part.. Please see below for the key tags..


--------------------------------------
    heat_template_version: 2013-05-23
 ....
 resources:
   volume_format_init:
     type: OS::Heat::SoftwareConfig
     properties:
       config: |
         !/bin/bash
         mkdir -p /opt/mysql3
 ....

   OPPA:
     type: OS::Nova::Server
     properties:
       admin_user: lps
       key_name: { get_param : key_name }
 ....
       user_data_format: RAW
       user_data: |
            get_resource: volume_format_init
---------------------------------------------------------

get_resource: volume_format_init

With above template I could pass the template-validation but when I try to do the stack-create it will fail with message as below.

AttributeError: 'Client' object has no attribute 'software_configs'

[root@vNode3 v3]# heat --version
0.2.6

Highly appreciate any hint/clue.

Thanks,

AttributeError: 'Client' object has no attribute 'software_configs'

Hi Gurus....

I meant one problem when draft the HOT template. For user_data part.. Please see below for the key tags..

--------------------------------------
    heat_template_version: 2013-05-23
    ....
    resources:
      volume_format_init:
        type: OS::Heat::SoftwareConfig
        properties:
          config: |
            !/bin/bash
            mkdir -p /opt/mysql3
    ....

      OPPA:
        type: OS::Nova::Server
        properties:
          admin_user: lps
          key_name: { get_param : key_name }
    ....
          user_data_format: RAW
          user_data: |
            get_resource: volume_format_init
---------------------------------------------------------

With above template I could pass the template-validation but when I try to do the stack-create it will fail with message as below.

AttributeError: 'Client' object has no attribute 'software_configs'

[root@vNode3 v3]# heat --version
0.2.6

Same issue even I upgrade the heat client to 0.2.8.

Highly appreciate any hint/clue.

Thanks,

AttributeError: 'Client' object has no attribute 'software_configs'

Hi Gurus....

I meant met one problem when draft the HOT template. For user_data part.. Please see below for the key tags..

--------------------------------------
    heat_template_version: 2013-05-23
    ....
    resources:
      volume_format_init:
        type: OS::Heat::SoftwareConfig
        properties:
          config: |
            !/bin/bash
            mkdir -p /opt/mysql3
    ....

      OPPA:
        type: OS::Nova::Server
        properties:
          admin_user: lps
          key_name: { get_param : key_name }
    ....
          user_data_format: RAW
          user_data: |
            get_resource: volume_format_init
---------------------------------------------------------

With above template I could pass the template-validation but when I try to do the stack-create it will fail with message as below.

AttributeError: 'Client' object has no attribute 'software_configs'

[root@vNode3 v3]# heat --version
0.2.6

Same issue even I upgrade the heat client to 0.2.8.

Highly appreciate any hint/clue.

Thanks,