Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

No traffic on br-tun

I configured one network node and one compute node on a Xen based server. When a VM is bring up, it cannot get a IP address from DHCP. I tried to set its IP address manually and ping the gateway, of course, all packets are timed out.

In computer node, I run tcpdump to capture packets. For br-int, I do captured packets from client

xxxx@os-compute:~$ sudo tcpdump -i br-int tcpdump: WARNING: br-int: no IPv4 address assigned tcpdump: verbose output suppressed, use -v or -vv for full protocol decode listening on br-int, link-type EN10MB (Ethernet), capture size 65535 bytes 22:48:56.730834 ARP, Request who-has 50.50.1.1 tell ge2-0.drr02.snpr.wi.frontiernet.net, length 28

However, in br-tun, there is no traffic.

The configuration of OpenVSwitch is listed below:

xxxx@os-compute:~$ sudo ovs-vsctl show 2918272c-fa27-48f2-938c-58915f431c49 Bridge br-int Port br-int Interface br-int type: internal Port "eth3" Interface "eth3" Port patch-tun Interface patch-tun type: patch options: {peer=patch-int} Bridge br-tun Port "vxlan-1" Interface "vxlan-1" type: vxlan options: {in_key=flow, local_ip="10.3.0.16", out_key=flow, remote_ip="10.3.0.15"} Port br-tun Interface br-tun type: internal Port patch-int Interface patch-int type: patch options: {peer=patch-tun} ovs_version: "1.10.2"

No traffic on br-tun

I configured one network node and one compute node on a Xen based server. When a VM is bring up, it cannot get a IP address from DHCP. I tried to set its IP address manually and ping the gateway, of course, all packets are timed out.

In computer node, I run tcpdump to capture packets. For br-int, I do captured packets from client

xxxx@os-compute:~$ sudo tcpdump -i br-int br-int

tcpdump: WARNING: br-int: no IPv4 address assigned assigned

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode decode

listening on br-int, link-type EN10MB (Ethernet), capture size 65535 bytes bytes

22:48:56.730834 ARP, Request who-has 50.50.1.1 tell ge2-0.drr02.snpr.wi.frontiernet.net, length 28

However, in br-tun, there is no traffic.

Anyone can help me on this? Thanks.

The configuration of OpenVSwitch is listed below:

xxxx@os-compute:~$ sudo ovs-vsctl show 2918272c-fa27-48f2-938c-58915f431c49 show

2918272c-fa27-48f2-938c-58915f431c49

Bridge br-int
      Port br-int
          Interface br-int
              type: internal
      Port "eth3"
          Interface "eth3"
      Port patch-tun
          Interface patch-tun
              type: patch
              options: {peer=patch-int}
  Bridge br-tun
      Port "vxlan-1"
          Interface "vxlan-1"
              type: vxlan
              options: {in_key=flow, local_ip="10.3.0.16", out_key=flow, remote_ip="10.3.0.15"}
      Port br-tun
          Interface br-tun
              type: internal
      Port patch-int
          Interface patch-int
              type: patch
              options: {peer=patch-tun}
  ovs_version: "1.10.2"

"1.10.2"