Ask Your Question

Revision history [back]

If openstack uses libvirt to manage VM's, why is there no support for Hyper-V and ESX?

In the documentation, it says, libvirt supports Hyper-V as well as ESX, then why do components like ceilometer have no support for Hyper-V and ESX.

P.S.: Nova does support the above mentioned hypervisors.

If openstack uses libvirt to manage VM's, why is there no support for Hyper-V and ESX?

In the documentation, it says, libvirt supports Hyper-V as well as ESX, then why do some components like ceilometer ceilometer have no support for Hyper-V and ESX.

P.S.: Nova does support the above mentioned hypervisors.

click to hide/show revision 3
improved the question so that it can gen an answer

If openstack uses libvirt What are the plans for Ceilometer to manage VM's, why is there no add support for Hyper-V and ESX?

In the documentation, it says, OpenStack uses libvirt and libvirt's documentation says: libvirt supports Hyper-V as well as ESX, then why do . Nova does support the above mentioned hypervisors. Unfortunately some components of OpenStack like ceilometer have no support for Hyper-V and ESX.

P.S.: Nova does ESX. What are the plans for adding support the above mentioned hypervisors.to other hypervisors in Ceilometer?

What are the plans for Ceilometer to add support for Hyper-V and ESX?

OpenStack uses libvirt and libvirt's documentation says: libvirt supports Hyper-V as well as ESX. Nova does support the above mentioned hypervisors. Unfortunately some components of OpenStack like ceilometer have no support for Hyper-V and ESX. What are the plans for adding support to other hypervisors in Ceilometer?