Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

failed to create network by dashboard

1.Create a network by command 'neutron net-create' with parameter '--tenant-id' is OK.

neutron net-create --tenant-id 42b15ed7cc7d4986a1cc1ccdda844eca test_net

Created a new network: +---------------------------+--------------------------------------+ | Field | Value | +---------------------------+--------------------------------------+ | admin_state_up | True | | id | cccb503b-03f7-4ac3-a8c2-82dd7f1c945b | | name | test_net | | provider:network_type | vlan | | provider:physical_network | physnet1 | | provider:segmentation_id | 3 | | shared | False | | status | ACTIVE | | subnets | | | tenant_id | 42b15ed7cc7d4986a1cc1ccdda844eca | +---------------------------+--------------------------------------+

2.Create a network by command 'neutron net-create' without parameter '--tenant-id' , failed!

neutron net-create test_net

Running without keystone AuthN requires that tenant_id is specified

3.create network on dashboard, failed, error message as below: Error: Failed to create network "test_net": Running without keystone AuthN requires that tenant_id is specified

However, there is no place to set tenant_id when create a network on dashboard!!!

I think the tenant_id should be included in the request context?? But how?