Revision history [back]

click to hide/show revision 1
initial version

swift help with installation

yum install has lot of python dependencies, can someone please help?

Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly) Requires: python-argparse Error: Package: 1:python-oslo-config-1.1.0-1.el6.noarch (epel-openstack-grizzly) Requires: python-argparse Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly) Requires: openstack-swift-plugin-swift3 Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly) Requires: python-prettytable Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly) Requires: python-requests >= 0.8.8 Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly) Requires: python-netifaces Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly) Requires: python-eventlet >= 0.9.8 Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly) Requires: python-keyring Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly) Requires: python-paste-deploy1.5 Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly) Requires: python-iso8601 >= 0.1.4 Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly) Requires: python-greenlet >= 0.3.1 Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly) Requires: pyxattr You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest [root@hostname16 ~]#

swift help with installation

yum install has lot of python dependencies, can someone please help?

Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-argparse
Error: Package: 1:python-oslo-config-1.1.0-1.el6.noarch (epel-openstack-grizzly)
           Requires: python-argparse
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: openstack-swift-plugin-swift3
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-prettytable
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-requests >= 0.8.8
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-netifaces
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-eventlet >= 0.9.8
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-keyring
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-paste-deploy1.5
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-iso8601 >= 0.1.4
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-greenlet >= 0.3.1
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: pyxattr
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@hostname16 ~]# 

~]#

swift help with installationHow to solve broken dependencies for Swift RPM packages?

yum install has lot of python dependencies, can someone please help?

Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-argparse
Error: Package: 1:python-oslo-config-1.1.0-1.el6.noarch (epel-openstack-grizzly)
           Requires: python-argparse
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: openstack-swift-plugin-swift3
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-prettytable
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-requests >= 0.8.8
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-netifaces
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-eventlet >= 0.9.8
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-keyring
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-paste-deploy1.5
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-iso8601 >= 0.1.4
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-greenlet >= 0.3.1
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: pyxattr
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@hostname16 ~]#