Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Glance Scrubber not running

Hi, I am installing openstack with Xen Server, I followed the official tutorial from openstack, I am blocked in Glance Scrubber that did not want to start.

Even I ignored this step of the tutorial, I was confronted to another problem when creating the test machine

The config glance-scrubber.com and log file scrubber.log :

[DEFAULT]

Show more verbose log output (sets INFO log level output)

verbose = True

Show debugging output in logs (sets DEBUG log level output)

debug = False

Log to this file. Make sure you do not set the same log

file for both the API and registry servers!

log_file = /var/log/glance/scrubber.log

# filesystem_store_datadir = /var/lib/glance/images/

Send logs to syslog (/dev/log) instead of to file specified by log_file

use_syslog = False

Delayed delete time in seconds

scrub_time = 43200

Should we run our own loop or rely on cron/scheduler to run us

daemon = False

Loop time between checking the db for new items to schedule for delete

wakeup_time = 300

SQLAlchemy connection string for the reference implementation

registry server. Any valid SQLAlchemy connection string is fine.

See: http://www.sqlalchemy.org/docs/05/reference/sqlalchemy/connections.html#$

sql_connection = mysql://root:password@127.0.0.1/glance

Period in seconds after which SQLAlchemy should reestablish its connection

to the database.

#

MySQL uses a default wait_timeout of 8 hours, after which it will drop

idle connections. This can result in 'MySQL Gone Away' exceptions. If you

notice this, you can lower this value to ensure that SQLAlchemy reconnects

before MySQL can drop the connection.

sql_idle_timeout = 3600

[app:glance-scrubber] paste.app_factory = glance.store.scrubber:app_factory

2012-02-21 21:53:52 22358 INFO [glance.store.scrubber] Initializing scrubber with conf: {'registry_port': 9191, 'datadir': '/var/lib/glance/scrubber', 'cleanup': False, 'cleanup_time': 86400, 'registry_host': '0.0. 0.0'} 2012-02-21 21:53:52 22358 ERROR [glance.store.s3] Could not find s3_store_host in configuration options. 2012-02-21 21:53:52 22358 ERROR [glance.store.base] Failed to configure store correctly. Disabling add met hod. 2012-02-21 21:53:52 22358 ERROR [glance.store.swift] Could not find swift_store_auth_address in configurat ion options. 2012-02-21 21:53:52 22358 ERROR [glance.store.base] Failed to configure store correctly. Disabling add met hod. 2012-02-21 21:53:52 22358 INFO [glance.store.scrubber] Deleting 0 images

Thanks