Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Network problem of the new launched instances

Hi Guys,

I am having trouble with launching instances. The launch fails on networking task with status error. Here is the output (at nova-compute screen session) on launching instance :

2012-05-02 06:41:52 TRACE nova.rpc.amqp RemoteError: Remote error: QuantumNotFoundException (u'Quantum entity not found: %s', '{"QuantumError": {"message": "Unable to find a network with the specified identifier.", "type": "NetworkNotFound", "detail": "Network 5f227bba-eb3b-4dba-ad4c-b47c80aaffd7 could not be found"}}')

And with this error no tap device is created for the device.

Dan was saying that running a fresh stack.sh script might resolve the error, but error is persistent even after running stack.sh again.

I have just a single node setup in a VM that has eth0 on NAT (ip= 10.0.3.15) and eth1 is on host-only-network (ip=10.0.0.10).

The way I launch instances: 1) either using dashboard Or 2) Using : euca-run-instances ami-00000001 -k mykey-$tenant0 -t m1.tiny

my nova.conf:

[DEFAULT] verbose=True auth_strategy=keystone allow_resize_to_same_host=True root_helper=sudo /usr/local/bin/nova-rootwrap compute_scheduler_driver=nova.scheduler.filter_scheduler.FilterScheduler dhcpbridge_flagfile=/etc/nova/nova.conf fixed_range=10.0.0.0/24 s3_host=10.0.3.15 s3_port=3333 network_manager=nova.network.quantum.manager.QuantumManager quantum_connection_host=localhost quantum_connection_port=9696 osapi_compute_extension=nova.api.openstack.compute.contrib.standard_extensions my_ip=10.0.3.15 public_interface=br-int vlan_interface=eth0 flat_network_bridge=br-int flat_interface=eth1 sql_connection=mysql://root:nova@localhost/nova?charset=utf8 libvirt_type=qemu instance_name_template=instance-%08x novncproxy_base_url=http://10.0.3.15:6080/vnc_auto.html xvpvncproxy_base_url=http://10.0.3.15:6081/console vncserver_listen=127.0.0.1 vncserver_proxyclient_address=127.0.0.1 api_paste_config=/etc/nova/api-paste.ini image_service=nova.image.glance.GlanceImageService ec2_dmz_host=10.0.3.15 rabbit_host=localhost rabbit_password=nova glance_api_servers=10.0.3.15:9292 force_dhcp_release=True connection_type=libvirt libvirt_ovs_bridge=br-int

----------------From Ryu example config--------------------

use_deprecated-auth=true firewall_driver=quantum.plugins.ryu.nova.firewall.NopFirewallDriver libvirt_ovs_integration_bridge=br-int libvirt_vif_type=ethernet libvirt_vif_driver=quantum.plugins.ryu.nova.vif.LibvirtOpenVswitchOFPRyuDriver libvirt_ovs_ryu_api_host=127.0.0.1:8080 linuxnet_interface_driver=quantum.plugins.ryu.nova.linux_net.LinuxOVSRyuInterfaceDriver linuxnet_ovs_ryu_api_host=127.0.0.1:8080 quantum_use_dhcp=true

Any ideas ? speculations? I have been stuck with this issue for some time now. Any help will be much appreciated.

Thanks!