Ask Your Question

Revision history [back]

Instance fails to spawn when running nova boot on ubuntu server

Sorry but I'm new to OpenStack

When I attempt to run ...

localadmin@openstack:~/creds$ nova boot --flavor 2 --image 9c53e40c-6edf-46d9-961a-2a891224f95d --key_name mykey --security_group default cirros

I get...

+-------------------------------------+--------------------------------------+ | Property | Value | +-------------------------------------+--------------------------------------+ | OS-DCF:diskConfig | MANUAL | | OS-EXT-SRV-ATTR:host | None | | OS-EXT-SRV-ATTR:hypervisor_hostname | None | | OS-EXT-SRV-ATTR:instance_name | instance-00000006 | | OS-EXT-STS:power_state | 0 | | OS-EXT-STS:task_state | scheduling | | OS-EXT-STS:vm_state | building | | accessIPv4 | | | accessIPv6 | | | adminPass | vR5XB5A4ami8 | | config_drive | | | created | 2012-06-08T15:39:26Z | | flavor | m1.small | | hostId | | | id | 16ba0aea-5cfe-4cf8-a768-ca93e6d15738 | | image | cirros-0.3.0-x86_64 | | key_name | mykey | | metadata | {} | | name | cirros | | progress | 0 | | status | BUILD | | tenant_id | 3749921409ce4ef9b89fe51b88383f79 | | updated | 2012-06-08T15:39:27Z | | user_id | e7d3d8b5594c48f48e57d60e9814c3a7 | +-------------------------------------+--------------------------------------+

But when doing nova list I get the following...

+--------------------------------------+--------+--------+-----------------------+ | ID | Name | Status | Networks | +--------------------------------------+--------+--------+-----------------------+ | 16ba0aea-5cfe-4cf8-a768-ca93e6d15738 | cirros | ERROR | private=192.168.100.2 | +--------------------------------------+--------+--------+-----------------------+

And from the nova-compute log...

2012-06-08 10:39:34 TRACE nova.rpc.amqp File "/usr/lib/python2.7/dist-packages/libvirt.py", line 581, in createWithFlags 2012-06-08 10:39:34 TRACE nova.rpc.amqp if ret == -1: raise libvirtError ('virDomainCreateWithFlags() failed', dom=self) 2012-06-08 10:39:34 TRACE nova.rpc.amqp libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/12 2012-06-08 10:39:34 TRACE nova.rpc.amqp Could not access KVM kernel module: Permission denied 2012-06-08 10:39:34 TRACE nova.rpc.amqp failed to initialize KVM: Permission denied 2012-06-08 10:39:34 TRACE nova.rpc.amqp No accelerator found! 2012-06-08 10:39:34 TRACE nova.rpc.amqp 2012-06-08 10:39:34 TRACE nova.rpc.amqp

Could this be causing this problem?

Any help is appreciated greatly....