Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Quantum: When using OVS, virtual interfaces silently disappear or lose their IPs

Hello all,

I'm running an OpenStack setup here with Quantum+OVS. As I run all services on one node, I need use_namespaces=true in my configuration file. With that, I can set up Quantum & OpenvSwitch nicely, but as soon as I fire up a VM, all the interfaces created by Quantum and OpenVSwitch silently disappear:

35: qbr54d531d7-f3: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UP link/ether 8e:7d:9b:e9:6d:87 brd ff:ff:ff:ff:ff:ff inet6 fe80::3871:9ff:fef7:16f7/64 scope link valid_lft forever preferred_lft forever 36: qvo54d531d7-f3: <broadcast,multicast,promisc,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether ea:7f:8f:ca:f7:6c brd ff:ff:ff:ff:ff:ff inet6 fe80::e87f:8fff:feca:f76c/64 scope link valid_lft forever preferred_lft forever 37: qvb54d531d7-f3: <broadcast,multicast,promisc,up,lower_up> mtu 1500 qdisc pfifo_fast master qbr54d531d7-f3 state UP qlen 1000 link/ether 8e:7d:9b:e9:6d:87 brd ff:ff:ff:ff:ff:ff inet6 fe80::8c7d:9bff:fee9:6d87/64 scope link valid_lft forever preferred_lft forever 38: qbrc004d01b-cf: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UP link/ether a2:08:7e:7a:5e:47 brd ff:ff:ff:ff:ff:ff inet6 fe80::c072:a6ff:fea7:b450/64 scope link valid_lft forever preferred_lft forever 39: qvoc004d01b-cf: <broadcast,multicast,promisc,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether f6:28:36:fc:8a:c0 brd ff:ff:ff:ff:ff:ff inet6 fe80::f428:36ff:fefc:8ac0/64 scope link valid_lft forever preferred_lft forever 40: qvbc004d01b-cf: <broadcast,multicast,promisc,up,lower_up> mtu 1500 qdisc pfifo_fast master qbrc004d01b-cf state UP qlen 1000 link/ether a2:08:7e:7a:5e:47 brd ff:ff:ff:ff:ff:ff inet6 fe80::a008:7eff:fe7a:5e47/64 scope link valid_lft forever preferred_lft forever 41: vnet0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast master qbr54d531d7-f3 state UNKNOWN qlen 500 link/ether fe:16:3e:c4:70:a8 brd ff:ff:ff:ff:ff:ff inet6 fe80::fc16:3eff:fec4:70a8/64 scope link valid_lft forever preferred_lft forever 42: vnet1: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast master qbrc004d01b-cf state UNKNOWN qlen 500 link/ether fe:16:3e:8e:52:dc brd ff:ff:ff:ff:ff:ff inet6 fe80::fc16:3eff:fe8e:52dc/64 scope link valid_lft forever preferred_lft forever

With use_namespaces=False in my configuration, this doesn't happen.

My configuration mainly follows Emilien Macchi's howto; it's using GRE.

I hope anyone can help me on this one!

Best regards Martin G. Loschwitz