Ask Your Question

Revision history [back]

Unable to ping VM using OpenStack and Quantum(LinuxBride plugin) in a Single node set up

Unable to ping VM using OpenStack and Quantum(LinuxBride plugin) in a Single node set up

After booting a server an ip address is getting assigned and it is coming to 'ACTIVE' state. But, when I tried to ping, it displays the below error.

root@vmquantum157:~# ping 5.5.5.12 PING 5.5.5.12 (5.5.5.12) 56(84) bytes of data. From 10.233.53.157 icmp_seq=2 Destination Host Unreachable From 10.233.53.157 icmp_seq=3 Destination Host Unreachable From 10.233.53.157 icmp_seq=4 Destination Host Unreachable

-----nova-list----- root@vmquantum157:~# nova list +--------------------------------------+----------+--------+--------------------------+ | ID | Name | Status | Networks | +--------------------------------------+----------+--------+--------------------------+ | 0665543d-7033-4e27-bc7a-58ecb6824898 | tests | ACTIVE | public=5.5.5.12 | | c493759d-b442-4f8d-a9bc-794c4cba4e0c | testing9 | ACTIVE | public=9.9.8.2 | | f1d3af6a-af42-44f7-acbd-0c063fc21517 | test59 | ACTIVE | public=9.9.8.3, 5.5.5.14 | | fc736124-2457-467c-8f51-441b37184606 | tests2 | ACTIVE | public=5.5.5.13 | +--------------------------------------+----------+--------+--------------------------+

-----nova.conf----- --dhcpbridge_flagfile=/etc/nova/nova.conf --dhcpbridge=/usr/local/bin/nova-dhcpbridge --logdir=/var/log/nova --state_path=/var/lib/nova --lock_path=/var/lock/nova --force_dhcp_release --iscsi_helper=tgtadm --libvirt_use_virtio_for_bridges --connection_type=libvirt --root_helper=sudo nova-rootwrap --verbose

--flagfile=/etc/nova/nova-compute.conf

--use_deprecated_auth --libvirt_type=qemu --sql_connection=mysql://nova:nova@127.0.0.1/nova --vlan_interface=eth0 --image_service=nova.image.glance.GlanceImageService --glance_api_servers=127.0.0.1:9292 --rabbit_host=127.0.0.1 --osapi_host=127.0.0.1 --scheduler_default_filters=AllHostsFilter

--network_manager=nova.network.quantum.manager.QuantumManager --libvirt_vif_type=ethernet --libvirt_vif_driver=nova.virt.libvirt.vif.QuantumLinuxBridgeVIFDriver --linuxnet_interface_driver=nova.network.linux_net.QuantumLinuxBridgeInterfaceDriver --quantum_use_dhcp=true

-----quantum.conf----- [DEFAULT]

Show more verbose log output (sets INFO log level output)

verbose = True

Show debugging output in logs (sets DEBUG log level output)

debug = True

Address to bind the API server

bind_host = 0.0.0.0

Port the bind the API server to

bind_port = 9696

Path to the extensions. Note that this can be a colon-separated list of

paths. For example:

api_extensions_path = extensions:/path/to/more/extensions:/even/more/extensions

The __path__ of quantum.extensions is appended to this, so if your

extensions are in there you don't need to specify them here

api_extensions_path =

[composite:quantum] use = egg:Paste#urlmap /: quantumversions /v1.0: quantumapi_v1_0 /v1.1: quantumapi_v1_1

[pipeline:quantumapi_v1_0]

By default, authentication is disabled.

To enable Keystone integration uncomment the

following line and comment the next one

pipeline = extensions quantumapiapp_v1_0

pipeline = authN extensions quantumapiapp_v1_0

[pipeline:quantumapi_v1_1]

By default, authentication is disabled.

To enable Keystone integration uncomment the

following line and comment the next one

pipeline = extensions quantumapiapp_v1_1

pipeline = authN extensions quantumapiapp_v1_1

[filter:authN] paste.filter_factory = keystone.middleware.quantum_auth_token:filter_factory auth_host = 127.0.0.1 auth_port = 35357 auth_protocol = http auth_version = 2.0 auth_admin_user = admin auth_admin_password = secrete

auth_admin_token = <token-value>

[filter:extensions] paste.filter_factory = quantum.extensions.extensions:plugin_aware_extension_middleware_factory

[app:quantumversions] paste.app_factory = quantum.api.versions:Versions.factory

[app:quantumapiapp_v1_0] paste.app_factory = quantum.api:APIRouterV10.factory

[app:quantumapiapp_v1_1] paste.app_factory = quantum.api:APIRouterV11.factory

I have installed and configure quantum with nova using "Quantum Admin quide".

Please suggest what could be the issue or cause.

Thanks, Shanthkumar Khandre