Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

swift error logs and error: [Errno 111] ECONNREFUSED

Hello ,I was wondering if any one could help me with this problem .I have installed a multimode installation based on the steps provided by http://swift.openstack.org/howto_installmultinode.html. The only difference that I made to the installation was that all my storage nodes have single hard drives and so I have partition the hard drives to ext3 for ubuntu and xfs for swift. The xfs partion is mounted at /svr/node/sdb1 on all the node.

every time I run swift -A https://<proxy_ip>:8080/auth/v1.0 -U system:root -K testpass stat

i get [Errno 111] ECONNREFUSED and when I run swift -A https://<proxy_ip>:8080/auth/v1.0 -U system:root -K <mypass> upload myfiles openSUSE-11.4-DVD-i586.iso where <proxy_ip> is the proxy ip address and <my_pass> is the password I get this error.

File "/usr/bin/swift", line 949, in run self.func(item, self.args, *self.kwargs) File "/usr/bin/swift", line 1639, in _object_job headers = conn.head_object(container, obj) File "/usr/bin/swift", line 861, in head_object return self._retry(None, head_object, container, obj) File "/usr/bin/swift", line 792, in _retry rv = func(self.url, self.token, args, *kwargs) File "/usr/bin/swift", line 573, in head_object conn.request('HEAD', path, '', {'X-Auth-Token': token}) File "/usr/lib/python2.7/httplib.py", line 955, in request self._send_request(method, url, body, headers) File "/usr/lib/python2.7/httplib.py", line 989, in _send_request self.endheaders(body) File "/usr/lib/python2.7/httplib.py", line 951, in endheaders self._send_output(message_body) File "/usr/lib/python2.7/httplib.py", line 811, in _send_output self.send(msg) File "/usr/lib/python2.7/httplib.py", line 773, in send self.connect() File "/usr/lib/python2.7/httplib.py", line 1154, in connect self.timeout, self.source_address) File "/usr/lib/pymodules/python2.7/eventlet/green/socket.py", line 59, in create_connection raise error, msg error: [Errno 111] ECONNREFUSED I also can not find the log files for swift.

I also don't know where the log files are.

my proxy-server.conf file is as follows

[DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key bind_port = 8080 workers = 8 user = swift log_facility = LOG_LOCAL1

[pipeline:main] pipeline = healthcheck cache tempauth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true

[filter:tempauth] use = egg:swift#tempauth user_system_root = testpass .admin https://<proxy_ip>/v1/AUTH_system

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache memcache_servers = <proxy_ip>:11211

I also get this when I enter the code below curl -k -v -H 'X-Auth-Token: AUTH_****' https:// <proxy_ip>:8080/v1/AUTH_system

  • About to connect() to <proxy_ip> port 8080 (#0)
  • Trying 1 connected
  • Connected to <proxy_ip> ( <proxy_ip>) port 8080 (#0)
  • successfully set certificate verify locations:
  • CAfile: none CApath: /etc/ssl/certs
  • SSLv3, TLS handshake, Client hello (1):
  • SSLv3, TLS handshake, Server hello (2):
  • SSLv3, TLS handshake, CERT (11):
  • SSLv3, TLS handshake, Server finished (14):
  • SSLv3, TLS handshake, Client key exchange (16):
  • SSLv3, TLS change cipher, Client hello (1):
  • SSLv3, TLS handshake, Finished (20):
  • SSLv3, TLS change cipher, Client hello (1):
  • SSLv3, TLS handshake, Finished (20):
  • SSL connection using AES256-SHA
  • Server certificate:
  • subject: C=SA; ST=gautang; L=johannesburg; O=**; OU=cns; CN=christopher; emailAddress=<my email="">
  • start date: 2011-09-23 07:41:45 GMT
  • expire date: 2011-10-23 07:41:45 GMT
  • common name: christopher (does not match ' <proxy_ip>')
  • issuer: C=SA; ST=gautang; L=johannesburg; O=**; OU=cns; CN=christopher; emailAddress=<>my email
  • SSL certificate verify result: self signed certificate (18), continuing anyway.

    GET /v1/AUTH_system HTTP/1.1 User-Agent: curl/7.21.3 (x86_64-pc-linux-gnu) libcurl/7.21.3 OpenSSL/0.9.8o zlib/1.2.3.4 libidn/1.18 Host: <proxy_ip>:8080 Accept: / X-Auth-Token: AUTH_********

    < HTTP/1.1 401 Unauthorized < Content-Length: 358 < Content-Type: text/html; charset=UTF-8 < Date: Wed, 28 Sep 2011 09:27:06 GMT < <html> <head> <title>401 Unauthorized</title> </head> <body>

    401 Unauthorized

    This server could not verify that you are authorized to access the document you requested. Either you supplied the wrong credentials (e.g., bad password), or your browser does not understand how to supply the credentials required.

    </body>

  • Connection #0 to host <proxy_ip> left intact
  • Closing connection #0
  • SSLv3, TLS alert, Client hello (1):