Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

SWauth issues in OpenStack Swift

I have configured my Openstack swift for multi node installation. it was working fine. I wanted to add SWAUTH on top of it to use S3 APIs.

I have installed swauth from github.

  1. https://github.com/gholt/swauth.git.
  2. Ran command sudo python setup.py install.
  3. Made changes to my proxy-server.conf. It looks like this now.

[DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key bind_port = 8080 workers = 8 user = swift

[pipeline:main] pipeline = catch_errors cache swauth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true

[filter:swauth] use:egg:swauth#swauth set log_name = swauth super_admin_key = swauthkey default_swift_cluster = local#https://128.111.55.19:8080/v1

[filter:cache] use = egg:swift#memcache memcache_servers = 128.111.55.19:11211

[filter:catch_errors] use = egg:swift#catch_errors

  1. After this i run the commnad $swift-init proxy reload. It works fine.
  2. I run the command swauth-prep -K swauthkey.

The proxy server is stuck no response from it , no error nothing just stuck.

Please help me out as to wht could be the prob.