Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Invalid input for operation: GRE networks are not enabled.

hi I am trying to create a with GRE provider network using quantum (Folsom release on Ubuntu 12.04 ) and i have a problem but i think no mestake on my ovs_quantum_plugin.ini file in the network node :

[DATABASE] sql_connection = mysql://quantum:password@10.38.97.1:3306/quantum reconnect_interval = 2

[OVS] tenant_network_type = gre tunnel_id_ranges = 1:1000 enable_tunneling = True integration_bridge = br-int tunnel_bridge = br-tun local_ip = 10.10.10.1

[AGENT] polling_interval = 2 root_helper = sudo /usr/bin/quantum-rootwrap /etc/quantum/rootwrap.conf

error return by quantum-network.sh : root@openstack-networker:~# ./quantum.sh Invalid input for operation: GRE networks are not enabled. usage: quantum subnet-create [-h] [-f {shell,table}] [-c COLUMN] [--variable VARIABLE] [--prefix PREFIX] [--request-format {json,xml}] [--tenant-id tenant-id] [--name NAME] [--ip-version {4,6}] [--gateway gateway] [--no-gateway] [--allocation-pool ALLOCATION_POOL] network cidr ...

in the controler node : the quantum server log file : 2013-04-02 17:25:33 ERROR [quantum.api.v2.resource] create failed Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/quantum/api/v2/resource.py", line 96, in resource result = method(request=request, *args) File "/usr/lib/python2.7/dist-packages/quantum/api/v2/base.py", line 335, in create obj = obj_creator(request.context, *kwargs) File "/usr/lib/python2.7/dist-packages/quantum/plugins/openvswitch/ovs_quantum_plugin.py", line 402, in create_network network['network']) File "/usr/lib/python2.7/dist-packages/quantum/plugins/openvswitch/ovs_quantum_plugin.py", line 339, in _process_provider_create raise q_exc.InvalidInput(error_message=msg) InvalidInput: Invalid input for operation: GRE networks are not enabled. 2013-04-02 17:25:33 DEBUG [eventlet.wsgi.server] 10.38.97.2 - - [02/Apr/2013 17:25:33] "POST /v2.0/networks.json HTTP/1.1" 400 195 0.066017 2013-04-02 17:25:33 DEBUG [keystone.middleware.auth_token] Authenticating user token

it my second install and i not understand why that not WORK.

HELP me please.