Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

cinder volume creation (status : creating)

Hi, I am trying openstack manual installation on a single node with the help of the manual http://docs.openstack.org/trunk/openstack-compute/install/apt/content/ap_installingfolsomubuntuprecise.html

I got stucked in creating volumes in cinder configuration

When i execute the command $ cinder create --display_name test 1

it gives,

+---------------------+--------------------------------------+ | Property | Value | +---------------------+--------------------------------------+ | attachments | [] | | availability_zone | nova | | created_at | 2012-11-05T11:59:59.548149 | | display_description | None | | display_name | test | | id | 8802e55c-29a6-4087-9730-286cfbd3fdb3 | | metadata | {} | | size | 1 | | snapshot_id | None | | status | creating | | volume_type | None | +---------------------+--------------------------------------+

And the status of the volume remains in creating

When i execute the command $ cinder list

it gives +--------------------------------------+----------+--------------+------+-------------+-------------+ | ID | Status | Display Name | Size | Volume Type | Attached to | +--------------------------------------+----------+--------------+------+-------------+-------------+ | 8802e55c-29a6-4087-9730-286cfbd3fdb3 | creating | test | 1 | None | | +--------------------------------------+----------+--------------+------+-------------+-------------+

the status of the volume should be 'Available', But in my case it still remains in 'creating' state

and my cinder.conf looks like, [DEFAULT] rootwrap_config = /etc/cinder/rootwrap.conf sql_connection = mysql://cinder:openstack@.../cinder api_paste_confg = /etc/cinder/api-paste.ini

iscsi_helper = ietadm volume_name_template = volume-%s volume_group = cinder-volumes verbose = True auth_strategy = keystone state_path = /var/lib/cinder volumes_dir = /var/lib/cinder/volumes

osapi_volume_listen_port=5900

and the part of my api-paste.ini file looks like, [filter:authtoken] paste.filter_factory = keystone.middleware.auth_token:filter_factory service_protocol = http service_host = x.y.z.a service_port = 5000 auth_host = x.y.z.a auth_port = 35357 auth_protocol = http admin_tenant_name = service admin_user = cinder admin_password = openstack

Please help me fix it..

Its urgent i need..

regards Rajesh kannan