Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

instance cannot attach volume, although compute-host establishes valid session?

I am using grizzly stable from cloud archive, and currently have a problem with cinder volumes not being mounted within instances. I am using tgtadm as the iscsi helper, which is set on cinder, nova controller, and nova compute hosts. The iscsi targets seem to be connected within the compute-host, as seen by iscsiadm. Is there a particular config option or setting that might cause this behavior? Or is there a way I can further investigate what the problem might be?

This appears to be the only warning I receive on the compute host:

/var/log/nova/nova-compute.log 2013-05-20 20:32:19.882 AUDIT nova.compute.manager [req-fbb43291-5251-4514-b977-8ce3cbbdfaf1 a0c94431c8f942b9a8b67d7cab818364 e953f96c7b2a4598ae0b507b936970e2] [instance: 8f530429-7a86-49e2-b5d8-505a75d7669d] Attaching volume e48ecedb-8580-4262-8488-97f8d7c116ee to /dev/vdc 2013-05-20 20:32:22.021 WARNING nova.virt.libvirt.volume [req-fbb43291-5251-4514-b977-8ce3cbbdfaf1 a0c94431c8f942b9a8b67d7cab818364 e953f96c7b2a4598ae0b507b936970e2] ISCSI volume not yet found at: vdc. Will rescan & retry. Try number: 0

From the /var/log/syslog, the compute host seems to have mounted it correctly: May 20 20:32:20 os-compute04 kernel: [24493.934883] scsi11 : iSCSI Initiator over TCP/IP May 20 20:32:21 os-compute04 kernel: [24494.945033] scsi 11:0:0:0: Direct-Access IET VIRTUAL-DISK 0 PQ: 0 ANSI: 4 May 20 20:32:21 os-compute04 kernel: [24494.945495] sd 11:0:0:0: Attached scsi generic sg3 type 0 May 20 20:32:21 os-compute04 kernel: [24494.948319] sd 11:0:0:0: [sdc] 62914560 512-byte logical blocks: (32.2 GB/30.0 GiB) May 20 20:32:21 os-compute04 kernel: [24494.949132] sd 11:0:0:0: [sdc] Write Protect is off May 20 20:32:21 os-compute04 kernel: [24494.949139] sd 11:0:0:0: [sdc] Mode Sense: 77 00 00 08 May 20 20:32:21 os-compute04 kernel: [24494.950632] sd 11:0:0:0: [sdc] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA May 20 20:32:21 os-compute04 kernel: [24494.957304] sdc: unknown partition table May 20 20:32:21 os-compute04 kernel: [24494.960315] sd 11:0:0:0: [sdc] Attached SCSI disk May 20 20:32:21 os-compute04 dnsmasq-dhcp[2716]: DHCP packet received on br-ex which has no address May 20 20:32:22 os-compute04 iscsid: connection1:0 is operational now

When I perform the "iscsiadm -m session -o show", I get this session, which is the correct volume tcp: [1] 10.0.0.137:3260,1 iqn.2010-10.org.openstack:volume-e48ecedb-8580-4262-8488-97f8d7c116ee

However, when I login to the VM, the device is not created (or any new device for that matter). Thanks in advance for any assistance.