Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to setup initial networking (Lan/Internet) after fresh installation

Hi all, I just successfully installed openstack on my office computer. I follow all-in-one packstack and able to access dashboard. After installation this is my pc network interface config:- My office IT provide me static IP of 192.168.100.15 (default network is by DHCP)

br-ex: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 172.24.4.1  netmask 255.255.255.0  broadcast 0.0.0.0
    inet6 fe80::b81a:34ff:fe0f:c94a  prefixlen 64  scopeid 0x20<link>
    ether ba:1a:34:0f:c9:4a  txqueuelen 1000  (Ethernet)
    RX packets 11  bytes 664 (664.0 B)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 8  bytes 656 (656.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 192.168.100.15  netmask 255.255.255.0  broadcast 192.168.100.255
    inet6 fe54::231:bfc:fe11:cf79  prefixlen 64  scopeid 0x20<link>
    ether 00:21:1c:31:cc:19  txqueuelen 1000  (Ethernet)
    RX packets 270483  bytes 336811530 (321.2 MiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 158065  bytes 14318385 (13.6 MiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

openstack neutron list
```
private - 10.0.0.0/24
public - 172.24.4.0/24
From dashboard i can see public network topology. 

```

To access my office lan and internet have to go thru network 192.168.100.15/24 which over eth1. So how to set so that openstack can also access Lan/internet. Seems like I need to create new subnet and router. Appreciate someone to guide me the right way to accomplish it. Thank you for your help and attention. Thank you

How to setup initial networking (Lan/Internet) after fresh installation

Hi all, I just successfully installed openstack on my office computer. I follow all-in-one packstack and able to access dashboard. After installation this is my pc network interface config:- My office IT provide me static IP of 192.168.100.15 (default network is by DHCP)DHCP). Interface br-ex and the IP 172.24.4.0/24 is automatic created after successfully deployed openstack.

br-ex: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 172.24.4.1  netmask 255.255.255.0  broadcast 0.0.0.0
    inet6 fe80::b81a:34ff:fe0f:c94a  prefixlen 64  scopeid 0x20<link>
    ether ba:1a:34:0f:c9:4a  txqueuelen 1000  (Ethernet)
    RX packets 11  bytes 664 (664.0 B)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 8  bytes 656 (656.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 192.168.100.15  netmask 255.255.255.0  broadcast 192.168.100.255
    inet6 fe54::231:bfc:fe11:cf79  prefixlen 64  scopeid 0x20<link>
    ether 00:21:1c:31:cc:19  txqueuelen 1000  (Ethernet)
    RX packets 270483  bytes 336811530 (321.2 MiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 158065  bytes 14318385 (13.6 MiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

openstack neutron list
```
private - 10.0.0.0/24
public - 172.24.4.0/24
From dashboard i can see public network topology. 

```

To access my office lan and internet have to go thru network 192.168.100.15/24 which over eth1. So how to set so that openstack can also access Lan/internet. Seems like I need to create new subnet and router. Appreciate someone to guide me the right way to accomplish it. Thank you for your help and attention. Thank you