Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Ansible Kolla - Unable to access external networks gateway

Good morning! I have tried to do a fresh install of openstack-Kolla with the openstack-train release. I came across a few errors:

  1. Errors importing queue , when running the openstack client. queue is named with lower case in python 3. Fix was to change affected imports to import Queue. Problem solved
  2. After setting everything up including the demo network, router shows interfaces for private network and for public network as down I can see errors in /var/log/kolla/neutron/neutron-l3-agent.log: 2020-05-23 00:22:12.862 17 ERROR neutron.agent.l3.agent [-] Failed to process compatible router: 19b4e5ca-73f7-4c72-84be-5f4c6bc3060f: NetlinkError: (101, 'Network is unreachable')2020-05-23 00:22:12.862 17 ERROR neutron.agent.l3.agent Traceback (most recent call last):
  3. On the startup of neutron-server container I saw the following error: ++ /usr/bin/update-alternatives --query iptables/usr/local/bin/kolla_extend_start: line 11: /usr/bin/update-alternatives: No such file or directory++ . /usr/local/bin/kolla_neutron_extend_start For reference I setup my globals.yml in the following way: network_interface: "aggi" keepalived_virtual_router_id: “101” kolla_internal_vip_address: "10.143.3.148" kolla_external_vip_address: "10.143.3.149” neutron_external_interface: "agge" kolla_install_type: "source"

aggi is my private network interface and agge is my external network interface. Only Agge has public internet. I have modified BR-EX bridge to have a static ip address in order to ensure that I still have internet access in the server It was a all-in-one deployment

I can't get internet access to work. No matter what I do the network interfaces of the router I created show status DOWN.