Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

instance snapshot fails to complete

I have several instances on one compute node. I can successfully "Create Snapshot" for all but one instance. The instance that fails to complete is much larger than the others, but at 99GB, there should still be plenty of disk space to create the temporary snapshot file. The temp snapshot file never gets bigger than 176KB.

The compute node is using a local NVMe drive for instance storage.

I have watched the local nova log and the glance log, but there are no errors. The process never gets past

2020-02-27 14:39:16.166 31638 INFO nova.virt.libvirt.driver [req-45708b6c-d892-4a87-ab82-2e68bfb8deb7 d63af2d376de4f68af54f1afdea41f8c d82194f0fc3a440faf5e73aae5337b61 - default default] [instance: 4a4fed08-ab95-4291-9841-c5a00a8cd7f5] Beginning cold snapshot process

I get the same result whether I run this via the Horizon interface or via the CLI. Is there anywhere else I can look to see why this snapshot is not processing? I am running OpenStack Stein (RDO Packstack with 6 compute nodes)