Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

cannot remove host from aggregate

This is on Steain. I had two aggregates and deleted one; now I can't delete the other, because I can't remove the host from it:

stack@devstack:~/devstack$ openstack aggregate list
+----+------+-------------------+
| ID | Name | Availability Zone |
+----+------+-------------------+
|  2 | agg2 | AZ2               |
+----+------+-------------------+
stack@devstack:~/devstack$ openstack aggregate show agg2
+-------------------+----------------------------+
| Field             | Value                      |
+-------------------+----------------------------+
| availability_zone | AZ2                        |
| created_at        | 2019-12-19T17:11:17.000000 |
| deleted           | False                      |
| deleted_at        | None                       |
| hosts             | [u'compute-01']            |
| id                | 2                          |
| name              | agg2                       |
| properties        |                            |
| updated_at        | None                       |
+-------------------+----------------------------+
stack@devstack:~/devstack$ openstack aggregate remove host agg2 compute-01
Cannot remove host compute-01 in aggregate 2 (HTTP 404) (Request-ID: req-0c968aa5-d16a-41d7-ada7-46e165d17905)
stack@devstack:~/devstack$ openstack compute service list
+----+------------------+------------+----------+---------+-------+----------------------------+
| ID | Binary           | Host       | Zone     | Status  | State | Updated At                 |
+----+------------------+------------+----------+---------+-------+----------------------------+
|  2 | nova-scheduler   | devstack   | internal | enabled | up    | 2020-01-06T17:36:05.000000 |
|  4 | nova-consoleauth | devstack   | internal | enabled | up    | 2020-01-06T17:36:14.000000 |
|  6 | nova-conductor   | devstack   | internal | enabled | up    | 2020-01-06T17:36:09.000000 |
|  1 | nova-conductor   | devstack   | internal | enabled | up    | 2020-01-06T17:36:08.000000 |
|  2 | nova-compute     | devstack   | nova     | enabled | up    | 2020-01-06T17:36:07.000000 |
|  3 | nova-compute     | compute-01 | AZ2      | enabled | up    | 2020-01-06T17:36:09.000000 |
+----+------------------+------------+----------+---------+-------+----------------------------+

"openstack server list" returns empty, so I know the instance that was running on compute-01 is no more. Searching on this problem returned some older issues that were resolve using direct database queries, which I am not afraid of, but it seems this should be simpler. Any help would be appreciated.

cannot remove host from aggregate

This is on Steain. Stein. I had two aggregates and deleted one; now I can't delete the other, because I can't remove the host from it:

stack@devstack:~/devstack$ openstack aggregate list
+----+------+-------------------+
| ID | Name | Availability Zone |
+----+------+-------------------+
|  2 | agg2 | AZ2               |
+----+------+-------------------+
stack@devstack:~/devstack$ openstack aggregate show agg2
+-------------------+----------------------------+
| Field             | Value                      |
+-------------------+----------------------------+
| availability_zone | AZ2                        |
| created_at        | 2019-12-19T17:11:17.000000 |
| deleted           | False                      |
| deleted_at        | None                       |
| hosts             | [u'compute-01']            |
| id                | 2                          |
| name              | agg2                       |
| properties        |                            |
| updated_at        | None                       |
+-------------------+----------------------------+
stack@devstack:~/devstack$ openstack aggregate remove host agg2 compute-01
Cannot remove host compute-01 in aggregate 2 (HTTP 404) (Request-ID: req-0c968aa5-d16a-41d7-ada7-46e165d17905)
stack@devstack:~/devstack$ openstack compute service list
+----+------------------+------------+----------+---------+-------+----------------------------+
| ID | Binary           | Host       | Zone     | Status  | State | Updated At                 |
+----+------------------+------------+----------+---------+-------+----------------------------+
|  2 | nova-scheduler   | devstack   | internal | enabled | up    | 2020-01-06T17:36:05.000000 |
|  4 | nova-consoleauth | devstack   | internal | enabled | up    | 2020-01-06T17:36:14.000000 |
|  6 | nova-conductor   | devstack   | internal | enabled | up    | 2020-01-06T17:36:09.000000 |
|  1 | nova-conductor   | devstack   | internal | enabled | up    | 2020-01-06T17:36:08.000000 |
|  2 | nova-compute     | devstack   | nova     | enabled | up    | 2020-01-06T17:36:07.000000 |
|  3 | nova-compute     | compute-01 | AZ2      | enabled | up    | 2020-01-06T17:36:09.000000 |
+----+------------------+------------+----------+---------+-------+----------------------------+

"openstack server list" returns empty, so I know the instance that was running on compute-01 is no more. Searching on this problem returned some older issues that were resolve using direct database queries, which I am not afraid of, but it seems this should be simpler. Any help would be appreciated.