Ask Your Question

Revision history [back]

Recovering data from an old cinderfs volume set

Hello!

I have a problem that I could really use help with. I got a set of servers away in Germany and they were used to set up an OpenStack environment, the system is years old and as we do not care much for the servers themselves, we really could use the data left on the storage machine there.

The problem is, the data is in volumes and I can't simply ssh in and get what I need. Every machine in there is separated too and something went crashing down in the Openstack system and the login ceased working.

Since I am fairly new with OpenStack and this system was installed by someone else in his/her own configuration, I could really use help getting the data.

The storage server is on Debian 8.11 (was on 7.9 before I did a little upgrade on it), I have tried reinstalling the identity system but I can't configure it well because there is not really a guide that works on an old Debian.. (I can't use fernet related commands either as they simply don't exist).

What I've tried: Took the head machine that controls the thing, repair the identity with no success, reinstalled the openstack set there as I did not care much for the given machine, that got openstack working but I can't seem to connect the storage to that machine. (Or don't know how to since the storage is preconfigured)

I've tried installing OpenStack web dashboard onto the storage itself now, but there still is the problem that I can't log with anything, even the install it self says invalid credentials at the end "Invalid OpenStack Identity credentials.".

I simply need the files from the storage but they are coded in a volume that I have no access to.. What could I do?

Thanks in advance!