Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Senlin unsupported version

I think I got Senlin installed by throwing away the entire system and starting from scratch with DevStack. However, when I ran the "Verify" step (at the Senlin installation guide https://docs.openstack.org/senlin/latest/install/verify.html, I got this:

$ openstack cluster build info
Failed to contact the endpoint at http://192.168.56.3:8778 for discovery. Fallback to using that endpoint as the base url.
Failed to contact the endpoint at http://192.168.56.3:8778 for discovery. Fallback to using that endpoint as the base url.
The clustering service for :RegionOne exists but does not have any supported versions.

The command "openstack endpoint list --service senlin" returns three enpoints with that URL, for public, admin, and internal interfaces.

I looked in stack.sh.log and near the end I see this:

2019-10-23 21:06:39.551 | [Call Trace]
2019-10-23 21:06:39.552 | ./stack.sh:1293:start_glance
2019-10-23 21:06:39.554 | /opt/stack/devstack/lib/glance:335:die
2019-10-23 21:06:39.557 | [ERROR] /opt/stack/devstack/lib/glance:335 g-api did not start

Beyond that, I can't think of anything diagnostic to add. So my questions are:

  1. Is this a sign of an installation error?
  2. If the error is in Glance, where do I start on the diagnosis?

As always, any help is appreciated.