Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Unable to upload image to Glance

Attempting install using the RedHat Install & Deploy Guide, and am having an issue uploading the test image. When I run the image-create command, I get the following:

NotAuthenticated: 401 Unauthorized This server could not verify that you are authorized to access the document you requested. Either you supplied the wrong credentials (e.g., bad password), or your browser does not understand how to supply the credentials required. Authentication required (HTTP 500)

I've tried every userid & password combination that I can think of. I've tried different values in the glance-api.conf and glance-registry.conf files. I've even used the user-password-update directive to change the passwords for the glance userid.

There is a warning in the keystone.log file that authentication failed with my management IP address. I don't know if it matters, but my public IP on the services is set to a true public IP, not my internal IP as suggested in the Install Guide. Also, the following message is in the glance/api.log:

2013-05-15 17:46:22.932 INFO glance.registry.client [949202b5-9417-4cf8-a275-7a21fc6bc3c4 None None] Registry client request POST /images raised NotAuthenticated

There is nothing evident in the glance/registry.log file.

My environment is CentOS 6.4, dual Xeon 2.66 GHz processors, 16 GB RAM, with a fresh minimal install of CentOS.

Thanks in advance for any assistance.

Unable How do I solve error NotAuthenticated when trying to upload image to Glance

Attempting install using the RedHat Install & Deploy Guide, and am having an issue uploading the test image. When I run the image-create command, I get the following:

 NotAuthenticated: 401 Unauthorized
 Unauthorized 
 This server could not verify that you are authorized to access the document you requested. Either you supplied the wrong credentials (e.g., bad password), or your browser does not understand how to supply the credentials required.
  Authentication required
  (HTTP 500)

500)

I've tried every userid & password combination that I can think of. I've tried different values in the glance-api.conf and glance-registry.conf files. I've even used the user-password-update directive to change the passwords for the glance userid.

There is a warning in the keystone.log file that authentication failed with my management IP address. I don't know if it matters, but my public IP on the services is set to a true public IP, not my internal IP as suggested in the Install Guide. Also, the following message is in the glance/api.log:

 2013-05-15 17:46:22.932 INFO glance.registry.client [949202b5-9417-4cf8-a275-7a21fc6bc3c4 None None] Registry client request POST /images raised NotAuthenticated

NotAuthenticated

There is nothing evident in the glance/registry.log file.

My environment is CentOS 6.4, dual Xeon 2.66 GHz processors, 16 GB RAM, with a fresh minimal install of CentOS.

Thanks in advance for any assistance.