Revision history [back]

click to hide/show revision 1
initial version

Why is it that CirrOS instances connect, but others don't?

Hello everyone, I am new to OpenStack and have been learning the ropes (rather slowly). I have spent the past week trying to troubleshoot why my instances aren't establishing a connection to the network I have created. I have a minimal 2 node architecture and I was successfully able to establish connection between two CirrOS images I created. The two CirrOS images get assigned an IP and establish connection, however everything else doesn't.

I had installed the proper VirtIO drivers and was able to get them running locally on my Virtual Machine Manager where I run my 2 nodes. I thought maybe it was because I had not configured a security group at all. After configuring the security group to allow traffic for ICMP and other TCP/UDP protocols such as DHCP/DNS/HTTP/etc, I am still not able to establish a connection with images that I create whether its CentOS7 or Windows XP/7 (with cloudbase-init). I have tried many different combinations of starting instances with/without cloudbase and/or using sysprep.

No matter which guide I follow to create and upload an image to OpenStack, I can never seem to get an instance fully up and running with network connectivity. With so many people successful at creating images/uploading images/running instances, I must be missing something fundamental about OpenStack image creation and/or network configuration. Whether it be that the instances are run extremely slow or not, I still can't get connectivity on anything other than a CirrOS instance.

Does anybody have any advice? I doubt anybody has a fix or outright solution for me. Perhaps someone could point me in the direction of some cohesive guides/turorials. Thanks for any help, and I apologize for the long-winded explanation.