Revision history [back]

click to hide/show revision 1
initial version

No credentials specified for placement API in nova.conf

Hello, I was following these instructions on setting up Nova:

https://docs.openstack.org/nova/latest/install/verify.html

When I run:

nova-status upgrade check

It says:

+-------------------------------------------------------------------+ | Upgrade Check Results | +-------------------------------------------------------------------+ | Check: Cells v2 | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Placement API | | Result: Failure | | Details: No credentials specified for placement API in nova.conf. | +-------------------------------------------------------------------+ | Check: Ironic Flavor Migration | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Request Spec Migration | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Console Auths | | Result: Success | | Details: None | +-------------------------------------------------------------------+

In nova.conf on both the controller and the compute node I have [placement] configured. Does anyone know WHAT EXACTLY that error is telling me to do? this has been driving me a bit crazy.

Details: No credentials specified for placement API in nova.conf.

thanks

No credentials specified for placement API in nova.conf

Hello, I was following these instructions on setting up Nova:

https://docs.openstack.org/nova/latest/install/verify.html

When I run:

nova-status upgrade check

It says:

+-------------------------------------------------------------------+ | Upgrade Check Results | +-------------------------------------------------------------------+ | Check: Cells v2 | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Placement API | | Result: Failure | | Details: No credentials specified for placement API in nova.conf. | +-------------------------------------------------------------------+ | Check: Ironic Flavor Migration | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Request Spec Migration | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Console Auths | | Result: Success | | Details: None | +-------------------------------------------------------------------+

In nova.conf on both the controller and the compute node I have [placement] configured. Does anyone know WHAT EXACTLY that error is telling me to do? this has been driving me a bit crazy.

Details: No credentials specified for placement API in nova.conf.

thanks

Update:

Is that message talking about the configuration on the controller node or the compute node?

Also in /etc/nova/nova.conf on the controller node I have:

[placement]
os_region_name = RegionOne
project_domain_name = Default
project_name = service
user_domain_name = Default
password = removedbutdoesntmatteranyway
username = placement
auth_url = http://controller:5000/v3
auth_type = password

In /etc/placement/placement.conf on the controller node I have:

auth_strategy = keystone

[keystone_authtoken]
auth_url = http://controller:5000/v3
memcached_servers = controller:11211
auth_type = password
project_domain_name = Default
user_domain_name = Default
project_name = service
username = placement
password = removedbutdoesntmatteranyway

anyone know what else I can check or look at???