Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

--os-compute-api-version 2.11 or later is required

When i run

openstack compute service set --up compute nova-compute

i get following output:

--os-compute-api-version 2.11 or later is required

openstack compute service list outputs:-

+----+----------------+------------+----------+---------+-------+----------------------------+
| ID | Binary         | Host       | Zone     | Status  | State | Updated At                 |
+----+----------------+------------+----------+---------+-------+----------------------------+
|  1 | nova-scheduler | controller | internal | enabled | up    | 2019-05-14T10:34:47.000000 |
|  7 | nova-conductor | controller | internal | enabled | up    | 2019-05-14T10:34:44.000000 |
| 17 | nova-compute   | compute    | nova     | enabled | down  | 2019-05-14T07:56:44.000000 |
+----+----------------+------------+----------+---------+-------+----------------------------+

when i try to restart nova-compute using

systemctl start openstack-nova-compute.service i got output:-

Failed to start openstack-nova-compute.service: Unit not found.

So i tried to make state up through the command

openstack compute service set --up compute nova-compute

but got the above output please help me.