Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Software Deployment in Heat: Problem with os-collect-config

HI all, I have a problem with the coe cluster deploy k8s creation. On the master node on k8s i have this error:

Authorization failed: Unable to establish connection to http://172.24.xx.xxx:5000/v3/auth/tokens Mar 21 13:47:11 k8s-gdbdfoalflcp-master-0 runc[2256]: Source [heat] Unavailable. Mar 21 13:47:11 k8s-gdbdfoalflcp-master-0 runc[2256]: /var/lib/os-collect-config/local-data not found. Skipping

Seems that the master node want to connect the internal url reported http://172.24.xx.xxx:5000/v3/auth/tokens.

I don't understand where is setted this parameter. i have installed manually magnum project by follow this documentation on centos queens https://docs.openstack.org/magnum/queens/install/install-rdo.html on my overcloud deployed by using tripleo

In the magnum.conf i have specified only public endpoint for uri and url [keystone authentication] section:

[DEFAULT]

transport_url = rabbit://guest:nYBy8MUw2CfAhTRwbwBY2p8sT@internal:5672//

[api]

host = publicip

[barbican_client]

[certificates]

cert_manager_type = local

[cinder]

[cinder_client]

region_name = regionOne

[cluster]

[cluster_heat]

[cluster_template]

[conductor]

[cors]

[database]

connection = mysql+pymysql://magnum:iniziale@internalip/magnum

[docker]

[docker_registry]

[drivers]

[glance_client]

[heat_client]

[keystone_auth]

[keystone_authtoken]

auth_uri = http://public:5000/v3

auth_version = v3

memcached_servers = internal:11211

project_domain_id = default

project_name = service

user_domain_id = default

password = xxxxx

username = magnum

auth_url = http://publicip:5000

auth_type = password

admin_user = magnum

admin_password = xxxxx

admin_tenant_name = service

[magnum_client]

[matchmaker_redis]

[neutron_client]

[nova_client]

[oslo_concurrency]

lock_path = /var/lib/magnum/tmp

[oslo_messaging_amqp]

[oslo_messaging_kafka]

[oslo_messaging_notifications]

driver = messagingv2

[oslo_messaging_rabbit]

[oslo_messaging_zmq]

[oslo_policy]

[profiler]

[quotas]

[trust]

trustee_domain_name = magnum

trustee_domain_admin_name = magnum_domain_admin

trustee_domain_admin_password = xxxxx

trustee_keystone_interface = public

[x509]

can anyone help me please?

Software Deployment in Heat: Problem with os-collect-config

HI all, I have a problem with the coe cluster deploy k8s creation. On the master node on k8s i have this error:

Authorization

 ***Authorization failed: Unable to establish connection to http://172.24.xx.xxx:5000/v3/auth/tokens 
Mar 21 13:47:11 k8s-gdbdfoalflcp-master-0 runc[2256]: Source [heat] Unavailable.
Mar 21 13:47:11 k8s-gdbdfoalflcp-master-0 runc[2256]: /var/lib/os-collect-config/local-data not found. Skipping

Skipping***

Seems that the master node want to connect the internal url reported http://172.24.xx.xxx:5000/v3/auth/tokens.

I don't understand where is setted this parameter. i have installed manually magnum project by follow this documentation on centos queens https://docs.openstack.org/magnum/queens/install/install-rdo.html on my overcloud deployed by using tripleo

In the magnum.conf i have specified only public endpoint for uri and url [keystone authentication] section:

[DEFAULT]

[DEFAULT]

transport_url = rabbit://guest:nYBy8MUw2CfAhTRwbwBY2p8sT@internal:5672//

[api]

rabbit://guest:nYBy8MUw2CfAhTRwbwBY2p8sT@internal:5672// [api] host = publicip

[barbican_client]

[certificates]

publicip [barbican_client] [certificates] cert_manager_type = local

[cinder]

[cinder_client]

local [cinder] [cinder_client] region_name = regionOne

[cluster]

[cluster_heat]

[cluster_template]

[conductor]

[cors]

[database]

regionOne [cluster] [cluster_heat] [cluster_template] [conductor] [cors] [database] connection = mysql+pymysql://magnum:iniziale@internalip/magnum

[docker]

[docker_registry]

[drivers]

[glance_client]

[heat_client]

[keystone_auth]

[keystone_authtoken]

mysql+pymysql://magnum:iniziale@internalip/magnum [docker] [docker_registry] [drivers] [glance_client] [heat_client] [keystone_auth] [keystone_authtoken] auth_uri = http://public:5000/v3

http://public:5000/v3 auth_version = v3

v3 memcached_servers = internal:11211

internal:11211 project_domain_id = default

default project_name = service

service user_domain_id = default

default password = xxxxx

xxxxx username = magnum

magnum auth_url = http://publicip:5000

http://publicip:5000 auth_type = password

password admin_user = magnum

magnum admin_password = xxxxx

xxxxx admin_tenant_name = service

[magnum_client]

[matchmaker_redis]

[neutron_client]

[nova_client]

[oslo_concurrency]

service [magnum_client] [matchmaker_redis] [neutron_client] [nova_client] [oslo_concurrency] lock_path = /var/lib/magnum/tmp

[oslo_messaging_amqp]

[oslo_messaging_kafka]

[oslo_messaging_notifications]

/var/lib/magnum/tmp [oslo_messaging_amqp] [oslo_messaging_kafka] [oslo_messaging_notifications] driver = messagingv2

[oslo_messaging_rabbit]

[oslo_messaging_zmq]

[oslo_policy]

[profiler]

[quotas]

[trust]

messagingv2 [oslo_messaging_rabbit] [oslo_messaging_zmq] [oslo_policy] [profiler] [quotas] [trust] trustee_domain_name = magnum

magnum trustee_domain_admin_name = magnum_domain_admin

magnum_domain_admin trustee_domain_admin_password = xxxxx

xxxxx trustee_keystone_interface = public

[x509]

public [x509]

can anyone help me please?