Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

nova-api did not start

Dear community, since days I try to install devstack and run into several issues. So far I tried both: Ubuntu 16.04 LTS (minimal) and Ubuntu 18.04 LTS. I run this as a VM in an ESX Server (ESXi-6.5.0-2017010400).

The first error which in all cases happens is the following one:

Waiting for nova-api to start...
+lib/nova:start_nova_api:884               wait_for_service 60 http://10.10.0.47/compute/v2.1/
+functions:wait_for_service:427            local timeout=60
+functions:wait_for_service:428            local url=http://10.10.0.47/compute/v2.1/
+functions:wait_for_service:429            local rval=0
+functions:wait_for_service:430            time_start wait_for_service
+functions-common:time_start:2303          local name=wait_for_service
+functions-common:time_start:2304          local start_time=
+functions-common:time_start:2305          [[ -n '' ]]
++functions-common:time_start:2308          date +%s%3N
+functions-common:time_start:2308          _TIME_START[$name]=1551235486702
+functions:wait_for_service:431            timeout 60 bash -x
++::                                        curl -g -k --noproxy '*' -s -o /dev/null -w '%{http_code}' http://10.10.0.47/compute/v2.1/
+functions:wait_for_service:431            rval=124
+functions:wait_for_service:436            time_stop wait_for_service
+functions-common:time_stop:2317           local name
+functions-common:time_stop:2318           local end_time
+functions-common:time_stop:2319           local elapsed_time
+functions-common:time_stop:2320           local total
+functions-common:time_stop:2321           local start_time
+functions-common:time_stop:2323           name=wait_for_service
+functions-common:time_stop:2324           start_time=1551235486702
+functions-common:time_stop:2326           [[ -z 1551235486702 ]]
++functions-common:time_stop:2329           date +%s%3N
+functions-common:time_stop:2329           end_time=1551235547383
+functions-common:time_stop:2330           elapsed_time=60681
+functions-common:time_stop:2331           total=40574
+functions-common:time_stop:2333           _TIME_START[$name]=
+functions-common:time_stop:2334           _TIME_TOTAL[$name]=101255
+functions:wait_for_service:437            return 124
+lib/nova:start_nova_api:885               die 885 'nova-api did not start'
+functions-common:die:195                  local exitcode=0
+functions-common:die:196                  set +o xtrace
[Call Trace]
./stack.sh:1294:start_nova_api
/opt/stack/devstack/lib/nova:885:die
[ERROR] /opt/stack/devstack/lib/nova:885 nova-api did not start
Error on exit
World dumping... see /opt/stack/logs/worlddump-2019-02-27-024553.txt for details

On the first view this looks like a timeout issue, but if I manually run:

curl -g -k --noproxy '*' -s -o /dev/null -w '%{http_code}' http://10.10.0.47/compute/v2.1/

Then I get a 401 (not authorized) as a response. Searching for others which ran into similar issues revealed that usually this is resolved after restarting the system or use unstack.sh / clean.sh and then stack.sh again. Actually this is true and the nova-api error goes away, but then there are other issues and I'm concerned that nova-api is related to this. Maybe I'm wrong.

I would like to address this step by step to get to a clean install. The next issue is that g-api also doesn't start which is extremely odd because before running stack.sh I can execute the test which times out after 60 seconds but if I run stack.sh again, then the service is not reachable again. Restarting the system allows me to access it. Extremely odd.

Thank you very much for your help.

PS: Here my local.conf:

[[local|localrc]]
ADMIN_PASSWORD=XXXXXXX
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD