Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

glance-api resource not found

Hi,

I'm having trouble with the glance service, after following the Docs to install glance. https://docs.openstack.org/glance/queens/install/install-debian.html I'm getting the following error when trying to create or list images.

root@controller02:~/# openstack image list
(http://controller02:35357/v3/v2/images): The resource could not be found. (HTTP 404) (Request-ID: req-d4876a12-c82e-40e0-b1af-cdd5df0113f0)

even though glance-api is running and listening on the 9292 port, and keystone on 5000 and 35357

root@controller02:~/# netstat -tnlp
...
tcp        0      0 0.0.0.0:9292            0.0.0.0:*               LISTEN      21727/python2
tcp6       0      0 :::35357                :::*                    LISTEN      11850/apache2
tcp6       0      0 :::5000                 :::*                    LISTEN      11850/apache2
tcp6       0      0 :::5000                 :::*                    LISTEN      11850/apache2
tcp6       0      0 :::5000                 :::*                    LISTEN      11850/apache2
tcp6       0      0 :::5000                 :::*                    LISTEN      11850/apache2

i created the service and the endpoints

root@controller02:~/# openstack service show glance
+-------------+----------------------------------+
| Field       | Value                            |
+-------------+----------------------------------+
| description | OpenStack Image                  |
| enabled     | True                             |
| id          | dd420cc446bd4cd891baf5732460811a |
| name        | glance                           |
| type        | image                            |
+-------------+----------------------------------+

root@controller02:~/# openstack endpoint list
+----------------------------------+-----------+--------------+--------------+---------+-----------+--------------------------+
| ID                               | Region    | Service Name | Service Type | Enabled | Interface | URL                      |
+----------------------------------+-----------+--------------+--------------+---------+-----------+--------------------------+
| 13595f0f483c428eaf4432afbfae9760 | RegionOne | glance       | image        | True    | public    | http://controller02:9292 |
| 2a790d5c7f3b43ff8d0ea3d62a28eced | RegionOne | glance       | image        | True    | internal  | http://controller02:9292 |
| 4e79eaccc12f4855b1b66c7c43d802e9 | RegionOne | glance       | image        | True    | admin     | http://controller02:9292 |
+----------------------------------+-----------+--------------+--------------+---------+-----------+--------------------------+

I'm not sure what's the problem, is it authentication? any help is appreciated. Thanks.